Skip navigation

iPad wifi connection drops - have tried evereything - any other suggestions

39783 Views 89 Replies Latest reply: Dec 27, 2011 12:11 PM by funkyseth RSS
  • Emmbeedee Calculating status...
    After the iPad is turned back on, it will not connect to wifi without a lot of hassle with passwords.


    After a trip where I brought along my iPad and connected to networks along the way, I had the same issue where it started to prompt me for passwords repeatedly each time I restarted the unit.

    Finally I tracked it down to this: the name of my network was the same as the name of other networks I connected to while traveling, so the iPad needed a password each time it restarted. Once I renamed my home network to something unique, I was never prompted again to insert a password.
    iMac, Mac OS X (10.6.5), None
  • newbie forever Calculating status...
    I have the same WiFi issue after upgrading to iOS 4.2. Have tried everything on this thread with no success. I just went to the Apple Store and tried their WiFi on the ipad while waiting for my Genius appointment. No WiFi/iPad problems at the Apple store. They use Airport Extremes just like I do. The main difference is I have my AE's set up for a roaming network and a guest network. Perhaps this is contributing to the issue. Do any of you have a roaming network?

    Also, I have done the following:
    reset network settings -- no success
    reset ipad and restored from itunes - no success
    reset the ipad and reinstalled all settings and data manually - no success
    for each of the above attempts, I also reset the AE routers - no success

    Still searching for a solution. Will follow up based on the Genius diagnosis.
    Mac OS X (10.6.3), Mac Pro Quad Core 2009
  • NZNormski Calculating status...
    This happens to me but only after I launch Airplay to apple tv.
  • jtgeme Calculating status...
    I just received a 64GB Wifi+3g Ipad for my birthday and the disconnects are tiresome. I have only had the ipad for a two days. I have no taken it out of the house yet, so I am not sure if the wifi problem occurs on any other network.

    I have Comcast internet and I am renting my router from them. its an SMC WBR145-n4. I have yet to do the firmware update (version installed is from Dec 2009 - I think the update is from October 2010). Hopefully this will fix it.

    I will post an update. But I found this interesting as well and I am not sure if its related or an indication of something else happening.

    I have an Airport Express installed and connected to the wireless as well. Generally, it is steady, green light, but once in awhile (1 - 2 times per hour) it blinks orange for a few seconds, then back to steady green. Basically, it is disconnecting and reconnecting to the wireless - now it appears the Ipad has a similar problem, except it is not re-connecting.

    I know the problem with the aiport does not belong in this thread - I am not looking for support on it because its not a functional problem - but I am thinking the two problems are related - maybe fixing one will fix the other.
    MacBook, iOS 4
  • DyreLogan Calculating status...
    Join the club. This 800 paperweight is constantly dropping connection on me and every other wifi gadget of mine works great, even my ipod touch which I updated to 4.2. I feel like I was robbed, I really do.
    HP, Windows 7, WIndows 80%, Apple 20%... I will stick with Windows.
  • jtgeme Level 1 Level 1 (0 points)
    Update:

    I ran the firmware update for the SMC router. The router says it was completed sucessfully but my problems with my Ipad continue - the airport issue seems to be resolved with the firmware update.

    I am trying the solutions in the posts and links, but still having problems. I have switched the router to "G only". It was originally 11 g/n mixed, I then tried 11 n only and the ipad would not connect at all.

    I thought the Ipad worked on N. Does it?
    MacBook, iphone, ipad, ipod, etc., Mac OS X (10.6.5)
  • JimHdk Level 7 Level 7 (21,750 points)
    Yes, the iPad works on 802.11n.
    IPad 64GB, iPhone OS 3.1.3
  • jtgeme Level 1 Level 1 (0 points)
    what's even more aggravating is my wife's Ipad (bought same day / time as mine) connects fine and does not drop wifi, even after "sleeping".

    I was troubleshooting from mine thinking that her's would react the same way, but I just tested hers and it connects and runs flawlessly.
    MacBook, iOS 4
  • Frogroast Calculating status...
    Don't post your serial number here, but can you check your serial numbers and FCC IDs to see if they're the same batch or closely related? Considering how many people aren't having this problem, I'm curious if those of us with problems are all on the same batch of ipads.
    iPod 4G 40 Gig, iPad 16gb,, Other OS, Linux, Mac OS, Windows, Android, iOS.
  • Chef Henry Calculating status...
    This problem of random drops after sleep or even when browsing appears to have stopped after I bumped brightness up to about 60% and turned off the 'auto adjust' feature.

    Weird, and somewhat disappointing.
    iPad, iPhone 4, MacBook Pro, iOS 4
  • Leo Jones Calculating status...
    I've a 32gig iPad, had it for 6 months and it ALWAYS looses wifi after going into sleep or power down. I've tried everything that can be found in a lot of user groups including resetting router, adjusting brightness, passing a ripe banana over the screen at 1.2 inches and even swearing at it but to no avail.

    Why will Apple not just bloody admit it and tell us "there is a problem" and they are looking into it instead of leaving us all floundering around trying everything conceivable including which craft.

    Come on Apple - own up!
    iMac11,3 2.93Ghz, Mac OS X (10.6.5), 8gig ram, 2TB HD, 16TB external, iphone, macbook
  • Tomp007 Level 1 Level 1 (10 points)
    Leo,

    When you say you are losing wi-fi do you mean you are seeing something like "Not connected...Connecting" after you resume from standby, and other times?

    In that case, you might not be losing wi-fi itself but instead are losing your DHCP lease. IOS seems to have trouble holding onto a lease for long for some folks.

    You can try changing that wi-fi connection on the iPad to "Static" instead of DHCP

    IP address: 192.168.0.155 (last part can be 0-255 ,choose somewhere in the middle to avoid conflict with dhcp range)
    Subnet mask: 255.255.255.0
    Router: 192.168.0.1
    DNS: 192.168.0.1

    You may need 192.168.1 instead of 192.168.0 in the addresses above, but it's 192.168.0 for most routers.
  • Leo Jones Level 1 Level 1 (0 points)
    Tomp007, sorry late reply, been away. My wi-fi loss is passwords only. I can continue to receive a weak 'free' wi-fi service which is too weak to be of use. When I enter 'Settings' and re-enter the password all is well again with a strong signal. Thank you for the idea of the 'static' connection, I will give that a go tomorrow and let you know.

    I also tried someone else's idea of stopping 'Push' email but that did not work either.
    iMac11,3 i7 2.93Ghz, Mac OS X (10.6.5), 8gig ram, 2TB HD, 16TB external, iphone, macbook
  • jake23410 Calculating status...
    I have read through quite a few of these posts and all are great ideas and some none might have ever thought of; but we need to remember that Apple released it's "new " and "improved" iOS 4.2 which was flawed from the get-go. If anyone has updated their iPad to the latest iOS version, it's not too late. You can revert back to the last iOS and all should be back to normal. 4.2 had A LOT of issues i.e. WiFi, Air Play, Air Print, etc. There is now talk of an iOS 4.3 to fix the 4.2 issues. If you've bought your iPad in the last few weeks then chances are it already has 4.2 in which case you'll need to downgrade it. I have the 3G WiFi iPad bought back in November (iOS 3.2) and have had no issues at all. Obviously I don't have the multitasking and the other features that came with the update, of which some don't work, but I'm staying optimistic.
    iPad, issues with iOS
  • eriktar Calculating status...
    Try this for troubleshooting:
    - Switch to WEP
    - Switch to no encrytion

    If the loss-of-internet problem goes away, that will give you an indication if the problem is related to WPA(2) encryption.

    I had the same problem as the OP. My problem was related to re-keying in WPA(2). If you can set Group key timer to infinity (0 typicaly if it is a numeric value) that should solve the problem.
    iPad wifi, iOS 4

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.