Previous 1 2 3 4 Next 53 Replies Latest reply: Feb 2, 2015 9:06 AM by cdnmommy Go to original post Branched to a new discussion.
  • laurihare Level 1 Level 1 (0 points)

    Yes, Dust-iMac and others...deleting fewer at time (not sure how many) seems to work--but it's only been a few minutes--let's see!  I've been tearing my hair out!  Thanks for the comments on this forum.  And, YES, Apple and/or AT&T REALLY needs to fix this.  (Airplane mode, and remote delete didn't help.)

  • nealtex Level 1 Level 1 (0 points)

    What worked for me:

     

    1. ONLY delete mesages using the Edit button top right of screen.

    2. ONLY delete no more than 4 at a time

    3. When you go to the delete screen, the "Clear All" button will be gray.  Tap somewhere on the iPhone BELOW the four messages you've deleted to get it go solid so you can invoke it, NOT anywhere else.

    4. Make sure the iphone is pointing due East (use your compass app).

    5. Only do this on a cloudy day.

    6. Swear to yourself that you are sick and tired of this run around and are ready to storm an Apple store and demand a replacement phone.

     

    Ok, steps 4-6 are not very scientific, but it is what worked for me after trying everything else on this thread with no success.

  • cameronjones Level 1 Level 1 (0 points)

    Am I the only one for whom this problem has totally been fixed after the 7.1 software update?

     

    Totally fixed....

  • dsooley Level 1 Level 1 (0 points)

    I too appeared to be 'cured' after 7.1. My headset drops all the freaking time now...but the phantom email issue looks to be resolved.

  • aaleencox Level 1 Level 1 (0 points)

    This still is happening to me on my iPhone 5S. My voicemail is full and even messages I've listened to will zombie back to life and remain unread. It's stupid annoying. I've tried everything on this thread.

  • dave_hw Level 1 Level 1 (0 points)

    I tried everything listed, and none worked. Finally I tried something new. I delete the messages, but leave them in my deleted messages folder. When I wake up the next day, I clear the deleted messages from the day before. This has been working perfect. The message are no longer reappearing.

  • HLT1 Level 1 Level 1 (15 points)

    I love that this thread is over four years old, and the bug is still happening. Incredible. Imagine the things Apple could accomplish if they actually paid attention to feedback in the support forums.

  • bbchat2000 Level 1 Level 1 (0 points)

    I oot it to work using the Airplane Mode technique--- Basically, I had to put my phone in Airplane mode...then go to voicemail and the dreaded "CLEAR ALL" button miraculously became enabled...oh well....then of course I clicked it and it worked!....It's a workaround but a simple one....thx for all the threads.....

  • cdnmommy Level 1 Level 1 (0 points)

    So I found my own solution using some of the information gleaned above.

     

    Hubby noticed the issue yesterday on his 5s.  Not being the most tech-savvy, he thought he got a "phone virus" because the deleted email kept coming back -he had tried to delete some junk mail voice mail from an unknown sender.  I checked my own voicemail on my 6 - I had a valid voice mail from a known sender that I could not delete.

     

    All I did was put the phone in airplane mode.  Delete the voicemail.  Go to deleted messages and hit CLEAR ALL.  Put the phone off airplane mode.  Voicemail gone.  Not hard power offs required.

Previous 1 2 3 4 Next