3 Replies Latest reply: Nov 23, 2010 11:05 PM by teecraig
tanmelvyn Level 1 (5 points)
I've set up Google calendar to sync with my iPhone 4 via Exchange.

Thing is, I've several calendars under one Google account.

When I set up my google account via exchange, it now only shows just one calendar. All the other calendars do not appear on my calendar app. It didn't use to be the case with my 3GS, but now with my 4 it is the case.

Can anyone tell me what I did wrong please?

I set up my iPhone 4 through backed-up data on iTunes, have deleted the account and re-created that account in settings. Ensure that all calendar are checked on google, but still no go.

Please help me.

Thanks in advance.

MBP 15"/iMac 24"/iPhone 4/iPhone 3GS/TC2TB/iPad 3G + WiFi, Mac OS X (10.6.4)
  • tanmelvyn Level 1 (5 points)
    Thanks, I've found the solution:

    "Go to http://m.google.com/sync on iphone browser and from there easily navigated to a screen that allowed me to check box each one of the calendars i wanted to see displayed on the exchange app. It worked perfectly with a nice added feature where entries from different calendars are marked with different colored dots."

    From: http://www.google.com/support/forum/p/Calendar/thread?tid=08283fceb939a53b&hl=en
  • codepawn Level 1 (0 points)
    On my iPhone 3GS

    When I load my Calendar it is empty. If I click another view, eg, monthly view and then return to the list view, the calendar entries are displayed properly.

    Also if I go to calendars and change which calendars to use back and forth it fixes it.

    If I leave the app in background mode, it appears fine, as soon as I kill it off from background mode and then restart it, it displays empty again.

    *This is looking and behaving like a bug in the iOS 4.2(?) app backgrounding code to me.*

    Would appreciate help, may not sound like a big deal but its a pain in the arse not to have your calendar list display when you load it. If I wanted to jump through hoops I'd use Windows
  • teecraig Level 1 (0 points)
    I am having the same issue with my calendar that started happening after the iOS 4.0.1 update. When I open the calendar app, I get nothing showing, but after switching views all my events show up. I am, and have always, synced with Google for email, calendar, and contacts. The only app that behaves this way is the calendar. I waited for the next update in hopes that this would be resolved but after updating to iOS 4.2 today, I am still having the problem.