1 5 6 7 8 9 Previous Next 187 Replies Latest reply: Jun 7, 2013 6:42 PM by Rathbone Hall Go to original post
  • 90. Re: New Apple TV loses connection to iTunes 10.0.1
    RogerP1970 Level 1 Level 1 (0 points)

    Like many, I've suffered from this problem since I first got AppleTV2 several months ago. Firmware and iTunes updates have made no difference. However, tonight I found some pattern/evidence and perhaps others more savvy with such things can advise.

     

    My symptoms:

    - more often than not when sitting down to watch something, attempt to connect to PC running iTunes results in spinning wheel of nothingness

    - a restart of iTunes (not AppleTV) solves the problem

     

    PC is running Vista (yes, yes, I know)

     

    Now, tonight I have observed that in the PC system logs (ie Control Panel->Administrative Tools->Event Viewer), EVERY TIME before I have a connection problem, I get the error message

     

    Client application bug: DNSServiceResolve(90BDC2A0D39EB5B0._appletv-v2._tcp.local.) active for over two minutes. This places considerable burden on the network.

     

    (or some slight variation thereof  - the parameter to DNSServiceResolve varies but the error is the same)

     

    After this appears, any attempt to get new content (ie anything not already cached), results in the spinning wheel and eventual loss of connectivity to the PC. An iTunes restart sorts it out

     

    Now, I know enough to go snooping for things but I don't always know what they mean...

     

    I've seen variations of this error mentioned on other threads, e.g. related to Brother printers, but not yet found anything that helps with this. I've tried hardcoding the AppleTV DNS settings to OpenDNS, but no good.

     

    Anyone have any suggestions?

     

    BTW, to clarify, my setup is

    AppleTV -> ethernet -> ethernet hub ->powerline adapter->BT Home Hub v3->wireless to Vista PC.

     

    Hope this helps , and grateful for any suggestions...

     

    RP

  • 91. Re: New Apple TV loses connection to iTunes 10.0.1
    lupunus Level 3 Level 3 (995 points)

    RogerP1970 wrote:


    Client application bug: DNSServiceResolve(90BDC2A0D39EB5B0._appletv-v2._tcp.local.) active for over two minutes.

     

    I've seen variations of this error mentioned on other threads, e.g. related to Brother printers,

    That happen if the service get no response from the mDNS service running on your PC.

     

    You should check the Firewall settings on your system and approve that port 5353 (mdns) and 5354 (mdnsresponder) are open.

    If you had recently updated iTunes, you should also check that there are no double entrys for the related services / ports in the firewall.

     

    Lupunus

  • 92. Re: New Apple TV loses connection to iTunes 10.0.1
    RogerP1970 Level 1 Level 1 (0 points)

    Thanks - just as this came in, I was following this article

     

    http://support.apple.com/kb/TS2235

     

    ..which also indicates a firewall problem

     

    I'd noticed that switching the firewall off solved it, so I 'repaired' the Bonjour installation as per instructions, and that got it listed in the firewall exceptions... and since then no problem

     

    Hopefully that's it!!

  • 93. Re: New Apple TV loses connection to iTunes 10.0.1
    robertfromchowchilla Level 1 Level 1 (0 points)

    KNOBS> Do you read these posts?  This is your answer!!!  Look under FIREWALL!

     

    http://support.apple.com/kb/TS2972

  • 94. Re: New Apple TV loses connection to iTunes 10.0.1
    Mike 2449 Level 1 Level 1 (0 points)

    Turn on apple tv

     

    apple tv settings ..output.720p/60hz

     

    Hold CTRL/Shift while starting I tunes.  (safe mode)

     

    Watch your movies.

  • 95. Re: New Apple TV loses connection to iTunes 10.0.1
    MorrowAll Level 1 Level 1 (0 points)

    I am really very cross, I've just bought Apple tv2 and cannot believe that apple have not fixed this apparently long term major problem! My ATV keeps losing my itunes libraries, this is a fault that is common to lots of people and is documented on forums for years, yet even in brand new ATV's this fundamental fault is still there!!! I am very tempted to return the unit as I feel so let down by Apple and this fault really compromises a really good product. I also can't get my photos to stream in from iPhoto, I wanted all my albums to be accessible but I can only view photos that appear in photostream.

     

    I would be very greatful for any advice on these two difficulties

     

    My iMac's are both running Lion and the ATV2 is using 4.4 latest update.

  • 96. Re: New Apple TV loses connection to iTunes 10.0.1
    RogerP1970 Level 1 Level 1 (0 points)

    Can only suggest you look at the last few posts on this thread and check your firewall settings. Worked for me. I initially didn't think this would be the problem, as the ATV could clearly establish a link to the library and then lost it (I incorrectly thought that if it was a firewall issue, it would not connect at all), but the support article I quoted previously fixed it.

  • 97. Re: New Apple TV loses connection to iTunes 10.0.1
    KjSilversteen Level 1 Level 1 (0 points)

    I've got the same problem with ITV2 losing the connection with iTune library. The only difference is my iTunes version is the latest available,  ver. 10.5.2.11.

    It is strange that Apple doesn't comment more on this problem. When googling "Problems with Apple ITV2 connection" you get alot of hits. Is it a hardware problem that can't be fixed with a SW patch?!?

  • 98. Re: New Apple TV loses connection to iTunes 10.0.1
    russellfromroseville Level 1 Level 1 (0 points)

    I sent feedback to Apple and I will also call them but I find their help desk isn't a "debug" desk. 

     

    I have tried a multiple of different network configurations and they all work for a while and then stop working after an indefinite amount of time.  The only way to get it work once it loses connectivity to the iTunes store or Home Sharing (network and interent connections are still strong when this happens) is to restart the process any number of ways as mentioned in this posting. 

     

    I strongly believe they have a bug in the firmware that is not fault tolerant of a certain type of loss, skip or time-out in connectivity and the only way around it is to restart the process until the bug rears its ugly head.  I have tried to isolate the what type of loss creates the non-recoverable timeout but I'm not deep enough into networking nor do I have access to the code to understand what puts it into a non-recoverable state.  Does anybody here have access to one of the product development managers that can explain the problem in an inteligible way to the aTV engineers?  Does the aTV team have the resources to test the product in real world conditions (various homes, isp, router combinations) as opposed to their development and QA offices.  I'm sure they must test it in a lot of real (non-manufactured or non-virtual) environments.

     

    None of my friends have had these problems with Roku... nor does my XBOX 360 have these kinds of problems when connecting and streaming from various accounts.  Come on... somebody from the aTV team needs to take this seriously or stop producing this product if all of the energy is being placed into the new Apple TV.

  • 99. Re: New Apple TV loses connection to iTunes 10.0.1
    fvspeilb Level 1 Level 1 (0 points)

    I have had this problem for 2 months; after 10-15 minutes streaming, the ATV disconnects from iTunes, and I have to restart the ATV, only to lose connection again 10 minutes later. I tried every suggestion from this and other fora. Deactivated firewalls, used cabled connection, opened ports, even changed the ATV box, with no success.

     

    My problem was the router - a relatively new Zyxel P2812 Multimodem! For some reason, the predefined SSID had a bug causing the problem, and the solution is very easy; redefine one ESSID and use this:

     

    - Log on to the router

    (Default Username: Admin; Default password: same as the predefined WLAN password)

    - Network settings

    - Wireless

    - More AP

    - Modify one of the ESSID's

    - Enable wireless LAN

    - Give a new name to the ESSID

    - Pull the security slider to the right and define the WLAN password for this ESSID

    - Apply

     

    Then, on your ATV, connect to this new SSID.

  • 100. Re: New Apple TV loses connection to iTunes 10.0.1
    Sixerbuddy Level 1 Level 1 (0 points)

    Not cool @robertfromchowchilla. About to check your firewall link, which may be helpful though.

  • 101. Re: New Apple TV loses connection to iTunes 10.0.1
    Troels Kolding Level 1 Level 1 (30 points)

    Just adding to "problems list" my ATV3 with iTunes 10.6 (40) on Mac OSX 10.7.3. I have to restart iTunes every 1-2 hours as my ATV3 just loses the connection and scans forever. In my case this is no firewall issue. I tried both wireless .n and 1000 Mbps cable connectivity, same issue. Other services work without problems on my LAN (including Airplay which is very stable). Now I know why I liked the ATV1 so much with its built-in hard drive. Should not be necessary to explain my daughters that they have to go to the mac, login to my account in order to restart iTunes to be able to watch their movies on the TV....

  • 102. Re: New Apple TV loses connection to iTunes 10.0.1
    SoundForSound Level 1 Level 1 (15 points)

    I'm seeing this behavior as well after 12 hours or so.  Restarting iTunes always fixes the issue.  For some reason after about a day apple tv just will not connect to the computer.  Restart iTunes and it instantly connects.

     

    Not too sure if my issues started with the new iTunes version or the new apple tv SW.  Either way I hope they fix this soon.

  • 103. Re: New Apple TV loses connection to iTunes 10.0.1
    Hingerson Level 1 Level 1 (0 points)

    I don't understand I bought an Apple tv 3 and it loses connection to the iTunes store after maybe 5 minutes every time, I even returned it today and got another and it does the same thing. Which ***** because I really like the lay out Much better to me then Roku also I have an iPhone so would prefer to rent and purchase from iTunes. any fixes for this?? Only thing that works is resetting it but again only for 5 minutes not enough to do anyhing...

  • 104. Re: New Apple TV loses connection to iTunes 10.0.1
    RDGNL Level 1 Level 1 (0 points)

    I too suffer from the disconnecting problem. The PC simply loses the home sharing to all iOS devices after a few minutes of playback. I find that using the iPhone remote and enabling playback over Airplay to the Apple TV does work, however. So if you need a temporary solution, simply use the Remote app to start playback on your PC, and then enable AirPlay to the ATV. That is stable for me.

1 5 6 7 8 9 Previous Next