Previous 1 2 3 Next 31 Replies Latest reply: Apr 14, 2016 7:09 AM by Tyler1990561
skatalite13 Level 1 Level 1
Hey all. I've got two micro SD cards and a normal SD card that I've been able to read/write on with no problems... Until tonight. Now, I can only read them.

My SD card is the one I use in my digital camera. When I plug it right into my MacBook Pro's SD card slot, I can't delete items from it via Finder or Disk Utility. I also cannot delete images from it through iPhoto.

However, if I hook the camera up to the laptop using a USB cable, I can delete the images through iPhoto.

All three cards are Fat16 which, I assume, has always been the case. I've never had a problem until now. I've even tried formatting the cards in the digital camera, but it hasn't changed anything.

When I look at the cards through Disk Utility, I can only Verify the discs and nothing else.

None of the cards are locked. I'm using an SD card adapter to load up the micro SD cards.

What could the issue be? I'm hoping to try a USB micro SD adapter tomorrow, to see if the issue could be my SD card slot. Any information would be appreciated.


Message was edited by: skatalite13

MacBook Pro, Mac OS X (10.6.4)
  • sig Level 8 Level 8
    Look at your card. There is a small slide lever on the left side. If that is in the down position your card is locked and will only read.
  • skatalite13 Level 1 Level 1
    You missed the part of my post that reads, *"None of the cards are locked."*

    However, I have found a solution, and it seems the problem is the SD card slot itself.

    On all the SD cards, if I keep the lock slider in between Locked and Unlocked, the computer will see it as read/write. If it's fully at unlocked, it'll be read only.

    Locked ___:-:___ Unlocked

    Kinda odd. But upon searching deeper, I'm not the only one with this issue. I'll call Apple and have them fix it.

    Message was edited by: skatalite13
  • sig Level 8 Level 8
    "You missed the part of my post that reads, "None of the cards are locked.""

    It was late.
  • ottonomy Level 1 Level 1
    skatalite13, have you found an permanent/satisfying resolution to this issue? I'm having the same problem now with both my MacBook and my iMac.
  • gigajosh Level 1 Level 1
    Unbelievable.. I don't have a built-in SD slot, but this turned out to be the same problem for me.. more or less.
    Only difference is I had my SD card in a USB SD card reader.

    The SD card was:
    - read-only with the SD card switch locked (duh!)
    - read-only with the SD card switch unlocked
    - unrecognised by my Mac with the SD card switch half-way
    - read/write (TADA!) with the SD card switch nudged a micrometer towards the unlocked position

    So I guess some SD card reading hardware is just dodgy and you gotta try different positions of the card's locked/unlocked switch if it's telling you it's read-only!
  • Dan Kurtz Level 1 Level 1
    This worked for me too, on my MacBook Pro. Crazy.
  • Markus M. Level 1 Level 1
    Hardware fault in the reader.
    I had the same problem.
    Fiddling with the little metal switch inside the reader with a needle a little fixed it.
  • miketech1 Level 1 Level 1
    What worked for me is moving the switch to lock on the sd card, putting it in my reader, ejecting it, moving the switch back to unlock, putting it in the reader. After I did that I had read/write access again. This was on a 2010 macbook pro i7 15 with the internal reader.
  • Emagdnimanitsol Level 1 Level 1

    Tried what Mike said and it worked. Have no idea why but thanks! This was on a late 2009 Macbook Pro 2.8GHz with 10.6.7.

  • Emagdnimanitsol Level 1 Level 1

    After ejecting it and putting it back in.. wen't back to read only. Unbelievable.

  • Emagdnimanitsol Level 1 Level 1

    I'll be calling AppleCare sometime this week. I have two SD cards, Sandisk 2GB, one's black and one is blue.


    The blue one will work with the switch in the middle, the black won't. The blue one worked with the switch in the middle through 5 ejects, then with the switch in unlocked worked, but after ejecting and remounting it was locked again.


    The cards both work no problem in my parent's HP desktops built in reader. This laptop is "old" by industry standards but it was $$$$$ and I just bought an iPad a couple weeks ago. I feel like I own a Xoom =(

  • jhamal242 Level 1 Level 1

    Weirdest thing ever. Put my sd card lock switch between lock and unlock and BANG...



    Thank you skatalite13

  • jeremie_rtw Level 1 Level 1

    I am having a similar but different problem and would appreciate if you guys can chime in on mine..

    I opened a new thread:


    But in my case, all SD cards, both methods of connection tested (via card reader or camera connected to USB) lead to read-only SD card, making me believe there is a problem with my MBP (I have not been able to test on another computer)



  • NURV2600 Level 1 Level 1

    I had the same result; I took a needle and bent the last 0.5mm about 90° and was able to hook it around the back of the metal pressure switch on the left side of the inside of the slot, allowing me to pull it out lightly just a bit. This worked, where compressed air and brushes didn't. Be gentle, and turn off the machine while you do this, just in case you accidentally cross the "reading/power" contacts inside there!

Previous 1 2 3 Next