12 Replies Latest reply: Jan 24, 2013 4:32 PM by JoeR_AUS
Pentalog Level 1 (0 points)
Suddenly the IPCU graphic interface doesn't start up any more. The process ipcu.exe appears briefly in the process list and then disappears.
OS: Windows XP Pro with .net 3.5 and all the updates
IPCU: latest version,
From ipcu.log:
[2010-10-19 16:11:41.5622 iPCU] Debug: Loading Apple Application Support from 'C:\Program Files\Common Files\Apple\Apple Application Support\'
[2010-10-19 16:11:41.5935 iPCU] Debug: Loading Apple Mobile Device Support from 'C:\Program Files\Common Files\Apple\Mobile Device Support\'
[2010-10-19 16:11:49.8278 iPCU] Error: Exception from OnStartupInitial: Object already exists.

[2010-10-19 16:11:55.2185 iPCU] Debug: Saving :<profile name and random letters>

I have tried reinstalling the application but it didn't helped. Any ideas?

Dell laptop, Windows XP Pro
  • perelo Level 1 (0 points)
    I've got the same problem. When I try to start ipcu.exe the following message appear:
    Unable to find procedure start address kFCHTTPVersion1_1 in the DLL-file CFNetwork.dll

    My system specs:
    Windows 7 Pro 32-bit

    //Per E, Sweden
  • himba Level 1 (0 points)

    i have same troubles with ipcu here,
    i had to update iTunes to install the newest ios to a few ipads and
    now ipcu wont start anymore.

    i reinstalled iTunes & iPcu ... still have the kFCHTTPVersion1_1 error.

    is the iPcu incompatible with the newest iTunes ?

    greets out of africa
  • perelo Level 1 (0 points)
    I've resolved my problem with cfnetwork.dll and IPCU.

    Another software (CA Unicenter Agent) on my machine registered it's own cfnetwork.dll. After I unistalled that software my IPCU was fully functioning again.
    Search for cfnetwork.dll and see if there's more than one cfnetwork.dll on your computer.

    /Per, Sweden
  • laurinl Level 1 (0 points)


    I am experiencing the same issue as pentalog.  I also have XP and have updated .NET and reloaded the IPCU.  Has anyone figured out how to resolve this issue?

  • pete_b_k Level 1 (0 points)


    I have exactly the same error message using iPCU v3.3 on my work laptop running Win XP SP3 (plus .Net 3.5 and all patches). iPCU used to work on this laptop as I configured it to access my work email using ActiveSync but when I recently upgrade my iPhone4 to IOS4.3.3 I was unable to launch iPCU. Having found the log file I can now see that it actually stopped working several months ago as the 'Object already exists' message was already present.

    Searching around I found what I think is the iPCU user and device config files in the following locations;


    C:\Documents and Settings\'username'\Local Settings\Application Data\Apple Computer\MobileDevice\Configuration Profiles


    C:\Documents and Settings\'username'\Local Settings\Application Data\Apple Computer\MobileDevice\Devices


    I've removed the files but still have the same error when starting iPCU. If anyone has any pointers as to what the 'Object' is or any other fix then I'd be grateful for the assistance



    I did install iPCU 3.3 on my personal laptop running Win 7. It works fine and lets me configure my iPhone, but I can't install the necessary Security Certificate to allow ActiveSync to connect to the Exchange server as the Root CA is within work's corporate LAN and I can't connect my personal kit into the corporate LAN. I have tried exporting the Certificates for Root CA and the Intermidate CA's but it still doesn't accept it.

  • sellmic Level 1 (0 points)

    perelo's fix is OK, but you don't have to uninstall your other software. The problem has to do with the SYSTEM PATH in Windows. You can fix this problem by making sure iTunes (which might have the newer version of the DLL) is first in the path.


    I put the details to fix this on my blog;


  • pete_b_k Level 1 (0 points)

    Hi, I've just tried applying sellmic's suggestion but it hasn't cured my problem, as I only had one copy of the cfnetwork.dll which was in the expected Apple folder  - but thanks to sellmic anyway.


    I've still got the following error message in the ipcu.log file


    [2011-05-20 21:12:49.1406 iPCU] Debug: Loading Apple Application Support from 'C:\Program Files\Common Files\Apple\Apple Application Support\'
    [2011-05-20 21:12:49.1718 iPCU] Debug: Loading Apple Mobile Device Support from 'C:\Program Files\Common Files\Apple\Mobile Device Support\'
    [2011-05-20 21:12:50.6250 iPCU] Error: Exception from OnStartupInitial:  Object already exists.


    SInce my last post I have tried numerous things to no avail

    • Deleted IPCU via Control Panel and then manually removed any remaining files from anywhere I could find them
    • Checked the Windows Registry for anything to do with IPCU - nothing obvious jumped out
    • Tried removing the Security Certificate that is assoicated with the ActiveSync configuration - no change
    • Removed iTunes - IPCU still gives the same error


    If anyone has more suggestions I can try then I would be most grateful for the assistance. Thanks

  • CSDS Level 1 (0 points)

    I am getting the exact same problem with no other errors. I recently updated iTunes to 10.3 and think there might be some connection. I checked in the log and have the exact same readout. Were you able to find a solution to this? Several of the other solutions are for similar, but different issues and do not resolve this.

  • Moustafa_cz Level 1 (0 points)

    Hi Guys,

    I have checked behavior of IPCU.exe starting and find that the problem is with writing the "Object" which is RSA key to C:\Documents and Settings\Administrator\Data aplikací\Microsoft\Crypto . The RSA key is built by another program. The solution is just delete whole Crypto folder. Then IPCU.exe can build new RSA key ("Object") ;-)

  • dnevans Level 1 (0 points)

    Same problem - Moustafa_cz's recommendation worked. I deleted the

    C:\Documents and Settings\%username%\Application Data\Microsoft\Crypto\RSA directory & was then able to successfully launch iPCU.

  • rsborges Level 1 (0 points)

    Same problem and none of the suggestions above worked. Any clue? I'm using:


    Configuration Utility 3.5

    Windows 7 SP1 64bits

    Only one "cfnetwork.dll" found on the system

    .NET Framework 4

  • JoeR_AUS Level 1 (0 points)

    For XP, I found the CFNetwork.dll in the C:\Program Files\Common Files\Apple\Apple Application Support folder.


    I had CA product installed, uses its own CFNetwork.dll, also and the system path only had a path to the CA folder.


    The Soultion that worked for me was to copy the Apple version of the file to the:


    C:\Program Files\iPhone Configuration Utility