5 Replies Latest reply: Jan 15, 2011 1:24 AM by NotSoCleverOne
CFS88 Level 1 Level 1 (0 points)
I think, or rather know, this is pretty simple. I know because I was told how to replace or get rid of system preferences by an Apple tech when I first bought this Mac Pro (09 Quad). Alas, I didn't write it down at the time as I was in panic mode in general confronted with a new Mac and as a new Mac user.

Specifically, the locks won't stick in any of the system preferences, which was the problem before. When I lock preferences they don't stay that way. Next time I check them they're all unlocked.

The tech had me go in and delete a file or folder I seem to recall is located somewhere in the System Library and then restart, at which point I seem to recall the system created a new System Preferences file or folder that then worked properly. I might be leaving out a couple details I can't recall. I just can't recall specifically enough and don't want to make a mess experimenting based on faulty memory.

Can anyone help with this? Thanks very much,

Mac Pro, Mac OS X (10.6.3), Replacing system preferences folder or file
  • 1. Re: Resetting System Preferences
    macjack Level 9 Level 9 (50,510 points)
    Create a new User go to System Preferences > Accounts > "+" (make it an admin acct) and test System Preferences in this new account, if they work the problem is isolated to your User and not systemwide.

    If the corruption is in your account only try this...

    Go delete these files
    Users/yourname/Library/Preferences /com.apple.systempreferences.plist
    /Users/YourUserName/Library/Preferences/com.apple.desktop.plist



    -mj
  • 2. Re: Resetting System Preferences
    CFS88 Level 1 Level 1 (0 points)
    First, thanks, Macjack, for help and very sorry to be so late getting back here. I did as you instructed--created a new admin account and then set a couple things in Sys Preferences and made sure to lock changes.

    When I logged out and back in, settings were still locked. When I restarted, however, settings reverted to unlocked. That's been the ongoing problem.

    So the problem is system wide?
  • 3. Re: Resetting System Preferences
    Martin Pace Level 5 Level 5 (5,090 points)
    In the Security preference pane, General tab, do you have 'Require a password to unlock each System Preferences pane' selected?
  • 4. Re: Resetting System Preferences
    CFS88 Level 1 Level 1 (0 points)
    Ah....DUH! I'm feeling pretty stupid.

    No, I did not have that enabled. I probably did previously, but after so many reinstalls of Snow Leopard when I first got my Mac Pro a few months ago, I must have forgotten to reset that preference after the last reinstall.

    That works; problem solved. Thanks so much, Martin, and to macjack too, as I wrote down those instructions for later use--just in case.
  • 5. Re: Resetting System Preferences
    NotSoCleverOne Level 1 Level 1 (0 points)
    I have the opposite problem, and it's driving me crazy.

    I +do not+ have the "Require a password to unlock each System Preferences pane" preference checked, and +do not+ want to have to unlock System Preference panes to use them. Yet after each restart, the panes are locked (whether I left them locked or unlocked)!

    I am an administrator. The computers are running Snow Leopard (latest version). I have four computers, two exhibit this behavior, two do not (they work as expected, leaving panes unlocked according to the Security: General preference setting).

    I have upgraded, or migrated these computers from Leopard, and I suspect there is some sort of remanent from the previous OS that is causing this beharior, but resetting permissions has not solved the problem. Nor has replacing System Preferences preference files. This security setting must be buried deep, as I expect it would be, and I cannot find the stubborn file where it is stored that seems to defy and ignore the "Require a password to unlock each System Preferences pane" setting.

    Ideas?