Skip navigation

MacBook Pro will not remember my wireless network after sleep

50926 Views 53 Replies Latest reply: Feb 13, 2014 4:03 PM by chressaapple RSS
  • jameski Calculating status...
    Any more suggestions folks - I am having same problem. My 17" Macbook Pro wont remember my WPA2 Personal network, but my Partners white macbook with exactly same OS will.
    MacbookPro 2009 unibody, Mac OS X (10.6.6)
  • tman_apple Calculating status...
    I was having similar issues with my MacBook Pro. What worked for me was to uninstall Parallels. Parallels kept messing with the NAT settings and network routing. Unfortunately I am not knowledgeable enough with network routing to configure Parallels or other virtual machines' network routes to work around this. So I simply chose to remove Parallels. Since uninstalling Parallels, my MBP is now able to remember my hidden wireless network. If you have some type of vmware, virtualbox, parallels, etc... I'd make sure they are not taking over your network configs.
    MacBook Pro, Mac OS X (10.5.8)
  • heyjohne Calculating status...
    I have same problem... close the lid put the computer to sleep open it back up wont see or connect to network. Have to restart computer and yes my pref is set to remember network. This is fricin annoying.
    macbook pro 2.4 GHz core2, Mac OS X (10.6.6)
  • sheeprancher Calculating status...
    Just finished reorder my network location to have my default be the first one in the list.
    Started to wake from sleep with the network fully active. Just finished the big system update last week... then noticed the problem of network appearing to be intact, but not functional after opening the list / wake from sleep. macbook 13" dual processor 10.6.6
    Macbook, Mac OS X (10.6.6)
  • drfrot Level 1 Level 1 (5 points)
    I have just been suffering this same problem out of the blue: whenever I opened my MacBook Air, it would say that none of my preferred networks were available, and then offer me a list of available networks to join... of which the only one was my preferred network. I never had to re-enter my password; all that was required was to click on it and it would connect... it just wouldn't do it automatically.

    Anyway, I tried all the things listed - deleting .plists, deleting all WPA2 remembered networks, Permissions repair, restart... and none of it worked.

    It was the simplest thing that got it working - using the "Set Service Order..." option from the little gear icon underneath the list of my connections. I thought that Airport was at the top of the list, because when nothing else is connected, it automatically moves itself up to the top of that list. But when I went in to "Set Service Order...", it was actually at the bottom, underneath (disconnected) Ethernet + Bluetooth + FireWire.

    A simple thing to overlook, in case you have... and as I say: it's working fine again now.

    G
     20" iMac 2.4GHz Intel Core 2 Duo 4GB RAM, Mac OS X (10.6.6)
  • drfrot Level 1 Level 1 (5 points)
    Ha! Ignore that post. I spoke too soon. It worked for me once and now I'm back to square one each time I open the laptop from sleep.

    Problem still exactly as described, with no obvious (or unobvious) solution, grrrr...
     20" iMac 2.4GHz Intel Core 2 Duo 4GB RAM ...and a lovely new shiny MacBook Air, Mac OS X (10.6.6)
  • drfrot Level 1 Level 1 (5 points)
    Ok, I got it working.

    I read this: http://macosx.com/forums/networking-compatibility/307423-airport-now-working-sho uld.html and tried that sequence in the bottom post... but it didn't help.

    I then read this: http://osxdaily.com/2009/09/01/how-i-fixed-my-dropping-wireless-airport-connecti on-problem-in-snow-leopard/ and tried a few things that didn't work, until...

    ...turning all security off my (admittedly newish) router fixed the problem. It was previously on WPA2 security, which connected ok, but gave the annoying error where it wouldn't find my preferred network (incidentally, if I had network prefs open and watched what happened as I opened the laptop from sleep, it could find the network, it just couldn't assign an IP address quick enough, and so decided that none were available).

    Since moving/downgrading to WEP security, it all works fine now. I don't know why, but it does. Straight away. Every time. I guess it's quicker than WPA2??

    Still doesn't get to the root of the problem (i.e. how come the other two Macs in the household would connect straight away to WPA2 secured connection, but the laptop wouldn't?)... and I shall watch this thread to see if anyone can in fact come up with a more definitive solution!

    Good luck people.

    G
     20" iMac 2.4GHz Intel Core 2 Duo 4GB RAM ...and a lovely new shiny MacBook Air, Mac OS X (10.6.6)
  • satcomer Level 4 Level 4 (1,105 points)
    drfrot wrote:
    Ok, I got it working.

    I read this: http://macosx.com/forums/networking-compatibility/307423-airport-now-working-sho uld.html and tried that sequence in the bottom post... but it didn't help.


    That last post was mine. I also urge people to log into their router and go through the settings and make sure the router's clock is on the right time and hopefully you can sync the clock to the same time server your Mac uses. Over time i have a lot of people's routers were on the wrong time and causing many wireless connection problem on Macs & PCs.
    MacBook Pro 2.16, Mac Pro Dual 2.8, 14G RAM, 2010 Mac Mini, Mac OS X (10.6.6), iPhone 32 3GS and Time Capsule 2T
  • S.K-L Calculating status...
    Hi-
    I have been living with this problem for the last 9months, and there is a less painful work-around that I have found. If you turn airport off, then back on, it will find your prefered network and connect. I tried reordering the different networks, putting my preferred later in the list from 1st place, but that did not help.
    macbook pro, Mac OS X (10.6.6)
  • mgk42 Calculating status...
    I was having the same problem: on wake my shiny 2011 MBP was not reconnecting to my preferred network. My older MBP does connect to same network. Both are running 10.6.6.

    In my case it affected mulple networks: 2 Airport Extremes and one other. None of the
    following helped:

    + removing all preferred networks and re-adding just one
    + turning the AirPort off and on
    + rebooting
    + muttering curses and scowling

    Combinations of the above did not help either.

    Resetting the PRAM solved the problem for me: http://support.apple.com/kb/ht1379

    Hopefully it will help others as well.

    </mgk>
    MacBookPro 15" 8,2
  • Adios Calculating status...
    It seems that the issue could be solved by resetting the PRAM.

    I had also encountered this issue on my 2010 MBA. My AP cannot be found after MBA's waking up. (AP: WHR-G125, 802.11g, WPA2 PSK AES, hidden).

    It is OK now after I reset the PRAM from the @mgk42's suggestion.
    MacBook Air, Mac OS X (10.6.7)
  • Mario Alessi Calculating status...
    Try deleting the keychains that are associated with that connection. You may have two and its picking and older one.
    2.66ghz 2010 mbp i7, Mac OS X (10.6.6)
  • StephTizio Level 1 Level 1 (5 points)

    This is a part of the larger MacBook Pro connectivity issue. There are several related threads dealing with the MBP's networking problems. If your unit is suffering from this type of difficulty, good luck ... (or a long ethernet cable)

     

    (PS Everybody please make noise on this one so apple comes up with a solution.)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.