Previous 1 2 Next 21 Replies Latest reply: Oct 13, 2015 2:25 AM by pietro.pescatore Go to original post
  • editortom Level 1 (0 points)
    Jan 7th, 2011: Same problem here. MacPro OS 10.5.8 (ie NOT snow leopard, as is the case for some of the other posters on this thread). Out of the blue, lost the ability to edit events in iCal. None of the typical fixes (permissions, preferences, etc) work. This is a bummer. Where is Apple tech support? Love all the new gadgets they're making, but if the existing ones aren't supported, what good are they?
  • shmeck Level 1 (20 points)
    Same issue: suddenly I can't edit events -- edit window doesn't appear unless I hit F10. When I click it after hitting F10, it just vanishes behind iCal. This is a major productivity jam for me, as I use iCal like crazy to schedule.
  • David Patridge Level 1 (0 points)
    All of my trouble went away after I opened Font Book, selected ALL of my fonts, selected "Resolve Duplicates" under the Edit menu. Voila.
  • asmystiq Level 1 (0 points)

    Having a similar problem and doing the Font Book trick did not do it. Once the calendar event is created, I cannot change the start or end dates/times. Can add a note and change the title. Any help on this? Thanks.

  • Colin Mann Level 1 (0 points)

    Having the same problems on my MacPro. I can open my events editing window and edit everything in the event except the title of the event. I have also done everything suggested on this link, to no avail. Even tried trashing all my calendars and creating a new one. Does the same. Yet the same calendar is running on my Macbook with no problem. Could this be an issue unrelated to iCal. Maybe a permissions issue?

  • kwh_tyro Level 1 (0 points)

    mine too! the font book tricked worked, but i had to quit ical and open it back up before the problem went away.  (my edit box was also vanishing behind ical when it had been working fine for years).  so try the fontbook trick, quit ical and open it back up. 

  • pietro.pescatore Level 1 (0 points)

    Workaround ...


    I have this problem since Yosemite. No suggestion helped. No deleting, restarting, ... helped. Some times I can edit, sometimes not. Frustrating! I have found out, that the iCal Edit windows appear but in a region of the screen I cannot reach. My workaround is to: 1) mark the event 2) go to one-day-view 3) edit the event there 4) go back to the desired view. Is it really Apple like to develop "workarounds"?

Previous 1 2 Next