Previous 1 2 3 4 Next 58 Replies Latest reply: Apr 21, 2015 5:48 AM by Lanny Go to original post
  • michaelfromcupar Level 1 (0 points)

    PS Having failed to find a relevant option in Finder's preferences, I tried the same experiment as before, but this time using the system's /tmp directory. First I opened this directory with Finder, and noted the contents.


    When I entered the command line...


    ls > /tmp/temp


    ...the new file ("temp") appeared immediately in the Finder directory.


    Working my way back with Finder to the image directory I was using before, I still don't see the "temp" file I created in that directory earlier.




    I'll have to investigate file and directory permissions, and look at the influence of the length of the path +- the presence of spaces in directory names etc.


    Meanwhile, I can use the "refresh" utility to work around the issue.

  • trmentry Level 1 (0 points)

    I've been having the same issue on my new mini running 10.8.4.  


    I have a USB drive that I'm working on converting some old home videos into MP4.  The program I'm using to do the converstions just puts the new MP4 into the same directory.  But I never see the new MP4s.  If I close Finder window and open it back up.. still not there.


    Installing the Refresh thing mentioned, clicking on it, viola.. files show up. 


    So Finder maybe dynamic... but it doesn't seem to work on USB drive. 

  • milew66 Level 1 (0 points)

    Ahhh nothing quite like Mac one can answer, just ask "why wouod you do that"? who cares? A question was asked. I have the same issue, I have multiple shares that take, sometimes, up to 10 kinutes to populate. This is way to expensive of a piece of equipment to have to wait around forever to see shares.

  • treuersohn Level 1 (0 points)

    I'm having the same problems (mostly with services like Dropbox, but have also had it on my local drive too).  Finder (and it's lacking functionality) is EXACTLY while I'll be switching BACK to Windows.

  • GTGeek88 Level 1 (0 points)

    Yes, VERY frustrating all these "why would you want to do that people."


    My issue is with FTP.  That needs a refresh button, but one of the suggestions (Refresh Finder) does seem to be working with an FTP window, but not until I unhid the toolbar by right-clicking on the top of the window.


    That thing was not working simply because I could find nothing on that page related to this issue. It does not look like a page for this issue at all.


    Also, if you don't use one of the suggestions, you can't even just close the window and reconnect.  It still will not refresh.  You have to use "Eject" from the Finder's File menu.  Only then will you get a refresh.  This whole thing is kind of lame.  An example of how Apple does not listen and how they always put form over function.

  • awasson Level 1 (0 points)

    I'm having the same problem with files not showing up in the finder and also on the desktop but I certainly never had it with Snow Leopard. It's only since I upgraded to Mountain Lion that my finder is no longer dynamic.


    Prior to the upgrade earlier this year, I could drag files or browse files on my local network and files I created on another machine's shared folder would be immediately available. Now, files do not show up unless I force quit the finder. Also if I FTP file over to my desktop, they don't show up until I click my mouse on the desktop. I've got 16Gig RAM and have only used about 1/3 of the hard drive so I doubt it's a memory issue. It seesm that the Finder caches and then doesn't release it.

  • LethalDuck Level 1 (0 points)

    I'm a new mac user (software engineer / architect). Have used (forced due to corporates feeling the need to pay for software) Windows at work, Linux, BSD, Solaris, etc, etc at home and for varius other businesses for years. There are many functionalities available in all of those OS's but missing in OS X. Yes a refresh is a very simple request, but because the source is closed and apple have you by the balls (you've paid them money, surely you can't turn back now?), they can do as they please, or not do as the case may be. To be honest, Linux is at a point and has been for a few years now, that makes it more user friendly for all desk top users. Only reason I bought a mac was because I liked the form factor and hardware features of the macbook pro. In saying that, I think I've learnt my lesson... All that shines is not gold.

  • awasson Level 1 (0 points)

    Yeah, I'm not so sure Linux is ready yet (still) which is why when I left Windows I picked up a Mac.


    I was an early Windows user and I've used windows since about 1992 (I had a monochrom version of Win 2.x back in the day) and I've had Linux on various machines since about 1998 but when I decided to leave WIndows I spent the better part of a year reviewing my workday needs (I'm a software developer). I finally decided to go with OSX. Just like Linux, I can work all day in the terminal but I also found that for me OSX has a superior desktop experience. About 6 months after I switched I realized that on my new desktop I just work. I don't fuss around with my antivirus or mess with the registry or tweaking it for performance, I just use the machine for the reasons I bought it.  


    This need to refresh the finder is a new one for me and the only think I have any problem with. I've been using OSX daily for about 3 years and it was only with the upgrade from OSX 10.6.x to 10.8.x that I've had the finder not show a real time view.


    The Refresh Finder app seems to fix it:  

  • mrcolj Level 1 (0 points)

    Confirmed that the finder not refreshing consistently is still a problem in Mavericks (10.9).

  • MisterNeutron Level 1 (0 points)

    Yup, still not fixed in 10.9. I'm seeing a very simple example of this on a brand-new Macbook Air with 10.9. In Finder, I mark three files, right-click, and choose "Move to trash." Do those files disappear immediately? No! It takes a few seconds for the Finder window to update itself. For a moment, you think the deletion hasn't worked, and try to do it again. Really annoying. Windows Explorer doesn't do this. Ever.

  • babowa Level 7 (29,085 points)

    Really annoying. Windows Explorer doesn't do this. Ever.


    Sorry, not sure I understand: I thought Windows Explorer is a browser? Which is different from the desktop (Finder)? Apologies if Explorer is, in fact, the Finder in Windows.

  • MisterNeutron Level 1 (0 points)

    Oh, dear. Internet Explorer is a browser. Windows Explorer is, in effect, Finder.

  • michaelfromcupar Level 1 (0 points)

    Apologies accepted! Windows Explorer is the file browser - you're thinking of Internet Explorer, which is the web browser.


    I'm still having the same problem now that I've upgraded to 10.9.


    Today I was tidying up by copying a number of files from a temporary folder into appropriate folders, using drag and drop. When I went back to the temporary folder (which I was viewing in Cover Flow mode) I found that the Cover Flow preview was displaying a different file from the one which had been selected in the text window. It was as though the Cover Flow feature was working on the directory as it existed before the drag-and-drop process had removed some of the files, but the directory listing had already been adjusted.


    This is not acceptable behaviour for such a fundamental part of the user interface.

  • babowa Level 7 (29,085 points)

    Thanks for the clarification - as I have never run anything Windows, I didn't know.

  • MisterNeutron Level 1 (0 points)

    You need to get out more.


    Those of us who do some software development have to live with one foot in each world, or at least a toe or two on "the other side."