Previous 1 2 3 4 5 6 Next 253 Replies Latest reply: Apr 26, 2016 3:22 AM by RosieGirlXx Go to original post
  • beaudta Level 1 Level 1

    Go to Settings / Mail

    Choose the mail account with the issue

    Turn mail Off and let it unload for a minute

    Turn mail back On and those unreads should be gone

  • ELN1970 Level 1 Level 1

    This seems to be a brand-aid for one of my users - not a fix. I have a user who continues to have this issue. The band-aid works each time, but it's getting old.

  • cdnogalie30 Level 1 Level 1

    Mine happens on a hotmail account.

  • Mattcheeks Level 1 Level 1

    Worked like a charm. Thanks!

  • fgrossi Level 1 Level 1

    Joey C, you rock.

    This was driving me nuts.

    Thanks so much for posting it.

     

    For the record, this issue popped up on me immediately following an update to IOS 6.1.

  • Kmperham Level 1 Level 1

    OMG! THANK YOU componentgeek! THIS SOLVED MY PROBLEM!!!!! The unread mail badge on my iPhone 5 has been driving me insane. I've killed my exchange email account again and again, a colossal waste of time, but it would clear the badge. Turning the mail off, then back on is SO MUCH SIMPLER! Genius. Thanks! Now, Apple---FIX THE PROBLEM FROM HAPPENING!

  • SchneidMD Level 1 Level 1

    Hey componentgeek,

     

    such a simple solution, but it WORKED on my iPhone 4s.  The email badge is now reset to zero! Thank you for taking the time to post your solution.

  • Rgrossjr Level 1 Level 1

    That did it for me! At first I thought it didn't because the badge did not vanish right away, but after it finished resyncing all the mail a few moments later it fixed it. THANKS!

  • miss zkitty4 Level 1 Level 1

    OMG thanks Joey C... It actually works! Those 10 phatom emails were driving me crazy!

     

    Thanks for the help

  • KMarkoufromSAust Level 1 Level 1

    This has been a saga going on long enough - APPLE - get it fixed

  • Mac idaddy Level 1 Level 1

    Well done Joey C.

    I had the phantom emails on my iphone 4 and your method was spot on an getting rid om my Phantom emails.

     

    Thanks Champ.

  • Laneymv Level 1 Level 1

    Everyone,

     

    This is only a temporary fix.  I've got a bug report filed with Apple.  If more people would report the issue then we probably could get a permanent fix.  They had the same problem in iOS 5 and they sent me a special update.

     

    Report issued here http://radar.apple.com

  • bunny2BEAR Level 1 Level 1

    I went into settings on both my iPhone 5 and iPad and simply turned the Mail option off on the account that was showing the phantom number -- for me it was an exchange account -- (waited for a sec while it turned off the mail sync), then, before turning it back on, I went to that specific inbox and the phantom number disappeared.  Then I went back into my settings and turned it back on.  After I did this (didn't just turn it off and on, but went to the inbox itself) it worked and the phantom number is gone. 

     

    Not sure why, but I feel I can breathe freely again!  It's crazy how this little stuff can drive us mad!!!  Best of luck out there.

  • Trchsngr Level 1 Level 1

    Double tap on your home button to bring up any open apps.  Touch the minus sign on the mail app to close it, then return to your home screen.  Next go to settings on your iphone and touch Mail.  Touch the account that's having the issue to open its email settings.  Swipe Mail to "off" and let the phone cycle through the off process. Once its complete, swipe back to "On".  Your email should be set back to 0.

  • Trchsngr Level 1 Level 1

    This works, but you have to close the mail app in order for it to clear, or the cache will retain the unread email amount.  So before you turn the mail on and off, double click home to pull up any open apps that are in the background.  Touch the minus sign to close the mail app, then go back to home and proceed with the steps mentioned.

Previous 1 2 3 4 5 6 Next