Previous 1 5 6 7 8 9 Next 186 Replies Latest reply: Aug 2, 2015 7:05 AM by Janice Fisher Go to original post
  • Mk Gonda Level 2 Level 2 (370 points)

    Your probably right about that, except Yahoo (really AT&T email) is an IMAP account and if the unread email does not exist in the host server, then how do you go about marking them read on the iPhone....


    For now, I simply have turned the badge app icon off on the problem email account in the Notification Center...

  • Howardsweb Level 1 Level 1 (5 points)

    I had all these problems before with hotmail. It's not an iOS fault imho.

  • M N B Level 1 Level 1 (0 points)

    I've tried marking all read.  Doesn't work.  It doesn't select ALL 8000 messages in that mailbox.  It marks 50, which is what the phone caches (due to the setting).


    Tried force quitting Mail, disabling affected accounts, power down, power up, reenable affected accounts, launch mail.  SOME mail gets fixed.  Not all.


    In fact, after doing that several times, an account that hadn't had problems started having problems.


    Mail is seriously messed up on iOS7.  Its ability to handle simple IMAP and POP3 functions is severely flawed.

  • M N B Level 1 Level 1 (0 points)

    completely deleting the account, force quitting Mail, power cycling the phone, launching mail and readding the account worked.  It should be noted that in the middle of this process, the ALL mail tab showed mail from deleted accounts.


    The IMAP accounts readded cleanly.  Unfortunately, POP doesn't save read/unread state - it's an older, less featured protocol, so I had to manually make the phone mark 2200 emails as read.  Fortunately, of my four accounts I use on the phone (I work on email server software for a living), that account had the least amount of email, the rest were 6k, 8k and more.


    FWIW, I backed up and sync'd before upgrading to iOS7 and all mail was working fine for the year I've had the phone prior to the upgrade.  It should also be note that I know several people that upgraded with no problems, some of them people I work with that probably have just as many emails and accounts as I do (if not more).

  • Mk Gonda Level 2 Level 2 (370 points)

    Interesting data to add.  The problem email account (AT&T/Yahoo mail) is accessed by both myself and my wifie.  It appears that phantom unread email exists when she deletes the message from her BB (yeah I know, its a work phone and she has no choice...).  My unread phantom email was 5 two days ago, up to 13 yesterday and now 14 today - all of those emails were deleted by my wife from her BB...


    The deleted emails by her are in the trash folder and once marked as read or completely deleted, it still shows as unread phantom email on my iPhone.


    To make the matter more odd, my other AT&T/Yahoo account has no problems at all... go figure....

  • Amhvillage Level 1 Level 1 (5 points)

    Try this it worked for my Comcast POP account and might work for your situation. I went into my email setting on IOS7, selected the account I was having problems with, went into advanced setting and under deleted messages selected the "NEVER" option (i belive the default is "after one week". After doing this I found a bunch of undread messages suddenly appearing on my phone. I then used the new feature in IOS 7 to mark them all as read. (while viewing your inbox - select the EDIT link top right, after select the MARK ALL link bottom left, and then the Mark All as READ feature. This was my final fix - GOOD LUCK!!!

  • Izzybelltuckey Level 1 Level 1 (0 points)

    After several hours, I believe I've found the solution to the 1,000's of unread emails showing up in the iPhone badge app from GMAIL after upgrading to iOS7.  Turns out the problem, at least for me, was with Gmail.  Fix is the following:

    1) Go to full site for Gmail on a computer and type in the following in the Gmail search field "is:unread" - without the quotes. 

    2) Then click on drop down arrow under the search field and click on "All". 

    3) Then go to middle of screen and click on "Select all conversations that match this search". 

    4) Then go to the More button under the search field and click on "Mark as read"

    5) You will then receive a warning sign and click OK.


    GMAIL will then process all the mail in your account from the beginning date you set it up and mark everything as read.  When you next log on to your iPhone mail account it will refresh and show no unread emails in your inbox and only when new emails arrive will the count begin again.  Hope this helps.

  • gumdoc2 Level 1 Level 1 (0 points)

    I have had the same problem but with bellsouth and yahoo. It's not just gmail.

  • Syadah Level 1 Level 1 (0 points)

    dear @Izzybelltuckey i hv tried on my yahoo mail and still doesnt work at all, my phantom mail still appear...:(

  • Dr_Wombat Level 1 Level 1 (5 points)

    This happened on my iPhone when I upgraded to iOS7 on my POP account. Three "unread emails" but there weren't any. I did the reset trick; I even trashed all the old emails on the server. Only one thing worked, and it sounds drastic, but it's not. Delete your email account on the iPhone/iPad (having carefully noted all the details), then add it back again. The only thing that got rid of the phantoms once and for all.

  • Mk Gonda Level 2 Level 2 (370 points)

    An Update - its all clear.


    Have no idea what's different but this morning, all the unread email notifications are gone from iPhone.


    I have to believe its either iOS7 did some type of "clean up" overnight or clean up on the host server side.


    Whatever it was, glad its gone.  Sadly, not knowing what caused it or fixed it, it probably can reappear anytime again so it may just be a temporary fix but for now its all good.



  • Syadah Level 1 Level 1 (0 points)

    Dear Dr, I still had the same problem even i try by using your method by deleting and adding again yahoo mail on my iphone..

  • gumdoc2 Level 1 Level 1 (0 points)

    I think I know what the problem is but don't know how to fix it.  This has come up several time before, even on my imac.  In the mail there appears a message that says no sender.  I have been unable to open, read or delete them.  Previously, over time they seem to dissapear and then the count goes to normal.  I have previously been unable to remove them manually, but usually I could see them.  The phantom emails are on my yahoo account.  I can tempoprarly reset the badge bty selecting all as unread and then all as read.  But then the no sender messages repopulate.  I can see them briefly as I search "no sender" and see that they have the unread blue dot next to them (they appear in the seach for 1-2 seconds), but they dissappear quickly and remain hidden.  I can not get them to show up if i access the mail directly via the web. Not sure if those no sender messages are viruses or spam or simply a glitch, but I have seen them occur on several mail servers.  Because they can't be opened they show up as unread, and even if you mark them as read, the server can not open them so they reset to unread!

  • Phil Berquist Level 1 Level 1 (5 points)

    Access the problem email account.  Go to EDIT.  Select all emails and mark as UNREAD.  Return to home screen. You will see on the the app button a huge number (I had 13,505 emails, and only 10,000 showed now as UNREAD.  Return to the problem email account.  Return to EDIT.  Select all email and mark as READ.  Problem solved. 

Previous 1 5 6 7 8 9 Next