Previous 1 3 4 5 6 7 Next 172 Replies Latest reply: Jul 23, 2012 4:33 PM by Lisa Iowa Go to original post
  • Felix Leiter Level 1 Level 1
    Agreed. Could this be the reason why Steve seemed sort of angry throughout the keynote?
  • sonicsoul Level 1 Level 1
    Guys

    I upgraded to iPhoto 11 with a brand new, empty library. I didn't even get asked to upgrade, but iPhoto was stuck in the infinity bounce. Tried cmd+opt and got the upgrade library dialog - after which iPhoto seemed fine.

    Quit iPhoto and relaunched. Stuck in infinity bounce again. Grrr.

    Reinstalled and deleted iPhoto Library (to force a new Library on startup) - nothing. Something is wrong here and I don't think it has to do with what's already in your existing library.
  • tHe sR5 Level 1 Level 1
    I think I solved this issue, I went to my iPhoto_Library file, right clicked "Show Package Contents" Deleted "InterruptedUpdate, ThemeCache, ProjectDBVersion.plist, Projects.db, Projects.db-journal" Restarted iPhoto did the upgrade, Closed and reopened and BAM! works like a charm... Hope this works for everyone else! Small note i was in Safe Mode when i did this.
  • David Schwartzer Level 3 Level 3
    Interesting. This would seem to support the idea that these update issues are in some way connected to the old Keepsakes/Projects that are in the database when iPhoto '11 tries to upgrade the database.

    I suspect that clearing the Keepsakes from the iPhoto '09 database clears the data out of these files which is almost the same as deleting the files themselves.

    I'ld be interested to know if you had Keepsakes in you '09 database and what do they look like in '11 now that theses files are gone.
  • dackman Level 1 Level 1
    I ran iPhoto in safe mode and it solved the problem. Didn't have to do anything else - just loaded it up and it started working.
  • Old Toad Level 10 Level 10
    expertise.photosformac
    Photos for Mac
    Did it continue running OK when you rebooted into normal mode?
  • WillGonz Level 1 Level 1
    Tried Safe Mode Failed.
  • WillGonz Level 1 Level 1
    tHe sR5 solved the issue. Now we need to determine why.
  • Chapin3 Level 1 Level 1
    This worked for me too. Thanks

    Message was edited by: Chapin3
  • Chapin3 Level 1 Level 1
    I mean the sR5 one a few posts up worked for me.

    Message was edited by: Chapin3
  • vaddelfanatic Level 1 Level 1
    Same problem here so I looked into some of my iPhoto libraries. This is what I found out:

    - all libraries that can no longer be opened after upgrading are missing a "Database" folder
    - the old iPhoto '09 datbase is still there: iPhotoMain.db and iPhotoMain.db.bak
    - iPhotoMain.db is quite small .. too small; delete it and make a copy of iPhotoMain.db.bak renaming it to iPhotoMain.db (should be a lot bigger than the old version, depending on the amount of pictures you have)
    - open the library again with iPhoto '11, upgrade again and you should at least get your picture pack
    - it survived rebooting on my machine
  • tHe sR5 Level 1 Level 1
    I did have keepsakes an they were still there after my edits, unfortunately I did not open them but I deleted them! I guess I should have opened them to see what they looked like, I wasnt to concerned with them as they were just test files, I never really used that feature.
  • smaugthewyrm Level 1 Level 1
    yep. ILM has errors out trying to rebuild a non iphoto '11 library. the manager requires that the user 'update' or 'upgrade' the library with iphoto beforehand.

    bummer.
  • bjames008 Level 1 Level 1
    This worked for me as well
  • Art-Art Level 1 Level 1
    Same problems in here.
    Uninstalling DivX solved the thing.
    (DivX was only installed for trial over a year ago, so it wasn't really active. Still this seemed to fix the problem).
Previous 1 3 4 5 6 7 Next