Skip navigation

iPhoto '11 stuck in loop trying to upgrade.

72240 Views 172 Replies Latest reply: Jul 23, 2012 4:33 PM by Lisa Iowa RSS
  • evmeyer Calculating status...
    Currently Being Moderated
    Oct 25, 2010 2:15 AM (in response to WillGonz)
    tHe sR5

    This solution worked also for me. Thanks a lot!
    MacBook Pro, Mac OS X (10.6.4)
  • zyfert Level 3 Level 3 (610 points)
    Currently Being Moderated
    Oct 25, 2010 2:40 AM (in response to tHe sR5)
    tHe sR5 wrote:
    I think I solved this issue, I went to my iPhoto_Library file, right clicked "Show Package Contents" Deleted "InterruptedUpdate, ThemeCache, ProjectDBVersion.plist, Projects.db, Projects.db-journal" Restarted iPhoto did the upgrade, Closed and reopened and BAM! works like a charm... Hope this works for everyone else! Small note i was in Safe Mode when i did this.


    Thank you sir, worked perfectly for me.
    Macbook Macbook Pro iPod Touch 3g (iOS 4.1), Mac OS X (10.6.4)
  • soyabm Calculating status...
    Currently Being Moderated
    Oct 25, 2010 9:29 AM (in response to strick455)
    I had a 160GB iPhoto database file until iPhoto 11 decided to delete the entire db. I have a TimeMachine backup from Sept 9, 2010 and have had 3 events after that date. I have downloaded the Stellar Phoenix for Macintosh and have let it run for 3 days. Finally after looking at what it found, almost none of my pictures showed up. I basically stopped using the computer so that it would not rewrite over the deleted files. Which type of recovery did you try to do? Any suggestions for me?
  • matyas.ka Calculating status...
    Currently Being Moderated
    Oct 25, 2010 11:22 AM (in response to WillGonz)
    I solved this problem in the following way:

    1_ restore iphoto 2009 from TM
    2_ restore iphoto library
    3_ fix/regenerate the library by opening iphoto keeping command+alt pressed (keyboard)
    4_ delete all the "unsupported" cards/books
    4_ put back iphoto 2011
    5_ convert the library

    enjoy...

    In my case it was clearly the old cards causing the culprit.
    Thanks for the data and informations i found in this post.

    Salut!
    MacBook Pro 2,2, Mac OS X (10.6.4)
  • Larry Walsh Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 25, 2010 1:44 PM (in response to WillGonz)
    My 3 days of not getting past the upgrade has come to an end.
    First, I did the following under normal boot, not Safe Mode:
    I restored my iPhoto Library from a Time Machine Back Up to the external hard drive.
    I then launched an old copy of the iPhoto 09 Application holding down the option key to point iPhoto 09 to the restored library. Once I saw that it opened and all my pictures were there, I quit iPhoto 09 and then re-launched it holding down Apple and Option and choose to repair permissions. Once the repair was complete and iPhoto 09 opened I deleted the pictures in the trash (not sure if that mattered) and then quit iPhoto 09.
    Next I launched iPhoto 11 holding down Option, choose the restored library that was still on the external drive and iPhoto 11 asked to Upgrade which took about 15 minutes on 25,000 pictures.
    I have quit and relaunched a few times and have never been asked to re-upgrade as some are experiencing. iPhoto 11 seems to be very snappy and is working quite well.

    I hope this can help others.
    MacBook Pro, Mac OS X (10.6.4), iPhoto 11
  • Wade Maney Level 3 Level 3 (685 points)
    Currently Being Moderated
    Oct 25, 2010 2:16 PM (in response to matyas.ka)
    So did you delete iPhoto 11 before you did all of the above and the "new" iphoto library? Thanks
    Intel iMac (24" Alum), Intel iMac 20" (White), MacBook, Mac OS X (10.5)
  • Larry Walsh Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 25, 2010 4:23 PM (in response to Wade Maney)
    ++So did you delete iPhoto 11 before you did all of the above and the "new" iphoto library? Thanks++

    No, I left iPhoto 11 alone.
    I haven't update iLife on all of my Machines so I simply used a copy of the Application (iPhoto 09) that was on another networked machine that I hadn't updated yet.
    MacBook Pro
  • Tom Ritch Level 1 Level 1 (90 points)
    Currently Being Moderated
    Oct 25, 2010 5:49 PM (in response to WillGonz)
    I installed iPhoto '11 and updated my library with no problem. Then I quit iPhoto. When I re-launched I got the endless spinning spikes. I remained at that stage for several days as I tried the many techniques suggested above.

    What finally worked for me was the suggestion given by vaddelfanatic, to delete iPhotoMain.db, then rename iPhotoMain.db.bak to iPhotoMain.db. When I then relaunched iPhoto, a dialog announced that the library needed to be rebuilt, the rebuild proceeded and everything worked fine. When I started to quit a dialog warned that iPhoto processes (I forget exactly what) were ongoing and should not be interrupted. I waited, and later quit and restarted iPhoto several times with no problem apparent.

    Knowing so many have such diverse issues, I tried to observe more details. Before and after the described rebuild, I compared the package contents of the iPhoto Library being rebuilt with a backup copy which works with iPhoto '09. One large difference is creation of a large "Database" folder in the iPhoto '11 library. Another is reduction of the size of the iPhotoMain.db file, from about 5 MB to 8 KB for my 1,300 photo library.

    My guess is that creation of the new iPhoto '11 database structure is a complex process which is subject to disruption by a number of conflicts, such as from DivX or Keepsake files, or from interruption before its creation is completed. In my case, after my initial attempt at conversion to iPhoto '11 form, my iPhoto Library did not even have any Database folder. Replacement of the greatly reduced iPhotoMain.db file with its backup allowed creation of the Database folder, after which everything seems to work well.

    I hope this helps someone.
    Mac Pro 3,1, Mac OS X (10.6.4), HP Photosmart C6180, Canon SD 950 IS, Canon Vixia HF100
  • rpelfrey Calculating status...
    Currently Being Moderated
    Oct 25, 2010 7:58 PM (in response to Larry Walsh)
    I was having the same issues. I got by it by doing a permissions repair on the HDD, then I uninstalled Divx. Fired iPhoto 11 back up and it did the conversion.
    MacBook and iMac, Mac OS X (10.5.4)
  • donsmith Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 27, 2010 3:58 AM (in response to zyfert)
    Didn't work for me. Just opened differently. All the squares showed up with the custom titles underneath, but the pictures are not there. Can't find a way around this.
    Mac Pro, Mac OS X (10.6.4), Four Macs in Household
  • Henry Carlson Calculating status...
    Currently Being Moderated
    Oct 27, 2010 6:44 AM (in response to matyas.ka)
    **No, no and no. The risks are too great for such manipulations, and you will never be sure that at least (some) of your photos didn't get lost.
    If you can't wait for apple's (official) fix, then check my site: http://iphoto11.wordpress.com/
    The fix is really easy AND safe.
  • PSShaffer Calculating status...
    Currently Being Moderated
    Oct 27, 2010 8:20 AM (in response to Henry Carlson)
    I also ran into problem during my iphoto 11 upgrade. I had several iphoto libraries and the update worked on one of them but on the others I got the message that iPhoto is "unable to open this library". I made numerous attempts to fix (using a restored backup each time) and sometimes got part of the library, but never the whole thing. I finally also thought about using the program batchmod referred to in the wordpress blog above. It worked beautifully for me.
    MacBook Pro, Mac OS X (10.5.6), None
  • Old Toad Level 10 Level 10 (113,105 points)
    Currently Being Moderated
    Oct 27, 2010 11:29 AM (in response to Henry Carlson)
    Not if you backup the library first and then try. You can always go back to the backup copy if it doesn't pan out.

    Your Batchmod method has been suggested previously in other topics and has worked for some and not for others. There just doesn't seem to be a one fix fits all this time around.
    3Ghz iMac, 4G RAM, 1TB HD; MBP 2.16 Ghz 2G RAM; 1.5TB/160GB HDs;, Mac OS X (10.6.4), Canon:i850/8600F, Epson R280; 4G Nano, 30G Video iPod; iPad 3G
  • ticzon Level 1 Level 1 (5 points)
    Currently Being Moderated
    Oct 27, 2010 9:27 PM (in response to WillGonz)
    I finally got my problem solved....

    Turns out that there are some plug ins that are causing problems with the upgrade of the iPhoto library to iPhoto '11. I had the pleasure of meeting an iPhoto engineer (at my house), who took a copy of my 73 GB iPhoto library to Apple to determine why my IPhoto would crash during the library update. (Yes, I gave Apple my personal library). I was selected since I am near the Apple Campus.

    I told the engineer that they are playing with people's lives, because our photos are very important to us. He told me that they are aware of that, and are investigating the problem.

    It turns out an old plug in from the Joe Soft application, called Hear was causing my problem. Even though this was a iTunes enhancement application, it had ties to the movie files (via Quicktime) that are in my iPhoto library.

    Other plug ins that can cause problems are the DIVX plug in and AVI Converter plug ins.

    Once I removed the offending plug in, my library converted within a hour and I was happy to be enjoying the new version of iPhoto. I will keep my old iPhoto 9 Library, just in case if I have a problem. (I am testing importing photos from all of my cameras and iPhtos, just to make sure import works.)

    I was also told that I can do the conversion in "Safe Mode" (hold Shift Key down during startup) if I didn't want to remove the plug ins. However, I needed to know if it was really the plug in, so I did the upgrade in the regular mode with the offending plug in removed.

    I have to say that I had moved a copy of the original iPhoto Library to a stripped computer (has no plug ins) and tried converting it to iPhoto '11, and it converted without any problems Therefore, I know it was a plug in issue.

    I was told that I can move a the converted library to my main computer (that has the plug ins) and should not have any problems running iPhoto. The plug in problem only occurs during the conversion process.

    Regarding the Projects (Books) items, they all converted without any problems. I have open them and verified. All albums are working and all 26,000+ photos are working!

    I have shut down and restarted iPhoto and also shut down and restarted my computer, then launch iPhoto without any problems. I actually think iPhoto '11 loads much faster than iPhoto '09

    A regular fix is in the works.

    Hope this helps.

    Thanks again iPhoto Team!
    MacMini, Mac OS X (10.6.4), 3 Drobo, Own about 35-40 Macs.
  • Skiziks Calculating status...
    Currently Being Moderated
    Oct 28, 2010 7:52 PM (in response to ticzon)
    ticzon,

    Can you be specific about how to find these plug-ins, what and where to look for them?
    We're not all equally computer literate, but we do experience some of the same problems.
    iMac 21.5, Mac OS X (10.6.2), Memory 4 GB

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.