Skip navigation

Safari denying access to web-based email

3825 Views 26 Replies Latest reply: Oct 23, 2010 7:09 PM by andyBall_uk RSS
1 2 Previous Next
PaBRO Level 1 Level 1 (0 points)
Currently Being Moderated
Oct 21, 2010 9:06 AM
Since yesterday, Safari (5.0.2) has denied me access to login to my school's Google Apps web-based email client. When click the link to login, I get a message saying "Message did not meet security requirements." I called my school to inquire, and they said that the server was fine and they did not know what could be the causing the problem. Interestingly enough, I can login using Firefox on my computer, as well as using Safari on another computer. The problem seems to be with Safari on MY computer. Since then, I have:
-Reset Safari (cache, history, cookies, etc.)
-Repaired permissions on my Mac (using both Disk Utility and Onyx).
-Reinstalled Safari (uninstalled using App Cleaner).
-Replaced the preference file.
-Disabled LIttle Snitch's network filter.
Still, I am essentially locked out of logging in the email client. Any ideas?
Any help would be greatly appreciated.

-P.
MacBook Pro 2.2 GHz Intel Core 2 Duo, Mac OS X (10.6.4)
  • andyBall_uk Level 6 Level 6 (17,450 points)
    Currently Being Moderated
    Oct 21, 2010 9:50 AM (in response to PaBRO)
    Hi

    does another User Account on the same mac show the same problems?



    The other Safari was on a mac?
  • andyBall_uk Level 6 Level 6 (17,450 points)
    Currently Being Moderated
    Oct 21, 2010 11:30 AM (in response to PaBRO)
    sure, your choice.

    a new account takes moments to create & almost no drive space (unless you use it & put music & photos inside) & is even quicker to remove.
    It's useful, since there are a whole bunch of preferences & files within an account, which if a new one shows the same problem, we can completely ignore, saving you time.
  • andyBall_uk Level 6 Level 6 (17,450 points)
    Currently Being Moderated
    Oct 21, 2010 12:44 PM (in response to PaBRO)
    Hi

    first thought would have been cookies, since it's browser-based - but you cleared those... I think I might quit Safari & trash Home/Library/Cookies/Cookies.plist anyway, just in case
    also Safari's cache:
    Home/Library/Caches/com.apple.Safari/Cache.db

    and local storage:
    +Home/Library/Safari/LocalStorage/
  • Carolyn Samit Level 10 Level 10 (84,045 points)
    Currently Being Moderated
    Oct 21, 2010 1:04 PM (in response to PaBRO)
    Hi...

    Just in case...

    From your Safari menu bar click Safari / Preferences then select the Advanced tab. Click: *Change Settings* next to: Proxies. That will prompt the System Preferences / Network pane.

    On the left where you see: Select a protocol to configure.

    If any of those boxes are selected, deselect the box. Restart your Mac. Try accessing the email client now.

    If proxies aren't the issue, when you try accessing the site for email, If you see a small gray lock icon top right corner of the Safari window, click on that once. A security certificate will open. It should say that it's valid.

    If not, open Keychain Access (Applications / Utilities). Select My Certificates on the left under Category. Right or control click that certificate then click Get Info. In the next window click the gray disclosure triangle next to: Trust. Click the first pop up menu. Select: Always Trust.

    Relaunch Safari and try logging in to your email client again.









    Carolyn
    27" iMac 3.2GHz Intel Core i3 MBAir iPad iPhone 3GS iLife iWork Pages Keynote, Mac OS X (10.6.4), QTPro Intuos Tablet Epson Olympus Airport JBL
  • Carolyn Samit Level 10 Level 10 (84,045 points)
    Currently Being Moderated
    Oct 21, 2010 1:05 PM (in response to PaBRO)
    Ok... we cross posted. Try my suggestion for the certificate. No guarantee, but it's worth a try.






    27" iMac 3.2GHz Intel Core i3 MBAir iPad iPhone 3GS iLife iWork Pages Keynote, Mac OS X (10.6.4), QTPro Intuos Tablet Epson Olympus Airport JBL
  • andyBall_uk Level 6 Level 6 (17,450 points)
    Currently Being Moderated
    Oct 21, 2010 1:05 PM (in response to PaBRO)
    The whole folder, unless trying to keep some info.

    is it autofilling any info there for you? (look in Safari-Prefs-Autofill & check/delete with the edit buttons)

    any entries for the site in Keychain Access ? (it's in /Applications/Utilities/)

    Is this just a straight-up web access email? - not using any google software on your mac?
  • andyBall_uk Level 6 Level 6 (17,450 points)
    Currently Being Moderated
    Oct 21, 2010 2:03 PM (in response to andyBall_uk)
    You hadn't changed cookies settings to 'from this site only' ?
  • Carolyn Samit Level 10 Level 10 (84,045 points)
    Currently Being Moderated
    Oct 21, 2010 4:04 PM (in response to PaBRO)
    HI,

    Contact the network administrator at your school.







    27" iMac 3.2GHz Intel Core i3 MBAir iPad iPhone 3GS iLife iWork Pages Keynote, Mac OS X (10.6.4), QTPro Intuos Tablet Epson Olympus Airport JBL
  • andyBall_uk Level 6 Level 6 (17,450 points)
    Currently Being Moderated
    Oct 21, 2010 4:13 PM (in response to PaBRO)
    Same exact url - one has the lock, one not - in the two accounts?
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.