14 Replies Latest reply: Jun 13, 2014 4:03 AM by jbmas
jacoelle Level 1 Level 1
This laptop (MacBook Pro, bought it a couple of weeks ago, all of the software is up to date) is the computer in my house running iTunes 10. I decided not to upgrade the others because I have had so many issues with it on this computer and I'd rather not do anything to mess up the others.

Basically, I have this computer authorized to share both of the libraries off of the other computers, but I get no "shared" tab when the libraries are open and should be accessible. They work just fine on the other two computers, and the library from this computer shows up on them. I'm using iTunes 10.0.1 on this computer, the others are running the last version of iTunes 9 from just before Apple came out with 10.

I have tried restarting the computers, restarting iTunes, and uninstalling and re-installing iTunes on this computer and none of it has worked. I also tried looking at the help files because on the drop-down I noticed one titled "If you don't see shared libraries" but the iTunes help box only shows up blank and then gets stuck searching when you try to look something up (which isn't an issue with the help tab when "finder" is selected).

How can I get these libraries to show up? I'd really like to have this work so I can listen to my music in other rooms, but so far I'm having no luck.

MacBook Pro, Mac OS X (10.6.4)
  • Katrina S. Level 7 Level 7
    Can you see the other PCs with just normal file sharing? Without itunes even involved?
    The laptop is connecting wirelessly, I assume?
  • jacoelle Level 1 Level 1
    This is the only file sharing any of them do. All three are Macs, but I'm using the older version of iTunes on the other two- does that make a difference?

    Yes, the laptop connects wirelessly.
  • Katrina S. Level 7 Level 7
    I meant, can you see the other PCs in Finder.
  • Mr Chase Level 1 Level 1
    I am having the same problem on my systems at the school where I work. The Shared Library tab is completely missing from the updated iTunes on the Windows computers that have upgraded. Interestingly, prior to the update the older version of iTunes showed the Shared Library tab and after the upgrade none of them are doing so. I've tried restarting bunches of times. I can't find any way to get the shared library to reappear.
  • Mr Chase Level 1 Level 1
    11/22/10: Update. I have done a thorough delete and reinstall of iTunes twice on the affected Windows computer with no resolution. Here's the confusing thing; the adjacent computer that has not had any additional work, the Shared tab is now back in iTunes. And another nearby computer that didn't have iTunes worked just fine when I installed iTunes for the first time. This is amazingly frustrating since the one computer that doesn't have the Shared tab on the list is the one we use for the primary Audio computer for our school Multi Purpose Room.
  • Mr Chase Level 1 Level 1
    Problem resolved: As I mentioned, the "Shared" tab was completely missing from iTunes after the upgrade to 10.0/10.1. After deleting & reinstalling iTunes several times I deleted PC Doctor and the problem resolved. Apparently it was PC Doctor interfering with iTunes. What was so frustrating is now resolved. I would suggest that anyone having this issue evaluate the influence of Anti-Virus software as a possible cause. I don't have these issues on my Mac, of course.
  • Brutus537 Level 1 Level 1
    Hi everyone, I was experiencing the same problem with the "SHARED" topic not even showing up. I am using PC-cillin. So I decided to turn off the firewall and restart iTunes and The "SHARED" showed up with my two other libraries. I turned the firewall back on and restarted iTunes and everything works as it should.... anyboy's guess as to why, but it worked... Thankd for all the other good information..
  • Jujutu Level 1 Level 1
    I'm also experiencing this, but the last fix didn't work for me.

    I have an Iomega network drive which has an iTunes server on board. The documentation explicitly how to configure this so that you can play content on the drive through iTunes on my Windows PC.

    The trouble is, the network drive does not appear under 'shared' - indeed 'shared' does not appear at all. I am using iTunes 10.2.1.1.

    I don't think this is a PC or firewall issue because Windows Media Player can see the shared drive perfectly well. Any further ideas would be very gratefully received.

    Julian
  • nvnv0 Level 1 Level 1

    itunes library made by newer version of itunes can't be read by older version of itunes

  • darps20 Level 1 Level 1

    I am also having this problem.  multiple wintel PC's. all on 10 with latest updates.  Shared library from the PC with the problem is visible as  shared library, tries to load but doesn't.  uninstalled and reinstalled with no luck. turned of virus programs with no luck.  updated other PC's with no luck.  All PC's visible and shared in other ways, both wireless and hard wired in the home network. Doesn't seem to matter if "sharing" is on or off; or Home Sharing is on or off. Gotta be something in the iTunes application? Any help is appreciated.

  • darps20 Level 1 Level 1

    Solved this problem: The windows firewall was blocking iTunes.  Once I allowed access through the firewall it worked again as expected.

  • BlueyedGl Level 1 Level 1

    I had the same problem. I read elsewhere that "Looking for Shared Libaries" is now on the "General" tab within Preferences, and I did find it there. However, then I still could not see the Shared Library(ies) until both computers were not only "on" but also actively running iTunes. THEN I could see the Shared Library(ies) on the left vertical pane.

     

    By the way, closing iTunes then gives you a warning that another user is connected to your library and the connection will be broken.

  • dtork Level 1 Level 1

    I've had the same problem as all of these people before me, except that I am using a Macbook Pro running OSX 10.7.4 (Lion) and iTunes version 10.6. There is no "Shared" or "Shared Libraries" in the left pane, even though the box is checked in general settings.

     

    I have tried with the firewall completely off, and with it on. I've tried with all the sharing items checked, and I've tried it with all of them unchecked. I've restarted my router. I've restarted iTunes. I've restarted my computer. As I said, I'm using a Mac, so there is no antivirus or firewall software running behind the scenes that I need to tweak. I spent 30 minutes on the phone with Apple support and he was stumped. 

     

    The fact of the matter is that at some point, I unchecked "Shared" in iTunes general preferences because at the time I didn't need it taking up space where all my playlists are, but now I want it back and it won't come back. I believe that this is a non-resolvable issue on my end and that Apple needs to update iTunes with an internal fix. The solution NEEDS to come from Apple.

  • jbmas Level 1 Level 1

    Hi, I'm having the same problem on Mac

    There is no "Shared" or "Shared Libraries" in the left pane, even though the box is checked in general settings.

    Any solutions?