Previous 1 27 28 29 30 31 Next 460 Replies Latest reply: Sep 23, 2013 9:06 AM by Old Toad Go to original post Branched to a new discussion.
  • Terence Devlin Level 10 Level 10 (128,825 points)

    As a Test:



    Hold down the option (or alt) key and launch iPhoto. From the resulting menu select 'Create Library'



    Import a few pics into this new, blank library. Is the Problem repeated there?

  • Craig Jones3 Level 1 Level 1 (5 points)

    As this thread seems to stay alive with odd iPhoto issues, let me share some odd experiences of the past week and see if anybody knows just what evil incarnation was spoken to my Mac...


    I replaced an old iMac which failed with a new one in April (3.2 GHz dual processor) and I am running 10.6.8.  I decided to go ahead and migrate my old iPhoto library to iPhoto '11 (now at 9.1.5 (615)).  I didn't have any of the issues described earlier in the thread; the shift seemed to work fine.  Downloading photos over several months after that led to no obvious problems.


    Then in the past month the wheels fell off the wagon (possibly when I updated to 9.1.5, though I am not certain of this). I did a download, combined a couple of the default day splits and then quit.  When I next opened iPhoto, those photos were gone as were a couple earlier downloads in the previous week; everything older than that was fine.  I tried finding orphaned photos from the rebuild window (command-option at start), no luck.  I tried rebuilding the database and after two days finally killed that process (I tried twice).  During this, I noticed that the thumbnails (distorted) for those missing photos would show up when scrolling through Photos but would immediately be replaced by higher resolution thumbs of other photos.  I tried rebuilding using iPhoto Library Manager, and the photos still were missing. The odd thing?  The photos were within the Masters folder in the iPhoto library's contents.  So I tried resetting permissions, deleting the iPhoto.plist from Prefs, the cache from ~/Library, tried again to find orphans and still they weren't found.  Weird.


    It is possible this all came after 9.1.5 was released; I think it possible that my last July uploads were before I updated iPhoto but I didn't keep detailed records.


    Since I now have access to the photos, I copied them out to a Finder folder and then reimported.  They seemed to import OK (though oddities with the small thumbnails continued).  However, I have options set to autosplit imports by day--but that wasn't happening now.  It made a single event for the import (was this a change in 9.1.5?).  Selecting that single event and then choosing autosplit from the Events menu would indeed split into day events, and I then recombined some as desired.


    At the moment I am rebuilding the small thumbs from the rebuild window (since those seem to be way out of sync) but I am worried that things are corrupted. I would really hate to lose the metadata associated with this library, but I am concerned that there are still gremlins in this database.  It seems from a lot of the posts that database integrity is not an Apple strong point.


    Anyways, I am curious why I couldn't recover the orphaned files that I could find manually in the Masters folder.  And I would like to know if there is a good way of testing the integrity of the iPhoto database.

  • alsays Level 1 Level 1 (0 points)

    Thanks for the advise.  What I did prior to reading your message was empty my trash which had over 15K photos that I didn't want.  Since doing problem seems to have disappeared.  I'm not sure why.

  • kimdura21 Level 1 Level 1 (0 points)

    I am having issues with my iPhoto and have been for some time.  I've tried to read through this forum to see if my problem is being experienced by anyone else, and I seem to be unique.  I've stumped the genious bar.


    I upgraded my iPhoto with iLife 11 (big mistake! ).  In the process, my projects seem to have been lost. 


    After many forums and tries later, I wiped out iPhoto, reinstalled from iLife 11 and at least now, when I scroll over my projects, it shows that there are photos in it, but when I click the project, nothing shows up.  I can create new projects when highlighting an event, but any of my old calendars/books created prior to the upgrade are non-existant.  I've done the plist fix (didn't work), tried booting in safe mode (didn't work), tried using a backup copy from my time machine (didn't work).


    So now I'm looking for help!  Some of the books I've created took me a long time to put together (wedding album, baby book, etc) and I really hate to lose those projects.


    I was able to take the project (after viewing package contents) onto another computer to see what pictures I have in them, but it only showed me thumbnails, so then I had to transfer the pictures from one computer to another to recreate the calendar.


    I don't think my "theme" folder is corrupt because I can create new projects.  It's my old ones that are the issue.




  • Old Toad Level 10 Level 10 (121,305 points)

    If you haven't tried the following fixes then do so: make a temporary, backup copy (if you don't already have a backup copy) of the library and apply the two fixes below in order as needed:



    Fix #1


    Launch iPhoto with the Command+Option keys held down and rebuild the library.



    Select the options identified in the screenshot


    Fix #2


    Using iPhoto Library Manager  to Rebuild Your iPhoto Library


      1. Download iPhoto Library Manager and launch.
      2. Click on the Add Library button, navigate to your Home/Pictures folder and select your iPhoto Library folder.
      3. Now that the library is listed in the left hand pane of iPLM, click on your library and go to the File ➙ Rebuild Library menu option
      4. In the next  window name the new library and select the location you want it to be placed.
      5. Click on the Create button.


    Note: This creates a new library based on the LIbraryData.xml file in the library and will recover Events, Albums, keywords, titles and comments but not books, calendars or slideshows. The original library will be left untouched for further attempts at fixing the problem or in case the rebuilt library is not satisfactory.


    If these fail then this is the next step:


    Start over from scratch with new library


    Start over with a new library and import the Originals (iPhoto 09 and earlier) or the Masters (iPhoto 11) folder from your original library as follows:


    1.  Move the existing library folder to the desktop.

    2. Open the library package like this.


    Click to view full size


    3. Launch iPhoto and, when asked, select the option to create a new library.

    4. Drag the Originals (iPhoto 09 and earlier) or the Masters (iPhoto 11) folder from the iPhoto Library on the desktop into the open iPhoto window.


    Click to view full size


    This will create a new library with the same Events as the original library but will not keep the metadata, albums, books slideshows and other projects.

    In the future instead of tacking your problem on the end of a long topic like this one I suggerst creating an new topic where you will get more direct attention.  You can reference the long topic to responders know where you're coming from. 

  • kimdura21 Level 1 Level 1 (0 points)

    Thank you for the suggestion.  I tried your option 1 but I'm really trying to NOT have to do something that won't pull over my projects.


    I have to amend my issues now- I just created a new project (a calendar) and it created fine.  Once I clicked off it (to an event), then tried to go back to that new project, NOTHING.  It wouldn't show my newly created project.  I just got the pinwheel of death.....


    I don't get how just the projects are the only thing not working.....


    It's sounding more and more like I'm going to have to create a brand new library and lose all of the projects.  I'm very unhappy that the original upgrade is what caused this issue.  I wish I would have never done it

  • Old Toad Level 10 Level 10 (121,305 points)

    You said that new projects worked OK and it was just the old projects that were giving you problems.  If that's the case you shouldn't need to start over with a new library.  Just delete the old projects and create new ones.

  • kimdura21 Level 1 Level 1 (0 points)

    Apparently, that was a lie.  I've been messing with it this morning (again) and here's what I just did:


    1. clicked on an event (with over 20 photos) and clicked Create>Book. 

    2.  I picked a theme.  (wire bound)

    3. The book showed up in the layout mode, but with no pictures  (shouldn't it create based on the event??).  When I clicked on "Photos" and made sure it showed all photos (not just placed ones), there were no pictures showing.


    Also, when I view the themes, they just don't seem to be showing correctly.  When I view, say, a book, and I scroll through them, instead of getting a cover view, it's like the project is showing an inside page (showing picture placement and placeholder text).  Pre-upgrade, I would get a cover view.  I'm not sure I'm explaining this right- but there is definitely something odd going on with my themes/projects.  I've tried the theme fixes I've found on the forums, but that hasn't helped either. 


    Also, you say to just delete my old projects and create new ones, but that is the problem- I don't want to have to create new ones for my old projects.  Some of them have like 100 pictures that were laid out in a specific way (which, by the way, I can view if I go to the project cache and check out the thumbnails).  So it's like my projects are cached within iPhoto, but they just won't show up so I can edit them or reorder (this is the big issue...).


    I wish I understood more about how iPhoto creates projects, because they are certainly stored within the iPhoto package contents (under Project Cache) but I just can't take those files and move them to a new iPhoto library and have them pop out the book (or calendar).  I'm frustrated because the data is there but I don't know how to extract it to make it work.  Or if my iPhoto is just so screwed up there's no hope....


    I just tried iPhoto on my Macbook Pro (the issue is on my iMac), and the themes are showing correctly- they show cover flow, not some odd inside page masking as a cover.  I think I'll try to open a backup of my library that is stored on my Time Capsule on my MacBook and see if I can't get that one working.  Perhaps my Mac is just really messed up....


    UPDATE:  Ok, just tried to open up the backup copy of my iPhoto library on my Time Capsule with my MacBook.  Same issue.  Projects show on the sidebar, and if you scroll over them, shows there are pictures within the project, but if you click on the project, I'm now getting the attempt at opening the project, but no pages show up.  If I try to change themes, I get the pinwheel of death.  The Time Capsule backup is from my iMac (where all my pictures are stored).  Apparently, the backup is taking the glitch along with it...

  • Craig Jones3 Level 1 Level 1 (5 points)

    If you haven't yet, take a gander at the file permissions throughout your project (ideally in the Terminal within the package).  I noticed some things had some odd permissions at one point and forced everything to be writeable (and readable) by user, group, and everyone to just eliminate this as a possible problem (in terminal, "chmod -R aug+rw *" will do the trick).

  • thebassman78 Level 1 Level 1 (0 points)

    There's one scenario not covered here, which was affecting me and took me forever to figure out.

    If you run a Diamond BVU 195 USB graphics adapter for external monitors, you will never ever be able to see your pictures (at least under current driver). This scenario and a solution for black pictures in iPhoto with external monitors is described here. I hope this might help someone like me, since most discussions only have the standard 3 suggested solutions.

  • Casuarina Level 1 Level 1 (0 points)

    Well after reading all these posts, my problem pales into insignificance!

    Sadly, I upgraded. Now I can't click onto a photo and have it open to anything larger than a playing card.

    I can't go back and forward using the arrow keys, and I can't move out of an album without hitting the esc key.

    Is this the way it is supposed to be?  If so, it is not good enough.

    If there are no fixes, how can I uninstall this and go back to the way it was yesterday, without losing labels and folders.


    Help me, please!

  • roberto262 Level 1 Level 1 (0 points)

    Hi,i can't open anymore iphoto...i was doing the update and then at the end a window pop up saying

    an error occured and weren't able to do the updates....and now i can't open the iphoto applicantion.....any help please? thanks

  • giogio78 Level 1 Level 1 (0 points)

    I have a terrible problem with iPhoto '11: when amount of photos, and open the event to see them, I see a preview of the erroneous notion that refers to other photos, I see that if I click the photo is actually one. ultimately there is an error on the thumbnails of the photos.




    this is the anteprima :

    Schermata 12-2455923 alle 17.24.55.png


    whe i click on the photo this is the foto:


    Schermata 12-2455923 alle 17.25.05.png

  • Terence Devlin Level 10 Level 10 (128,825 points)

    Back Up and try rebuild the library: hold down the command and option (or alt) keys while launching iPhoto. Use the resulting dialogue to rebuild. Include the option to rebuild the thumbnails. This can take thre or four goes to work.






  • Froggybeth Level 1 Level 1 (0 points)

    Thanks Old Toad, your solution #1 worked for me.


    I have recently upgraded to Lion/iPhoto '11. While all began well I noticed a set of photos had gone missing after import, culling and editing.


    I found the photos in the Masters folder (as per your instructions) and after rebuilding my library I was able to reimport them.


    So far everything is working as it should.