1 2 3 Previous Next 460 Replies Latest reply: Sep 23, 2013 9:06 AM by Old Toad Branched to a new discussion.
Richard Tanner Level 1 Level 1 (55 points)
I am having a nightmare with iPhoto '11

1. Every time I open it, it asks me to upgrade my photo library. When it closes it saves changes, but comes up with the same upgrade message each time.
2. It hangs when trying to import photos from a file.
3. It doesn't see my iPhone (not tried it with another camera yet, but not hopeful)
4. Cannot open books I've already made, and when I create a new book, nothing happens - other than adding a new book under the project list. However, even this disappears next time I open iPhoto '11.

I am currently regretting upgrading at all!

I have restarted the computer and tried repairing permissions.

iMac 20" Core2Duo, Mac OS X (10.6.4)
  • 1. Re: Numerous problems with iPhoto '11
    yohannus Level 1 Level 1 (0 points)
    i have the same issue with the books.
  • 2. Re: Numerous problems with iPhoto '11
    theBigD23 Level 1 Level 1 (20 points)
    yoahnnus: does it take a long time for it load the Create a Book too? Pinwheel and about 30 seconds to 2 minutes to launch?
  • 3. Re: Numerous problems with iPhoto '11
    Richard Tanner Level 1 Level 1 (55 points)
    Unable to delete from the iPhoto Trash either.
    Have switched back to iPhoto '09 and tried rebuilding the library, but has made no difference.
  • 4. Re: Numerous problems with iPhoto '11
    yohannus Level 1 Level 1 (0 points)
    I can't even load it. I left it online all night after creating a project. The project shows up right away on the left, but I can't get to the "All pages view" to edit the book.
  • 5. Re: Numerous problems with iPhoto '11
    Avinash Vakil Level 1 Level 1 (25 points)
    I also have the problem with Cards and Books.
  • 6. Re: Numerous problems with iPhoto '11
    mach0u Level 1 Level 1 (0 points)
    Well I'm having a ton of problems with iphoto 11 - I strongly urge not to make the upgrade.

    1. before upgrade, I had 1000 pictures in trash folder - after upgrade I wanted to delete these, it does remove them from the trash view, but when I restart iPhoto 11 they trash still says it has 1000 photos (but not showing the actual pictures, just grey ones) - I've tried all kind of delete within iPhoto without success

    2. Creating books - I choose the event from whioch I want to create the book, it shows me the preview and then I select create and nothing..it only automatically fill the first page and the reste of the book has the "default" theme pictures. Option to automatically fill is also greyed out

    3. Having big troubles to split events (I cannot in fact) - I choose the picture from an existing event, I flag it, then from the menu I choose to split it to another event and it creates an event. I go to check this new event and there is no way to see the picture once inside the event. I go back to the events list, choose my event and slideshow, and it shows the picture...I try to go back in the event and no picture shown

    4. also, iPhoto 11 is not remembering after every restart how my events are sorted. I sort them by Date > Descending and after every restart the events are sorted by Date > Ascending

    I've restarted, checked permissions etc...and still not working. Feels very very BETA....
  • 7. Re: Numerous problems with iPhoto '11
    SDmofo Level 1 Level 1 (0 points)
    Add me to the list of issue-havers

    1) Events - iPhoto is not showing my recent events (from about the last 2-3 months), but if I go to the photos section, they show up here (and with the correct name of the event they are grouped by).

    2) Faces - I have an album that looks for Missing Faces (works very well on old iLife). When I import photos it scans and any it find that does not have a name for a found face, it puts them in that album. On '11, it seems to be finding faces. But when I got to assign names, it won't show me where the "face" is it found so I can edit it. I did find a few and changed them, but then one of them came back with the same message. I've restarted it, restarted the Mac, same result.
  • 8. Re: Numerous problems with iPhoto '11
    revdlc Level 1 Level 1 (0 points)
    It's a small thing compared to other problems listed so far, but I notice that it is possible to change the name of a picture at the top center of the edit window, but then when I go back to the picture later or go to the browse window, the name has not changed. On the other hand, if I change the name in the browse window, the name change sticks. Odd...
  • 9. Re: Numerous problems with iPhoto '11
    Old Toad Level 10 Level 10 (115,720 points)
    Try deleting the Delete iPhoto Pref File
    iPhoto preference file, com.apple.iPhoto.plist, that resides in your User/Library/Preferences folder.



    NOTE: If you're moved your library from its default location in your Home/Pictures folder you will have to point iPhoto to its new location when you next open iPhoto by holding the the Option key. You'll also have to reset the iPhoto's various preferences.


    Then backup the library and launch iPhoto with the Command+Option keys depressed to rebuild the library. Select the options #1, #2 and #5.




    Click to view full size


    See if that helps.


    OT
  • 10. Re: Numerous problems with iPhoto '11
    Misjen Level 1 Level 1 (0 points)
    I am also having the same issue with the creation of books and cards. I tried all of the suggestions listed here, but nothing seems to be working. When I launched iPhoto 11 for the first time, it asked me if I wanted to repair my permissions. Is that significant? Also, coincidentally, I upgraded my hard drive and RAM 24 hours before installing iLife '11. They seem to be functioning flawlessly, but could this have affected my install?
  • 11. Re: Numerous problems with iPhoto '11
    Felix Leiter Level 1 Level 1 (5 points)
    Same here. I tried everything and iPhoto refuses to open, both under "library repair" and normal mode. Interestingly, my databases which do not contain movies made with the iPhone seem unaffected. So it has to have something to do with the movie files, at least on my computer.
  • 12. Re: Numerous problems with iPhoto '11
    Old Toad Level 10 Level 10 (115,720 points)
    Have you tried repairing disk permissions with Disk Utility? If not do so.
  • 13. Re: Numerous problems with iPhoto '11
    Felix Leiter Level 1 Level 1 (5 points)
    Tried to no avail.
  • 14. Re: Numerous problems with iPhoto '11
    Photojourney Level 1 Level 1 (0 points)
    Shame on Apple for releasing a product before it is ready and fully tested. I am returning my purchase to the Apple Store.
1 2 3 Previous Next