Previous 1 2 3 4 Next 49 Replies Latest reply: Apr 14, 2012 4:54 AM by cap_n
OSU-Mac Level 1 (10 points)
After recently installing iLife '11, my iPhoto Library became unusable. When I OK'd iPhoto to "upgrade" my library, it started the process and then presented an error message "iPhoto is unable to open this Library".

I couldn't rebuild the Library either. So I was able to "downgrade" back to iPhoto '09 and restored my Library from an older backup (a couple days old). I simply moved iPhoto '11 to the desktop, deleted iPhoto prefs, and reinstalled iPhoto '09 from disc. My intention was to use iPhoto '09 to rebuild the library and then upgrade again. After reinstalling iPhoto '09, I can open my iPhoto library just fine. Appears to be normal. However, when I try to "rebuild" the library, iPhoto instantly quits. No error messages or anything. Just quits.

I downloaded iPhoto Library Manager hoping that it may allow me to rebuild the library. When I try to do that, it prompts me to use iPhoto 9.0 ('11) to upgrade the library before I rebuild. It appears that my Mac (at least iPhoto Library Manager) still thinks iPhoto 9.0 ('11) is installed. I'm positive that iPhoto 8.1 is installed, and that's what's in my Applications folder. That's what is successfully opening my iPhoto library. Any ideas on how I can rebuild this Library in '09 so that I can try to "upgrade" again?

Running on new iMac with 10.6.4 installed.

Mac Pro, MacBook Pro, iPhone, iPod Video, Mac OS X (10.6.4)
  • dage007 Level 1 (0 points)
    Is your library located on a nas?
  • OSU-Mac Level 1 (10 points)
    No. It's on the internal hard drive.
  • John Dewberry Level 1 (0 points)
    I'm getting the exact same message. . . "iphoto is unable to open this library" . . . . never had this type of trouble with an iLife upgrade before
  • Christopher Liebe Level 1 (0 points)
    Same exact problem here!
  • Johan Kjellman Level 1 (0 points)
    Same problem here!
  • Vernexto Level 1 (5 points)
    Just wanted to chime in to this as I ran into the same issue, and these boards have been a great resource in the past.

    Here's what I attempted to do that didn't fix the issue;

    - Tried to rebuild the library from iPhoto '11 (CMD+Option) when opening the program, which failed with the exact same error as OSO - Mac was mentioning above.

    - Reverted back to iPhoto '09 (deleted iPhoto '11 from /Applications/, as well as deleted any reference to iPhoto in /Library/Receipts; I saw no references but took that suggestions from a previous thread here), then reinstalled iPhoto '09 via original discs. I was able to open the library as I wanted (pulled a library from a few days ago in a Time Machine backup to be safe), then attempted to rebuild in hopes that would help issue. Reinstalled iPhoto '11, but the same issue occurred.

    Here's what I attempted to do that somewhat fixed the issue;

    - Option-clicked to open iPhoto '11, then chose to create a new library. Created a new library (I named mine iPhoto2) in the ~/Pictures/ folder. Closed iPhoto. Then I navigated to the ~/Pictures/ folder, right-clicked on the original iPhoto library that won't open, as well as the newly created iPhoto library that does open (but lacks any content), and choose to Show Contents. I manually copied all the contents of the original iPhoto library to the new iPhoto library (some folders and files overwrote, some did not; note that the structure of the iPhoto '11 library is radically different than that of the iPhoto '09 library) and then re-opened iPhoto. iPhoto prompted me to upgrade the library again (peculiar since the library technically was created in iPhoto '11, but I guess it saw elements of the iPhoto '09 structure) and successfully upgraded the library. The only downside was that, for whatever reason, certain photos did not come back and were blatantly missing thumbnails and originals. But my album structure, faces, etc. remained intact.

    What I did that finally fixed the issue;

    - Brought back my good library from a Time Machine backup, then right-clicked on it within ~/Pictures/ and chose Get Info. I manually set permissions for everyone on my machine (admin, staff, everyone, and myself) to Read & Write. Option-clicked when opening iPhoto, forced it to look for my newly-permissioned library, and viola, upgraded without issue and no lost photos.

    Not sure if my solution will work for all, and my apologies for providing such information that isn't so concrete, but since these are user-to-user forums, I thought I'd offer my experience as I was not able to locate any other solutions without entirely losing my album structure, faces data, etc.
  • Sam den Hartog Level 1 (0 points)
    For me it sure helped to solve this issue. Maybe just the permissions will solve the problem, after doing that, just restart iPhoto.
  • OSU-Mac Level 1 (10 points)
    Thanks for the info. After fully deleting iPhoto '11 (trashing it), I was able to get iPhoto Library Manager to rebuild my library. It's currently underway (going on 3 hours... Library contains 25,000+ photos!). I also followed your advice about the permissions. Hopefully between those 2 actions I will be able to reinstall iPhoto '11 and successfully upgrade my library! (*Fingers Crossed*)
  • Felix Leiter Level 1 (5 points)
    I'll try, but I doubt this will solve the problem.
  • tHe sR5 Level 1 (10 points)
    I think i solved this issue, i went to my iPhoto_Library file, right clicked "Show Package Contents" Deleted "InterruptedUpdate, ThemeCache, ProjectDBVersion.plist, Projects.db, Projects.db-journal" Restarted iPhoto did the upgrade, Closed and reopened and BAM! works like a charm... Hope this works for everyone else! Small note i was in Safe Mode when i did this.
  • OSU-Mac Level 1 (10 points)
    I'm not familiar with safe mode- is that done at startup?
  • ROCKofCSWO Level 1 (0 points)
    You have to restore the iPhoto file from backup and then reset the ACL permissions. Was on the phone with apple and it works.
  • elscorcho0 Level 1 (0 points)
    same issue. "iphoto is unable to open this library" i restored library from time machine, repaired permissions, same message " iphoto is unable to open this library"
  • Dale.Lowery Level 1 (0 points)
    As an interesting aside, I popped onto the Forum today to look into an issue that I had hoped 11 would solve: I have been getting this error ("You have made changes to your photo library using a newer version of iPhoto. Please quit and use the latest version of iPhoto.") for some time in_iPhoto9 (!!!)
    I had looked but not found any prior comments on this error. Now it seems many folks are having it with 11. As others have noted, the error is extremely frustrating because iPhoto will not upgrade the Library in question (an older Library restored from Time Machine), but also insists on quitting if the Library is not upgraded.
    As of this moment, it seems like option-clicking moved things past the blockage, but I won't be sure until the Library upgrade is completed (~25,000 images in this particular Library, a smaller one for me).
Previous 1 2 3 4 Next