Skip navigation

Library can't upgrade to iPhoto '11, can't rebuild Library either.

25493 Views 49 Replies Latest reply: Apr 14, 2012 4:54 AM by cap_n RSS
  • chester4444 Level 1 Level 1 (0 points)
    This did seem to work for me, however I did this when my library was already deleted, I am now recovering my library from my backup. I hope this works, I have hopes for it. It finally stopped upgrading overtime I open it!!

    Thanks
    Mac OS X (10.5.4)
  • Cappe Calculating status...
    Hello,
    I have the same problem you describe:
    - I have installed iLife 11
    - launch iPhoto 11 and it update the libray. It seems that all is ok
    - close iPhoto, reopen, and it's locked with the loading icon
    I wait for 6 hour but no start. I have 4 library: for 3 library I have deleted some files from the library file (InterruptedUpdate, ThemeCache, ProjectDBVersion.plist, Projects.db, Projects.db-journal)and now they work. For the big library, no difference. It's locked.
    Apple, what are you doing???
    Mac Book Pro late 2007 - 4 Gb Ram, Mac OS X (10.6.4)
  • kyroha Calculating status...
    Currently Being Moderated
    Oct 25, 2010 4:50 PM (in response to Cappe)
    Upgrade completed successfully -
    Opened iPhoto -
    "Your Library needs updated" -
    "iPhoto is unable to open this library" -
    "Quit" -

    I really need to know what to do next. I would love to see an official post from apple with a step by step. After looking through this forum I think it is crazy there hasn't been some kind of warning posted about this upgrade.
    iMac, Mac OS X (10.6.4)
  • Robert Rogers Level 2 Level 2 (345 points)
    Currently Being Moderated
    Oct 25, 2010 8:21 PM (in response to kyroha)
    My suggestion is if you have a back up restore it and open it in IPhoto 09 and temporarily leave well enough alone. After spending 3days with Apple tech support and engineers I was told to rebuild by data by installing the originals and masters directly into the iphoto11 icon on the doc once the iphoto 11 new library is open .You will loose all your albums and other things you did but the pics will be there..Or you can rebuild your backup and let IP09 open it as before. Perhaps Apple will get this sorted out. Not a pretty picture.. I have 2 libraries one 750GB with 92000 pics and another with 1.45TB with some 200000 pics. Yes they worked in 09. I remember when ILIFE first came out there was a limit of some 20,000 pictures but no limits where set with 09 or 11 or Aperture. My plan is to open them in 09 again and break them into some 10 libraries and than see if I can get them into 11 or better with just dump 11 and us Aperture.
    2X 2.26 Quad Core Nehalem 16GB mem, Mac OS X (10.6.2), ATA HD 4870 video card
  • madrhino Calculating status...
    Hello,

    I have had the same problems in this post since Friday when I upgraded our pictures for family (26K plus) and cannot get the spinning bars to stop. On Sunday I let the program run for almost 24 hours. I am now restoring from Time Machine my iPhoto database and hoping to see if it will take this time.

    Very disappointing the performance of iPhoto 9. If anyone has a simpler way of doing which has not be posted please advise. Thank you
    Imac Intel 3.06 Gig, Mac OS X (10.6.4)
  • serotonina74 Calculating status...
    After installing iphoto 11, it couldn't upgrade the library, all my photos were lost from the library. Looking inside the library icon with show contens -> originals only were the year folders, but they were empty. Returned to iphoto 08 throw Time Machine and tried to restore a copy of my library from Time machine. Iphoto couldn't do it as there was an error and just part of my photos were recovered but without preview icons at the events.

    What i did is just delete the library from Images folder, installed iphoto 11, and at start asked me to create a new empty library. After that just copied the photos from Time machine -> iphoto library -> show contens -> originals and copied the years folders with my 20K photos to another disk (just to have another copy of my photos :D). Now from iphoto 11 just imported those folders.

    That was the only way i could have my photos with ilife 11.
    imac, 27"
  • Jammer5 Calculating status...
    My condition was completely same as here.
    But finally, I succeed in upgrading iPhoto09 to 11!

    My iPhoto Library size is 177GB and it contains about 100 smart and
    non-smart albums.

    1. Backrev to iPhoto09.
    2.Delete all Smart and Non-smart Albums.
    3.Quit iPhoto09 and restart with OPT+CMD key. Library rebuilting will
    starts.
    4.Quit iPhoto09. and remove iPhoto09 then reinstall iPhoto11.
    5.Launch iPhoto11 and start library upgrade. Will be successful this time.

    If you need to keep the albums, You should better mark the Keyword to
    every photos in the album. Then in the iPhoto11, Make the smart album
    using that keyword.
    iMac 21.5inch Core i5 3.6GHz 8GB RAM, Mac OS X (10.4.6), MacBook Core-Duo
  • m11091940 Calculating status...
    I followed your exact advice ( other than in safe mode) and now it works perfectly. Thanks and others should try this procedure.
    MacBook Pro 17", Mac OS X (10.6.4)
  • Chip George Calculating status...
    Same problem, but the fix was really easy.

    1. Drag backup of iPhoto library to the iPhoto icon.
    2. this will launch iPhoto '11. Allow iPhoto to update library.
    3. close iPhoto. Copy your now updated, back up, iPhoto library back to your Pictures folder.

    Not sure why this only works with the backup, but it works.
    Mac Pro, Mac OS X (10.6.4)
  • U of W Calculating status...
    I am having the same issues with the install on my 2 year old iMac running 10.6.4. Won't upgrade my photos, can't rebuild library. Spinning gear goes on forever and still updates.

    Oddly, I can click a sidebar option while he gear is spinning and photos open, places and faces works for a few minutes but the app freezes or closes. The background graphics go crazy when it freezes.

    Yikes.

    It did load on my MacBook with no issues.

    Good luck, all!!
    iMac 24" OS 10.5 MacBook 13" OS 10.5 Macbook Air, Mac OS X (10.5)
  • madrhino Level 1 Level 1 (0 points)
    Hello

    I did what you did and was able to upgrade to iPhoto 9. Very much appreciate your advice and taking the time.

    I will now have to explain to my wife why a great Apple product made me delete the smart albums.

    Thank you

    Mike
    iMac 3.06 gHz, Mac OS X (10.6.4)
  • Jammer5 Level 1 Level 1 (0 points)
    Hi madrhino
    I feel happy I could help you.

    I will now have to explain to my wife why a great Apple product made me delete the smart albums.

    I also have great problem same as you!
    iMac 21.5inch Core i5 3.6GHz 8GB RAM, Mac OS X (10.4.6), MacBook Core-Duo
  • Larry Nolan Level 2 Level 2 (165 points)
    Found this on Macintouch:

    David Ticzon

    I finally got my problem solved....
    Turns out that there are some plug ins that are causing problems with the upgrade of the iPhoto library to iPhoto '11. I had the pleasure of meeting an iPhoto engineer (at my house), who took a copy of my 73 GB iPhoto library to Apple to determine why my IPhoto would crash during the library update. (Yes, I gave Apple my personal library). I was selected since I am near the Apple Campus.
    I told the engineer that they are playing with people's lives, because our photos are very important to us. He told me that they are aware of that, and are investigating the problem. (I had my library go from 73 GB shrink to 9 GB when I tried to upgrade to iPhoto '11.)
    It turns out, an old plug-in from the Joe Soft application, called Hear, was causing my problem. Even though this was a iTunes enhancement application, it had ties to the movie files (via Quicktime) that are in my iPhoto library.
    Other plug ins that can cause problems are the DIVX plug in and AVI Converter plug ins.
    Once I removed the offending plug in, my library converted within a hour and I was happy to be enjoying the new version of iPhoto. I will keep my old iPhoto 9 Library, just in case if I have a problem. (I am testing importing photos from all of my cameras and iPhones, just to make sure import works.)
    I was also told that I can do the conversion in "Safe Mode" (hold Shift Key down during startup) if I didn't want to remove the plug ins. However, I needed to know if it was really the plug in, so I did the upgrade in the regular mode with the offending plug in removed.
    I have to say that I had moved a copy of the original iPhoto Library to a stripped computer (has no plug ins) and tried converting it to iPhoto '11, and it converted without any problems. Therefore, I know it was a plug in issue.
    I was told that I can move the converted library to my main computer (that has the plug ins) and should not have any problems running iPhoto. The plug in problem only occurs during the conversion process.
    Regarding the Projects (Books) items, they all converted without any problems. I have open them and verified. All albums are working and all 26,000+ photos are working!
    I have shut down and restarted iPhoto and also shut down and restarted my computer, then launch iPhoto without any problems. I actually think iPhoto '11 loads much faster than iPhoto '09
    A regular fix is in the works.
    Hope this helps.
    Thanks again iPhoto Team!
    iMac 24" (Aluminum);iPad;iPod Touch 2G; Intel Mac mini, Mac OS X (10.6.4), XP Pro via Fusion 2.0.6
  • Peter Alexander Level 1 Level 1 (130 points)
    The problem and solution has been documented here.

    http://iphoto11.wordpress.com/
    24" iMac Extreme and loads of other stuff, Mac OS X (10.5.4)
  • Terence Devlin Level 10 Level 10 (121,670 points)
    The link you refer to will solve the issue for those with permissions issues. However, it will be of no help for those with Plug-In issues, and that's what Larry Nolan's post refers to.

    Regards

    TD
    MacBook Pro 15 2.4 C2D / iMac 20" 2.66 C2D, Mac OS X (10.6), 4 gig RAM/ 4 gig RAM

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.