Previous 1 2 Next 21 Replies Latest reply: Jun 14, 2014 7:20 AM by @happy2dent
princesambit Level 1 Level 1 (0 points)
whenever I click on link, it opens a new tab but then it throws up the error saying the safari is not able to connect to the server. But, if I logoff from my account and login back thru guest account, I am able to open the same link. Any ideas why this is happening and how to fix it?

MacBook, Mac OS X (10.6.4)
  • andyBall_uk Level 7 Level 7 (20,495 points)
    Hi

    are other browsers affected, or just Safari ?
    Mail too?

    Just one link causes this, or you can't reach the web at all on that account?
  • princesambit Level 1 Level 1 (0 points)
    It happens with all browsers but not with mail. I am able to open all webpages when I go and type the address manually on the address bar like www.apple.com. But if some other website like CNET have a link which should connect me to apple.com then I am ale to do so.
  • andyBall_uk Level 7 Level 7 (20,495 points)
    I see

    sounds possibly as if some software add-on or plugin is affecting clicked links, while the address bar entries work normally.

    Look in Home/Library/Internet Plug-Ins & Input Managers
    also check in System Preferences-Accounts-Login Items
  • princesambit Level 1 Level 1 (0 points)
    Well, there are only 4 internet plugins which are

    BrowserPlus_2.9.8.plugin
    Move-Media-Player.plugin
    nprevweb.plugin
    Picasa.plugin

    I moved all of them from the plugins folder to the desktop and did a reset of Safari and tried to click on the links but it was no different. Hence, I moved these plugins back to the folder. Also, all the items in Accounts - Login Items are unchecked.
  • andyBall_uk Level 7 Level 7 (20,495 points)
    I moved all of them from the plugins folder to the desktop and did a reset of Safari.

    You do need to move them with safari quit, or at least quit/restart after moving them.

    all the items in Accounts - Login Items are unchecked

    the check mark controls whether or not they're hidden - they still run, checked or not.

    ---
    from Apple help...

    To make items open automatically when you log in:
    Choose Apple menu > System Preferences, click Accounts, select your account, and then click Login Items.
    Open Accounts preferences
    Click the Add ( + ) button to the right of the account list.
    Select an application, document, folder, or disk, and then click Add.

    If you want the window for an item to remain closed, click the Hide checkbox next to it.

    To temporarily prevent items from opening automatically when you log in:
    In the login window, hold down the Shift key while clicking the Log In button.
    Continue holding down the Shift key until you see the Dock.

    To permanently prevent an item from opening automatically when you log in:
    Select the item in the login items list.
    Click the Delete ( - ) button.
  • princesambit Level 1 Level 1 (0 points)
    Thanks for the instructions. As per the Apple help, I deleted few of the items from the login items. I removed the Internet Plugins and quit safari. But this didn't help either!
  • Carolyn Samit Level 10 Level 10 (95,950 points)
    Hi,

    But, if I logoff from my account and login back thru guest account, I am able to open the same link


    That's good. It's not a system wide problem, just your user account.



    Open a Finder window select your Home Folder in the Sidebar on the left. Then open the Library folder, then the Caches folder, then the com.apple.Safari folder. Move the cache.db file from the com.apple.Safari folder to the Trash. Relaunch Safari.

    If that doesn't help, from your Safari menu bar click Safari / Reset Safari. Select the top 7 buttons, click Reset.

    If that doesn't help, try troubleshooting the Safari .plist file. Quit Safari if it's open. Open a Finder window. Select your Home Folder in the Sidebar on the left. It has a small house icon. Then open the Library folder then the Preferences folder.

    Move the com.apple.Safari.plist file from the Preferences folder to the Desktop. Now launch Safari. If Safari opens links as it should, move that .plist file to the Trash.







    Carolyn
  • princesambit Level 1 Level 1 (0 points)
    Thank you, Carolyn. Tried all the 3 steps are you mentioned but nothing helped.
  • Carolyn Samit Level 10 Level 10 (95,950 points)
    Ok...

    Open System Preferences / Network. Click the Advanced tab then select the Proxies tab.

    If there are any boxes selected under: *Select a protocol to configure* deselect and relaunch Safari.

    And if you haven't tried, shut down your Mac, wait about 2 mins, then turn it back on and try Safari again.

    Note... It's taking me a minute or two get post a reply. Bear with us.

    If you are running a prior version of Safari before 5.0.2, click your Apple Menu / Software Update...







  • princesambit Level 1 Level 1 (0 points)
    Tried this but no different results!

    Safari's version is 5.0.2.
  • Carolyn Samit Level 10 Level 10 (95,950 points)
  • princesambit Level 1 Level 1 (0 points)
    Registered and added the 2 DNS entries as directed.
  • Carolyn Samit Level 10 Level 10 (95,950 points)
    Did that make a difference?






  • princesambit Level 1 Level 1 (0 points)
    No.
Previous 1 2 Next