3 Replies Latest reply: Dec 8, 2010 2:23 PM by corvus2606
jpcarr Level 1 (10 points)
I am unable to connect to another Mac on my wired LAN (Netgear wndr3700), and it is unable to connect to my machine. We cannot see each others’ Public Folder / Drop Box.
We can see each others Macs in the Shared section of the Finder’s sidebar, but trying to connect fails: “The server … may not exist or it is unavailable at this time…”
Both are running 10.6.4 Snow Leopard SL. No Windows machines on the LAN - so this should be AFP only.
We can see and connect to another Mac running 10.4.11 Tiger with no problem. BUT it is unable to connect to either 10.6.4 machine.
Firewall on both machines: On; File Sharing (AFP) set to “Allow incoming connections”; Stealth mode Enabled (toggling doesn’t change); “Automatically allow signed software to receive incoming connections” is Off; “Block all incoming connections” is Off. Some other apps and services are set to Block… (krb5kdc, numbed, smbd…) AppleFileServer is set to Allow.
Sharing: File Sharing Service only is On:
Hard Drive - Everyone - Read & Write
Users - Everyone - Read Only
~ (My Home Directory) - Everyone - Read Only
Public - Everyone - Read & Write
Drop Box - Everyone - Write only

Thanks for any suggestions.

MacPro3,1 dual quad core 2.8 GHz 2008 "Harpertown",, Mac OS X (10.6.4), 10GB, Radeon HD 2600
  • Kevin Hawkins Level 1 (105 points)
    Seems to be a bug from the software update from yesterday. I can not connect to any of my shared drives on my Mac network. I hope someone figures this out!

    Kevin
  • jpcarr Level 1 (10 points)
    I have not applied the Security Update 2010-006 yet.
    Disabling the OSX Firewall allows access to the shared folders, so the problem is related to it.
  • corvus2606 Level 1 (10 points)
    It isn't directly related to the firewall, I'm having the same problem between two up to date machines, and to be sure, I have disabled the firewall on both. however, If i connect using the connect to server dialogue, I get through just fine. I believe it could be a dns resolution problem.

    strike that.

    Just tested, check in advanced network settings, and if you have any wins servers listed, remove them.

    krb5kdc needs to be allowed to accept connections, for me it popped up in little snitch when it was authenticating.