Previous 1 2 3 Next 79 Replies Latest reply: May 7, 2014 7:20 AM by iLee
nevillev Level 1 Level 1
Using iLife 09, iMovie showed my iPhoto videos in the lower pane event browser.
Upgraded to iLife 11.
iPhoto spent some time converting my library - but it completed; and seems fine.

iMovie, however, no longer shows the iPhoto videos. The text says no video clips match the current selection - but this never changes no matter what is selected.

My previous iMovie projects all still exist; and seem fine. The videos that were added from the event browser in '09 are also still fine within those projects.

I'd appreciate any suggestions for fixing this.

Macbook Pro, Mac OS X (10.6.2)
  • John Cogdell Level 5 Level 5
    Similar to issues with iPhoto and iMovie '09, you may need to instal QuickTime Player 7 (if not already installed). Apparently, some older video file formats need to have QuickTime Player 7 installed in order to play. Possibly, iMovie '11 also needs this. See this Apple article:

  • nevillev Level 1 Level 1
    Good suggestion - but unfortunately it didn't help.

    I followed the instructions in the kb article. When I next started iMovie 11 it went through all the usual motions - including some time spent scanning my iPhoto library for new videos. Unfortunately at the end of all that the event library is still empty. It lists a node called iPhoto Videos - but nothing is shown there.

    I'd need to get this working again because right now I can't make progress on my projects since I can't select any new video clips.

    I'd appreciate any further suggestions.
  • John Cogdell Level 5 Level 5
    Sorry to hear it didn't work for you Neville. My copy of iLife '11 should be delivered on Monday (it's now Saturday evening here). Once I've got things up and running, I'll be able to see what happens with my iPhoto videos, although I only have a few.

    As a quick test, close iMovie, then drag one of your shorter iPhoto videos to the Desktop, then drag it back to iPhoto. Open iMovie - possibly it will now see the freshly imported video in iPhoto. I have a vague recollection that I suggested this to another user in the iMovie '09 forum, and I believe it did the trick. So, here's hoping!

    I'll let you know how things go with my iPhoto videos.

  • nevillev Level 1 Level 1
    Thanks John. I tried your suggestion and imported a video from my desktop, but it also made no difference.

    Then I tried a variation on the theme: I changed my iPhoto preferences and checked the box to "copy items to the iPhoto library" for Importing (on the Advanced tab). I always have this unchecked since I want control over the location of my photos on the disk. I reimported the same video. This time when I shut down iPhoto and started iMovie the single video showed up in the usual place.

    It seems that iMovie has lost the ability to see videos that are imported into iPhoto with the above checkbox unchecked.

    This is very sad and problematic for me since I have over 2,000 videos amongst my 100,000+ photos.

    I have now logged a bug with Apple - but I'd still appreciate any other thoughts or hints. Also interested to hear your experience once you receive your iLife 11.

  • John Cogdell Level 5 Level 5
    It seems that iMovie has lost the ability to see videos that are imported into iPhoto with the above checkbox unchecked.

    That's interesting - thanks for letting us know Neville. It was good thinking on your part to change that preference. This will help others with similar issues. As I always have my preference set to copy items to the iPhoto Library, hopefully I won't see any problems.

    Once I'm running with iLife '11 (hopefully some time on Monday) I will let you know how things go.

  • appleky Level 1 Level 1
    I upgraded from 9 to 11.

    I can see iphoto videos, but everything else is greyed out. Itunes, Photo's, all media on the bar. I literally can only use video in imovie. No photo's. Any suggestions for this?
  • JBinCalifornia Level 1 Level 1
    I did the following, and solved the "MISSING VIDEO CLIPS SCARE" I had on our iMac; we have only a tiny amount of video / photos on our Macbook Pro . . . and the iLife '11 stuff loaded normally for that (knock on wood).

    (note: I did notice iMovie '09 still exists in my applications folder in the 'iMovie (previous version)' folder) . . .

    1) Couldn't see the "iPhoto Videos" as mentioned above in the "Event Library" (lower left)

    2) Needed to re-boot iPhoto --> to import / update thumbnails (or something like that)

    (Restarted iMac)

    3) Open Applications folder --> Utilities folder --> run "Disk Utility"

    4) In Disk Utility --> click "Repair Permissions" (about 8 min / avoided running any other programs)

    (Restarted iMac again)

    5) Then, iMovie found the "iPhoto Videos" normally (note: iMovie takes 2 or 3 mins to boot up, and load all our clips . . . seems like a bit longer than before . . . so, be patient. From there = works great)

  • ddelmoli Level 1 Level 1
    I have the same example problem and symptoms as Neville does. Roughly 12,000 photos and 700 iPhoto videos -- none of them are copied into the Library. My old Mac Mini couldn't handle them, so I never generated thumbnails for them. Was looking forward to working with them on my new iMac and iMovie '11.

    I tried JBinCalifornia's suggestion of rebooting and fixing permissions -- no help.

    Also repeated Neville's experience -- importing with the checkbox selected to copy into iPhoto Library worked -- video showed up in iMovie.

    BTW, every time iMovie starts up it scans the iPhoto library looking for clips, but doesn't find the ones that were not copied into the library.
  • John Cogdell Level 5 Level 5
    John Cogdell said:
    As I always have my preference set to copy items to the iPhoto Library, hopefully I won't see any problems. Once I'm running with iLife '11 (hopefully some time on Monday) I will let you know how things go.

    Neville, just to let you know (as promised), everything went very smoothly with my iLife '11 upgrade. All my iPhoto videos showed up in iMovie '11 within the item "iPhoto Videos" in the Events Library. But, as I mentioned earlier, my preferences are set to copy photos to the iPhoto Library.

    After installing iLife '11, my first step was to open iPhoto and allow the database to update. Once I was satisfied that iPhoto was running OK, I then opened iMovie and waited for it to do all the upgrading. That went smoothly also, other than a warning about a Centred Title missing from one of my iPhoto Videos and that the video wouldn't play without it. I haven't bothered to track that down yet - the video wasn't identified in the warning message.

    I appreciate this doesn't really help you solve your issue, but it does help to confirm that things seem to work OK when the iPhoto preference is set to the option I've selected (copy photos). Note that my iPhoto Library is located on the internal drive. I have a small number of photos that I keep in separate folders outside of the iPhoto Library - mainly stuff I've done for other people that I don't want cluttering up iPhoto (although I realise that these can be hidden in iPhoto).

  • nevillev Level 1 Level 1
    Thanks John - it's good to know it works for you.

    Apple closed my bug report, claiming that it works as designed; and that it hasn't changed. This seems wrong to me because it obviously has changed in fact.

    Here's Apple's response to my bug report:
    Thank you for contacting us regarding Bug ID# 8587924.

    Engineering has determined that this issue behaves as intended based on the following information:

    iMovie only supports videos that are copied into the iPhoto library. That has not changed between iMovie '09 and '11.

    We are now closing this bug report.

    I strongly suggest that the other people who are also affected by this problem file additional bug reports. Hopefully Apple will eventually realize that something has gone wrong; and fix it.

  • oldenglish Level 1 Level 1
    I just upgraded to ilife 11. iMovie imported videos from iphoto (I did have the copy to library option checked in iphoto) but only loaded movie clips from iphoto for 2009 and 2010. I could import manually but had to use the Adjust date and time option so they'd be filed correctly (otherwise the date is the current date and time when you do the import). Also, I inadvertently used the Space Saver option which removed all clips from the event library that were not part of a project. How do I get them back?
  • ddelmoli Level 1 Level 1
    Neville -- I'll file a bug on this -- forgive me, but how do I do that? I can't find anywhere to file a bug.
  • ddelmoli Level 1 Level 1
    BTW, on my machine I've found a "workaround"...

    If I right click on my hard disk in the Event Library and select Import Movies..., the Finder Sidebar has items under Media called Music, Photos and Movies. If I select Movies, I get a choice of iMovie, Movies, iPhoto and iTunes.

    If I select iPhoto, I see thumbnails of all of my iPhoto videos -- even though they were not copied into the iPhoto Library.

    You can display them as icons or in a list, and you can do some basic searching by name. For the list view, you can Show Columns: Name, Duration, Dimensions, Size and Kind. Unfortunately Date isn't one of the options.

    Within the iPhoto selection, I can select my folders and the list becomes limited to the videos in each folder. Since my folders are all named Year-Month, I can narrow my selection to a particular set from a particular month.

    So far, this seems to work fairly well as a way to import my iPhoto videos into iMovie...
  • nevillev Level 1 Level 1
    This is a useful work-around - thanks! The only downside (and it can be a big one) is that it makes another copy of the video. Previously they were just "there" and iMovie made thumbnails; but otherwise didn't take up any more space. Still, at least it's a way to get at them.

    Regarding bug reporting: The site is, and you have to sign in with your Apple Id.
Previous 1 2 3 Next