Previous 1 2 3 4 5 6 Next 79 Replies Latest reply: May 7, 2014 7:20 AM by iLee Go to original post
  • freesmith Level 1 Level 1 (0 points)
    thanks for the help but i can not find the Master/Volumes inside my iPhoto Library. i have my iphoto library in the exact same spot you do but i do not have those folders inside...does the symbolic link have to be done to that folder in particular?thanks again for your time!
  • Marco Laurenzano Level 1 Level 1 (0 points)
    If you "show package contents" on the iPhoto library you should at least see a folder called Masters which is basically where iPhoto puts the photos or the links to them.

    Volumes is the folder that will be created when you run the command I wrote.
  • nevillev Level 1 Level 1 (5 points)
    You genius, sir!!

    I did what you suggested - using the path to my iPhoto library, which is on an external drive - and it worked! I now have all my iPhoto videos back in iMovie. I also haven't tried importing new pictures yet - but the link can be recreated, as you say, if it disappears. Why can't Apple do this simple fix themselves?

    Thanks again for sharing your very useful discovery
  • freesmith Level 1 Level 1 (0 points)
    it worked?i can not make it work...
    this is what i iphoto library is inside a folder named iPhoto Library...

    ln -s /Volumes ~/Pictures/iPhoto\ Library/iPhoto\ Library/Masters/Volumes

    i then started imovie and nothing happened.did you do anything else in between?thanks again!
  • Marco Laurenzano Level 1 Level 1 (0 points)
    After issuing the command, did you check that you actually end up with a folder link named Volumes inside the folder Masters of the iPhoto Library bundle?
  • freesmith Level 1 Level 1 (0 points)
    yes, i did. do i have to restore permissions or have the iphoto checkbox of "copy all the pics to the library" validated? anyone else tried this strategy?
  • Marco Laurenzano Level 1 Level 1 (0 points)
    Honestly I don't know what to say. I don't think permission will help and "copy all the pics to the library" will certainly make the problem go away at the cost of transferring all your content in the the iPhoto Library which is something that I suppose you wanted to avoid in the first place.

    Of course the whole trick is supposed to work if the problem consists in having the videos referenced instead of copied. Apparently there are other instances where iMovie misbehaves for different reasons.
  • Level 6 Level 6 (11,035 points)
    When I upgraded to iLife 11, I did not notice the problem mentioned in this thread until I went back and tried to view my movie clips in iPhoto and noticed they show up as still images with no demarkation as a video clip and they of course do not show up in my imovie thumbnails. Worse, I do not seem to have a Masters folder. What to do? Oh, what to do? I have two different weddings somewhere on my hard drive that I can not find. iPhoto will not reveal them to me. I have been working on this problem for two days and I am distraught...totally distraught...these wedding movies were to be Christmas Gifts and instead, Apple has become the Grinch by putting out a product with obvious deficiencies. I think I am actually getting a stress stomach ache. Will someone provide me with assistance and brighten the holidays for many?
  • jvolino Level 1 Level 1 (45 points)
    As you probably realize your core problem is that your iPhoto library seems to be damaged rather than the iMovie bug. If you have a backup of your iPhoto library from prior to the iLife 11 upgrade you could restore that. Then I would update iPhoto as there have been some reports of a bug it has that can cause data loss. Then restore your iPhoto library, open iPhoto, and see if the masters are there.

  • diveactive Level 1 Level 1 (0 points)
    Can you tell me why when i had trouble with 09 know one new the answer why it kept looking for files in MV movie , well i got that sorted my self and a liitle help after up grading to 11 , that started of having the same problem. And the above. No video files. but now there is no aperture or i photo icon on the left m and no stills and no music on the right.

    can i get a refund or stop my card and re install 08 that seemed to do the job. ? Or will my 09 library's
    on other drives not work ?
  • terjes Level 1 Level 1 (0 points)
    Think i might have a solution: Bought iMovie11 and iPhoto11. iMovie would not show any video in the black "screen" in the right side upper corner. Only the video sound was heard. Now and then iMovie even crashed. I got one crash report that gave me the clue - it contained among a lot of other things, the following line:

    Dyld Error Message:
    Symbol not found: _CGCMSUtilsGetMD5Signature
    Referenced from: /System/Library/PrivateFrameworks/GraphicsAppSupport.framework/Frameworks/Quart zComposer.framework/Versions/A/QuartzComposer
    Expected in: /System/Library/Frameworks/AppKit.framework/Versions/C/AppKit

    So, in the link that you can see after "Referenced from", I found the "QuartzComposer" deep in my folders - a little program i think it is - removed it, and everything works!! I did not do anything with the "Expected in"-link.

    Hope this is helpful

    Sincerly Terje (from Norway)

    Message was edited by: terjes
  • terjes Level 1 Level 1 (0 points)
    I have learned now that "QuartzComposer" is an important system file. Removing it will produce other problems with your computer, so dont remove it. It solved the problem with my iMovie, though.
  • burdell1 Level 1 Level 1 (10 points)
    Has anyone found a cure for this? Mine is starting to do the same thing..
  • burdell1 Level 1 Level 1 (10 points)

    I tried this but it didn't seem to help....are there any other things to try?

  • XofDyer Level 1 Level 1 (0 points)

    In iMovie 11, if you can see an iPhoto movie in the event library, but it won't play or plays only as a still photo on the viewer, then try: 1) Reveal in Finder (right click on buggered movie); 2) drag and drop revealed file(s) into RealPlayer converter (free and good); and 3) re-import the files into a new event.