Previous 1 2 3 4 5 6 Next 79 Replies Latest reply: May 7, 2014 7:20 AM by iLee Go to original post
  • XofDyer Level 1 Level 1 (0 points)

    Convert the file to PC or Mac (H.264).

  • patrickfromnanaimo Level 1 Level 1 (0 points)

    I (a computer idiot) managed do fix the problem in iPhoto Preferences, Sharing, Allow Sharing, then I closed all programs and restarted.  My iPhoto videos are once again in my iMovie Event Library.

     

    Bon Chance.

  • Olympus Level 1 Level 1 (0 points)

    I think everyone is blowing this thing way out of proportion. I even jumped on this train because I had the same problem. You have to update the thumbnails in iMovie. Now the only bug I can see is that the dialog box for updating the thumbnails seems to disappear a little too soon. If you start up iMovie then look down at your phone, it could be gone by the time you look up. I have a huge library and it took my iMac a long time to update the library but when it was done, everything looked normal.

  • Little96 Level 1 Level 1 (0 points)

    I've discovered that upgrading to iPhoto 11 breaks iMovie 09's ability to find iPhoto Videos.  The only solution that has worked for me is to upgrade iMovie so that I have both iMovie 11 and iPhoto 11.  Bit of a shame as iMovie 09 was sufficient for my needs, and iPhoto 09 I only upgraded to try Photo Stream which I've since abandoned.  Anyway, upgrading both seems to have solved the problem of not being able to see iPhoto Videos in iMovie.

  • br121 Level 1 Level 1 (20 points)

    I've had the same problem. It has something to do with updating the iPhoto video thumbnails. Sometimes when iMovie opens it updates it - sometimes it does not. Seems to be inconsistent.

  • Stevearoo Level 1 Level 1 (0 points)

    I had this problem out of the blue. Possibly the first time I ran iMovie after upgrading to 10.7.3, though who knows if that's related. It had always worked before - then suddently, no iPhoto videos at all.

     

    Today, iMovie started asking the "generate thumbnails" question again at launch. I'm not sure what I did to fix it. I repaired permissions on the disk, rebuilt the iPhoto library several times with different options. Rebooted. Nothing made any  difference. Then today, I sync'd my phone with a new video on it, launched iMovie, and it started seeing iPhoto videos again.

     

    I don't know what made it quit, nor what made it start again. There are several discussions about this - they all have a bunch of random suggestions. I don't think anyone has figured it out yet.

  • jclorden Level 1 Level 1 (0 points)

    My iPhoto 11 and iMovie 11 worked seemlessly, then suddenly the iPhoto icon disappeared from the iMovie event library.  The timing seems to correspond to the last update of iPhoto (9.2.2) i made the other day.  I also performed a sync between my iPhone and iPhoto that pulled in a new movie.  When i went back to iMovie the iPhoto icon had reappeared in the event library.

  • madmac88 Level 1 Level 1 (0 points)

    Thanks for the tip. I tried downloading photos/videos from my iPhone and opened iMovie afterwards. Then when I click on the iPhoto Videos library it started generating thumbnails again!

     

    I will have to remember this trick...

  • Robby Berman Level 1 Level 1 (130 points)

    Empyting my iPhoto trash fixed this for me, causing a long, but effective, thumbnail rebuild next time I opened iMovie.

  • dr_click Level 1 Level 1 (0 points)

    I discovered a few things:

     

    1. At least for me, using iMovie 11 / OSX Lion, when selecting the "File->Import->Movies..." menu option, I got a file selection dialog whose sidebar included a "Movies" option after scrolling to the bottom.

     

    2. Clicking on "Movies" offered options to view videos in "iMovies", "Movies", and one other place that wasn't iPhoto.

     

    3. It turns out that you also need to have iPhoto running. Once iPhoto is up, "iPhoto" shows up as an option.

     

    Just for grins, iMovie is now claiming that it will take 18 hours to transfer and optimize all of the iPhone videos I imported into iPhoto. Good times!

     

    Good luck,

     

    Ted

  • mikelach2 Level 1 Level 1 (0 points)

    I'd appreciate some advice here. I've had this problem off-and-on for the past few months, always using the latest versions of iMovie and iPhoto. Wth iPhoto 9.3, the database structure appears to have been rebuilt (it's now compatible with Aperature libraries, and there's a new dialogue with rebuilding options when startup with command-option is pressed).

     

    In my iMovie 9.0.6, there's now no iPhoto library listed in the Event Library, and no about of rebuild iPhoto/restart seems to be bringing it back. I sure do miss it!

  • dr_click Level 1 Level 1 (0 points)

    Unfortunately, I have no insights on that front. After importing all of the movies as described, the "iPhoto library" spontaneously reappeared in the Events sidebar. So now I have two copies of all of my pre-existing iPhone videos. That much doesn't bother me - redundant copies are good. But still, I don't understand why it should have suddenly reappeared.

     

    This is iMovie '11 and iPhoto '11.

     

    Ted

  • judesromes Level 1 Level 1 (0 points)

    Don't know if this will help much but appreciated the help everyone else was contributing.

     

    I have iMovie 11 and iPhoto 9 - could not see iPhoto videos.  Awhile ago I had realized that I had 3 iPhoto Libraries on my computer (not sure how or why - another story...)  Anyway, I used iPhoto Library Manager to merge them; then deleted all the "extra" libraries and made sure that the new library was in the Pictures part of the user folder (Users/myname/Pictures). 

     

    When I opened iMovie, it wasn't seeing any photos or videos (I think I confused it by moving the library).  So I closed iMovie, opened iPhoto and kept it open, then opened iMovie.  Sure enough, it started generating ALL the thumbnails.

     

    So maybe if you change the name or location of the iPhoto Library, have iMovie look at that and get "confused," it will sort itself out when you put the library back in place again.

     

    Hope that might help someone.... ;-)

  • Matt Ginzton Level 1 Level 1 (0 points)

    I just want to say thanks to nevillev for describing this problem so well, and to Marco Laurenzano for his workaround. Good on you, Internet.

     

    I don't find iPhoto/iMovie usable unless I get to organize my files how I want (and leave the files visible to other apps whose name doesn't start with lowercase i, too). I don't get why Apple considers their design the only right one, and I'm very happy Marco found and shared this trick.

  • Randy Farnsworth Level 1 Level 1 (35 points)

    I tried many remedies and found that the simplest remedy finally fixed it: delete the imovie preferences file and restart iMovie, which re-builds the thumbnail library.

     

    In finder, option-click Go, then Library, then go to the Preferences folder, then delete com.apple.iMovieApp.plist

     

    This is on OS 10.8 Mountiain Lion, with iMovie '11 and iPhoto '11