Previous 1 2 3 4 5 6 Next 79 Replies Latest reply: May 7, 2014 7:20 AM by iLee Go to original post
  • samo9789 Level 1 (0 points)

    This solution worked for me, thanks !

  • MrsMinton Level 1 (0 points)

    Yes, you are right!  It would be nice if the comment told you that you need to allow the thumbnail updates in order to view your IPhoto videos...IMovie has so many of the great Mac software features, but is a little bit lacking in user friendliness for a first-time user.

  • rnc_matador Level 1 (0 points)

    I tried all the options including Marco's without success. Ultimately, I decided to try to repair the iphoto library ( By holding down CTRL and OPTION while starting iPhoto, I simply reselected the same iPhoto Library. iPhoto opened just fine and when I opened iMovie, I was prompted to regenerate the thumbnails, putting the "iPhoto Videos" option back into the Event Library

  • diveactive Level 1 (0 points)

    Enable i photo to share , and the same with aperture. In preferances

  • konomike Level 1 (10 points)

    Thank you for posting this solution. It solved my issue (sort of). iMovie 11 wasn't seeing any of the recent movies I had added to iPhoto 11. I tried rebuilding everything in iPhoto (holding Option + Command while launching iPhoto), but it still didn't work. Pages could see my videos in the media browser, but iMovie didn't seem to want to acknowledge their existence. I would launch iMovie and it would ask to generate high resolution thumbnails. I would click "Now" and the progress bar would appear and then vanish. No new movies.




    I moved the ~/Library/Preferences/ out to my desktop as a backup and relaunched iMovie. It searched iPhoto and rebuilt its library. My new videos were in there.






    As a test, I took another video with my iPhone, added it to iPhoto, and relaunched iMovie. The same issue. It asked to generate high resolution thumbnails, but failed to find my new video. Unless I can find a better solution, I'll just have to clear out that .plist file every time I need iMovie to find my videos. Frustrating, but better than before.

  • asquires13 Level 1 (0 points)

    Hi Marco,


    2+ years on, this solution worked for me. iMovie would not show any of my Aperture video clips. The message that iMovie was giving me was "no video clips match the current selection".


    I think the important thing here was that my video files in Aperture, like my photos, are all referenced, ie. saved outside of the aperture library itself.


    Creating the Volumes 'Symbolic Link' with the following command made iMovie see my Aperture video files on next restart. This was what I typed into Terminal:


         ln -s /Volumes /Aperture\ Library/Aperture\ Library.aplibrary/Masters/Volumes


    My Aperture library is stored in a folder called Aperture Library in the root of my second hard drive.




    Marco Laurenzano wrote:


    I had the same problem. Then I did some debugging (the kind of debugging that Apple refuses to do since version 8.0.5 of iMovie) and found out that iMovie does find the movies in iPhoto as they are listed in its plist file but the referenced ones appear under a wrong path. Apparently the actual path is appended to the path to the internal folder of the iPhoto Library bundle. End of the technical rant.

    Here is how I fixed it: open the Terminal and type (provided that you have the iPhoto Library in its default location otherwise fix the path with what it is)

    ln -s /Volumes ~/Pictures/iPhoto\ Library/Masters/Volumes

    it will create a symbolic link inside the iPhoto Library bundle so that the paths that are stored in iMovie will have sense.

    I doesn't seem to affect iPhoto. I haven't tried to import new pictures into iPhoto to see if that link disappears but you can always recreate it.
  • Dave Friesen Level 1 (50 points)

    When I put this command "ln -s /Volumes ~/Pictures/iPhoto\ Library/Masters/Volumes" in the Terminal I get this: "No such file or directory"


    None of the iApps can see the iPhoto library.


    10.8.2 with all the lastest updates on everything.

  • G.O.A.T. Level 1 (10 points)

    I've solved the problem by empting the iPhoto trash. Simple solution.

  • idee17 Level 1 (0 points)

    This is what Imovie looks like for me. No Iphoto under event library.

    Screen Shot 2013-04-27 at 1.16.44 PM.png

    Or here:

    Screen Shot 2013-04-27 at 1.20.07 PM.png

    I have tried deleting this file (imovie does regenerate thumnails afterwards):

    Screen Shot 2013-04-27 at 1.12.42 PM.png

    Did al of the repair or rebuild things and emtied trash:

    Screen Shot 2013-04-27 at 1.13.30 PM.png

    Done all of onxy's things, repaired my hard drive and start up disk via disk utility. Restarted, shut down, etc.

    Iphoto and Imovie are 11.

    What else should I try?


    ~Thanks Idan

  • Tigervision Level 1 (10 points)

    I have noticed if this happens. I close everything. Shoot a 15 second bogus video clip with my camera. Slide the sd card in iMac. iPhoto opens. I import that clip. Wait until all is imported and any face detection stops. Remove sd card by ejecting. Then open iMovie. I am then asked to generate new clips. I say now.

    It seems like it forces iMovie to redo everything.


    If this doesn't work. Try another camera to shoot a short bogus clip and retry it.


    Also. IMO. iPhoto is NOT a place to store video clips. I take mine out of iPhoto immediately and copy/store them in iMovie events. Just like iMovie is not a place to store pics.

  • burdell1 Level 1 (10 points)

    Can I just manually put a link (or alias) to Volumes in the Masters folder?

  • JeffMark77 Level 1 (0 points)

    I have a fix for this!! Just got off the phone with applesupport.


    It has to do with refresing a particular file that allows iMovie to connect with iPhoto. Here's how you do it:


    1. close iMovie and iPhoto


    2. Hold down OPTION while clicking on iPHOTO


    3. create a NEW iphoto library, and select this one


    4. put any photo or video in there, then close it


    5. open imovie. iphoto videos should pop back up on lower left


    6. close imovie


    7. hold down option again while clicking on iPhoto. Switch back to original library, open iPHOTO


    8. Close iphoto


    9. reopen iMovie. Await LOOOOONNNGGG refresh of iPhoto videos


    Hope this fixes it for everyone!!

  • Phil Weyman Level 1 (25 points)

    You GENIUS!


    I tried pretty much every other thing mentioned an every other forum and this is the only thing that worked!

  • OldMan100 Level 1 (0 points)

    Had the same problem.  The iPhoto library disappeared from iMovie all of a sudden.  Just solved the problem.


    Closed iMovie.  Opened iPhoto.  Connected my iPhone and downloaded one video to a new event. Closed iPhoto.  Opened iMovie.  The iPhoto library was there.  Refreshed thumbnails.  Everything back to normal.

  • Dan Rohtbart Level 1 (0 points)

    @JeffMark your solution worked. Took a few minutes before I got iPhoto requesting to generate video thumbnails. I may have spurred that by opening the Photos panel and navigating my iPhoto library to a Smart Album of movies.


    For what it's worth, I had been using iPhoto Library Manager to split my library. So I may have brought this upon myself.