Previous 1 2 Next 29 Replies Latest reply: Jul 30, 2012 5:44 AM by Rick Lang
Taro-71 Level 1 Level 1 (0 points)
Hi.
I've just have an issue with soundtrack 1.5 (final cut express 3.5) and the latest Pro kit update:

After updating, Soundtrack won't start no more! (with error: Terminating app due to uncaught exception 'NSArchiverArchiveInconsistency', reason: '* class error for 'MKModuleLayoutManager': class not loaded')

I've tried to restore /System/Library/PrivateFrameworks/ProKit.framework from time machine and Soundtrack works again.

But after another "Software update" SnowLeopard replaced again ProKIT with 6.0.1 killing Soundtrack.

It's very annoying, because I don't know if I need the new ProKIT because, I have FinalCut Express 3.5, Logic Express 8, Aperture 3.1 and the latest iLife '11.

Now I'm confused because the new Update is needed for the lastest apps but it doesn't work with the oldest (not so old).

MacPro (early 2008) 8 Core 3GHz - CinemaDisplay 30", Mac OS X (10.6.4), 24 GB ram - ATI Radeon HD 4870
  • BDMovies1 Level 1 Level 1 (0 points)
    I'm having the same issue. Just checked and there is no patch available. I can't believe a software update is able to be released without anyone realizing it would break an app completely.
  • Pancenter Level 6 Level 6 (8,755 points)
    BDMovies1 wrote:
    I'm having the same issue. Just checked and there is no patch available. I can't believe a software update is able to be released without anyone realizing it would break an app completely.


    It's called the upgrade cycle, it also is called planned obsolescence and sometimes known as, we'll take your money, thank you.

    If all your programs work do you really need the latest OS updates? The answer is No. Is iLife 11 complaining that it doesn't have Prokit 6, I would have to check but does Apple list why the Prokit update id needed.

    Pros have learned that not every update offers the best most stable performance, nor is it always required.

    Thanks for the heads up on Prokit 6, hopefully it will save others some grief.

    pancenter-
  • ncrayls Level 1 Level 1 (0 points)
    Add me to the list of people whose Soundtrack 1.5 will not work now that the latest PRO kit update 6.0.1 was loaded yesterday. Stupid me forgot to backup before updating, now I'm stuck.

    Any suggestions on how to 'uninstall' this last PRO kit update (i.e. which files/folders to remove)?

    I tried reloading Soundtrack to no avail. Same error as noted in original post. Thanks for any assistance.
  • bradbridges Level 1 Level 1 (0 points)
    Same here. Soundtrack quit unexpectedly. Same with all my Macs, Mac Pro, MacBook Pro, & Mac mini.
  • Pancenter Level 6 Level 6 (8,755 points)
    Don't know if this will help... everyone has repaired permissions after the update... correct?

    pancenter-
  • Taro-71 Level 1 Level 1 (0 points)
    It's called the upgrade cycle, it also is called planned obsolescence and sometimes known as, we'll take your money, thank you.


    Ok for the update cycle and the planned obsolescence, but this time it seems a bit premature:

    In this time Final Cut Express 4 is the latest release and don't offers Soundtrack in the box, instead Final Cut Express 3.5 is only the earlier release!
    In the past Apple has accustomed to us whit a log time support for applications in OSX; think about of PowerPC third party applications running in Snow Leopard whit Rosetta, or the support of OS9 since Panther.
    Now I can't absolutely believe Apple want to kill a so early Apple software, with an Apple OS patch, without offer no kind of upgrade: It must be an oversight.

    If all your programs work do you really need the latest OS updates? The answer is No.


    Software isn't perfect, we patiently wait time after time for a patches who fix functionality bugs...

    Is iLife 11 complaining that it doesn't have Prokit 6, I would have to check but does Apple list why the Prokit update id needed.

    Pros have learned that not every update offers the best most stable performance, nor is it always required.


    Ok, but also this time was ambiguous: I've Aperture3 and a lot of bux fix is made with 3.1 and ProKIT was proposed "before" AP3 update, like if it were necessary.

    Also have Logic Express 8 that seems to needs the ProKIT update for compatibility with latest Apple technology.

    Thanks for the heads up on Prokit 6, hopefully it will save others some grief.


    We simply trust in Apple because until now we had a very good bug fixing service, this time something seems gone wrong :/
  • Taro-71 Level 1 Level 1 (0 points)
    Any suggestions on how to 'uninstall' this last PRO kit update (i.e. which files/folders to remove)?

    I tried reloading Soundtrack to no avail. Same error as noted in original post. Thanks for any assistance.


    if you have a time machine disk regularly updated, you can restore the older ProKIT and "come back from the dead" soundtrack, but if you had other Pro/semiPro apps installed I don't know if this can breaks some other OS related dependences.

    This is only a temporary fix.
    To do:

    finder go to: /System/Library/PrivateFrameworks
    open TimeMachine and go back before the update day.

    looking for ProKit.framework folder and restore it

    Now soundtrack bring back to life, and the next software update will recommend you to upgrade ProKIT, obviously it must be ignored.

    we hope soon from Apple a smarter solution.
  • Taro-71 Level 1 Level 1 (0 points)
    Pancenter wrote:
    Don't know if this will help... everyone has repaired permissions after the update... correct?


    Permissions aren't the problems.

    Alas, the framework calls are changed: is visible from the stack trace errors message.
  • Taro-71 Level 1 Level 1 (0 points)
    FYI
    After some (debug) investigation the problem seems to be in a broken call from the file:

    /Applications/Soundtrack.app/Contents/Resources/English.lproj/MainMenu.nib/objec ts.nib

    Probably responsible to the MainMenu bar creation.
  • bradbridges Level 1 Level 1 (0 points)
    Don't use Time Machine, any other recommendations?
  • ncrayls Level 1 Level 1 (0 points)
    I don't use Time Machine either (perhaps it's time to buy it!)

    Anyway, I've got a call with Apple Support scheduled from 8:00-8:15pm EST tonight, I'll reply with hopefully a fix, or at least Apple's feedback that they're working on the issue.
  • ncrayls Level 1 Level 1 (0 points)
    no luck with Apple Support...they suggested I upgrade to Final Cut Studio for $999. Nice try. There is no way to 'uninstall' the prokit 6.0 update. Tech guy said I'll to do a full re-install of my system and just not update to the prokit 6.0, or do the expensive upgrade which has soundtrack pro in it. I'll start looking into the less expensive cleansing and reinstall of my system. bummer.
  • bradbridges Level 1 Level 1 (0 points)
    Clean install all my Macs????? No thanks! This is some BS!
  • Rick Lang Level 4 Level 4 (1,230 points)
    Thank you very much! Restoring the ProKit from last March (ProKit 5.1) did the trick. My ProApps continue to work (Final Cut Express and Aperture and now Soundtrack). If and when Apple releases Final Cut Express 5, then I’ll likely upgrade from FCE HD 3.5.1 but it’s a great product.

    Here’s the Software Update note for ProKit 6.0.1:
    This update is recommended for all users of Final Cut Studio, Final Cut Pro, Motion, Soundtrack Pro, DVD Studio Pro, Aperture, Final Cut Express, Soundtrack, Logic Studio, Logic Pro, MainStage, WaveBurner and Logic Express.

    Obviously Apple needs to quickly update ProKit or alter the recommendation re Soundtrack.


    Ooops! i spoke too soon, now iPhoto ’11 won’t start. I had just installed iLife ’11 before replacing ProKit 6.0.1. I’ll try a reinstall of iLife ’11 using the old ProKit 5.1.

    Message was edited by: Rick Lang

    Message was edited by: Rick Lang
Previous 1 2 Next