Previous 1 2 3 Next 38 Replies Latest reply: Mar 23, 2011 9:38 AM by RandyMassey Go to original post
  • gobeezer Level 1 (0 points)
    I'm in the same boat as Jim -- got iLife '11 for Christmas, and new iPhoto keeps freezing my white Intel 24" iMac with NVIDIA GeForce 7300 GT. The freezing occurs even after I create a fresh new library and import a few photos. The system eventually comes back after a freeze, sometimes with partially corrupted windows/graphics on the screen.

    It does sound kind of like a graphics/driver issue, though I've seen others complaining of iPhoto '11 freezing with newer Macs as well. At any rate, what can I do but wait for a fix from Apple? It's all their hardware and software. Very disappointing.

    Any informed suggestions are welcome, and of course I can provide additional info if it would help.
  • Chappsnet Level 1 (0 points)
    Yeah, I'm stuck in the same boat. I was fine with iPhoto 09, then as soon as I installed and fired up iPhoto 11, everything I did in the app froze my entire system. You have to wait for the system to unfreeze and do a force quit.

    I've also got an iMac with the NVIDIA GeForce 7300 GT graphics card.

    The question is, how can I roll back to iPhoto 09, now that my photo database has been upgraded to 11?
  • gobeezer Level 1 (0 points)
    Chappsnet, I don't know of a way to revert your '11 library back to '09 format, other than restore the '09 library from backup (if you have one).

    Searching these forums for "NVDA(OpenGL): Channel exception!" shows A LOT of interesting discussion on this and related nVidia problems, going back a year or two. As I just posted on one of those threads, here's an update from my efforts:

    I have a 2006 white Intel iMac 24" with 3GB RAM and nVidia 7300 GT, running Snow Leopard (was 10.6.5, now 10.6.6). When I try to use iPhoto '11 (9.1.1), the system freezes quite regularly when performing simple operations like double-clicking a photo for viewing/editing. "Freeze" means the mouse cursor still works, but the user interface is otherwise completely unresponsive for up to a few minutes. Once I get control back, the graphics on screen sometimes appear corrupted. During the time of a freeze (and no other time) there are always Console messages as follows:

    1/9/11 8:53:35 PM kernel NVDA(OpenGL): Channel timeout!
    1/9/11 8:53:35 PM kernel NVDA(OpenGL): Channel exception! exception type = 0x6 = Fifo: Parse Error
    1/9/11 8:53:35 PM kernel 00000069
    1/9/11 8:53:55 PM kernel NVDA(OpenGL): Channel timeout!
    1/9/11 8:54:15 PM kernel NVDA(OpenGL): Channel timeout!
    1/9/11 8:54:36 PM kernel NVDA(OpenGL): Channel timeout!
    1/9/11 8:54:36 PM kernel NVDA(OpenGL): Channel exception! exception type = 0x6 = Fifo: Parse Error
    1/9/11 8:54:36 PM kernel 00000069
    1/9/11 8:54:56 PM kernel NVDA(OpenGL): Channel timeout!
    1/9/11 8:55:16 PM kernel NVDA(OpenGL): Channel timeout!
    1/9/11 8:55:16 PM kernel NVDA(OpenGL): Channel exception! exception type = 0x6 = Fifo: Parse Error
    1/9/11 8:55:16 PM kernel 00000069
    1/9/11 8:55:36 PM kernel NVDA(OpenGL): Channel timeout!
    1/9/11 8:55:56 PM kernel NVDA(OpenGL): Channel timeout!
    1/9/11 8:56:16 PM kernel NVDA(OpenGL): Channel timeout!

    I submitted a detailed report using "iPhoto -> Provide iPhoto Feedback", and as advertised did not hear anything back.

    I'm also in the process of working through Apple tech support. I've been bounced around to several people, all of whom were polite but dismissive when I described the Console messages and the numerous detailed reports on these forums of the identical problem with no cure. They note that there's a lot of negativity and misinformation on user forums, and then ask me to try a series of things like deleting old preferences, creating a new iPhoto library, etc. They've graduated me to senior tech support, and the last thing they had me try was:

    Create a brand new partition on my hard drive, install Snow Leopard and iPhoto on it from scratch, and create a tiny iPhoto library by dragging in a dozen images from /Library/Desktop Pictures/.

    On that bare-bones setup I've confirmed that iPhoto '11 has lots of freezing, whereas iPhoto '09 works flawlessly. Senior tech support had me capture some system info during one of the freezes, and has sent it to engineers with hopes of hearing something back this week.
  • gobeezer Level 1 (0 points)
    After a few weeks, I got another update from senior tech support by voice mail over the weekend:

    * He's still waiting on engineering for a solution for getting iPhoto '11 to work on my system
    * At this point in time a workaround would be to go back to iPhoto '09

    So there you go.
  • Alan Routh Level 1 (5 points)
    My Mac Pro with an NVIDIA GeForce 7300 GT has all these same problems. Have reported numerous times to Apple. Still no fix on the horizon.
  • J.Dietz Level 1 (0 points)
    FWIW, I have the same lock-up issues with iPhoto '11, though I have a Mac Pro 1,1 machine with an ATI upgrade card and not an Nvidia card. Near as I can tell the trouble starts with double-clicking on a photo to zoom in, so no editing or other operations required. It appears that on the fourth or fifth picture you look at, the app implodes and manages to take the whole Mac down with it - a serious feat in OSX if you ask me.
  • weezimp Level 1 (10 points)
    I recently updated to iPhoto '11 and I have the same problem. Locks up for several minutes. Seems to have trouble sharing/switching focus with other applications that use OpenGL (in my case, Adobe Lightroom). I started to prepare to try to regress it to '09 and opened it up in its own Spaces window and I was able to export all my recent iPhone photos without any issues. Hmm.
  • Anastassios T Level 3 (815 points)
    A friend of mine, that has an iMac with the 7300GT told me that the latest Mac OS upgrade seems to have fixed the problems he was having with iPhoto. You should try it and see if it works for you. Let us know,
  • RandyMassey Level 1 (0 points)
    I have a Quad core Xeon 3.0 GHz, with the oft mentioned Nvidia GeForce 7300 graphics card & had this very same issue, with 10.6.5 & iPhoto from iLife 11. It would lock for up to about 5 minutes & then, at least allow you to quit the app, locking the OS in the process, until the successful quit was finally allowed to happen, then everything was just fine. Nothing worked on my tower for the new iPhoto save just scrolling the main photo's window, that I could do, now, my ATI 2.33GHz C2D & newer Nvidia 330M i5 Macbook Pro's did work, with the very same 20 Gig iPhoto data file copied over, so same data file on all 3 systems.

    Anyway, I applied the 10.6.7 UD to the Xeon tower with the nVidia 7300 GT & now it seems resolved 100% on the tower. YAY, & I definitely tested the heck out of it. Not one lock up.

    The new iPhoto is a bit graphics heavy on that 7300 Nvidia card, so I did think about getting the new Radeon 5770, since a "different" card would have also been a solution, but vs an OS update, def, a much costlier one.

    Anyway, I saw the post mentioning 10.6.7 & then no one posted after that, so I thought I would add a blurb to let people know if you have this configuration, def give it a try, (I did not go to 10.6.6 from 10.6.5, but I hear that did not work either, so as I understand it, it is tied to fixes in 10.6.7).
Previous 1 2 3 Next