Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: itunes not connecting via airplay on wired and wireless network

I have some computers on the wired part of my network, and others on wireless. My appletv2 shows in itunes on ALL (both wired and wireless) computers that there exists an AppleTv airplay speaker, but only the computers on the same "side" of the network (wired, or wireless) can actually connect and use the appletv as an airplay device. I have Bell Fibe25 and they provide 2 devices to achieve wireless connectivity, the main VDSL unit that has 4 lan ports on the back, and a basic Cisco WAP610N that connects into one of the lan ports on the VDSL unit for the wireless part.

My firewall is turned off as well.

Can anyone shed some light on why this is happening? My MacPro does not have wireless, and it would not be practical to connect my AppleTV2 to Ethernet cable.

Thanks in advance,

S

Mac OS X (10.6.4)

Posted on

Reply

Page content loaded

Oct 23, 2010 6:42 AM in response to Shane Scott In response to Shane Scott

Shane Scott wrote:
My MacPro does not have wireless, and it would not be practical to connect my AppleTV2 to Ethernet cable.


while it doesn't answer your original question, you might want to consider getting a pair of *powerline adapters* _*such as these*_ if you don't get your issue resolved.

J GG

User uploaded file

Oct 23, 2010 6:42 AM

Reply Helpful

Oct 23, 2010 8:23 AM in response to Shane Scott In response to Shane Scott

I finally was able to solve my problem by following the instructions below (pulled from another thread regarding airtunes) to disable IP6 settings in the network. When I did this, I was able to connect to everything just fine.


So people; when you have problems with iTunes not connecting to your Airtunes maybe you can try the following:
1. Open System Preferences
2. Open Network pane
3. Select Airport in the left list
4. Click the Advanced button
5. Go to the TCP/IP tab
6. Set the "Configure IPv6" field to Off.
7. Click "OK"
8. Click "Apply"
9. Let iTunes connect to you're Airtunes speakers

Message was edited by: Shane Scott

Oct 23, 2010 8:23 AM

Reply Helpful

Dec 11, 2011 4:03 AM in response to Shane Scott In response to Shane Scott

I have Windows 7 and the same resolution fixed my problem but you do it in a slightly different way:


  1. Open Control Panel.
  2. Network and Internet
  3. Network and Sharing Center
  4. On the left menu bar select "Change adapter Settings"
  5. Right Click on Network Adapter (Might be Wireless or Wired or change Both) select Properties
  6. Under "The connection uses the following items:" UNCHECK - Internet Protocol Version 6 (TCP/IPv6)
  7. Click OK
  8. Restart Itunes and refresh Connection! 🙂



Thanks for your help Shane

Dec 11, 2011 4:03 AM

Reply Helpful

Oct 15, 2016 10:11 PM in response to Shane Scott In response to Shane Scott

Was interesting, new to wireless connections, just bought Airport Extreme. I wanted to leave my IMac 2008 hooked up to the wired cable modem connection, and have wireless capability for using MacBook Air, and my two iphones. How did you do this, using both wired and wireless?

Oct 15, 2016 10:11 PM

Reply Helpful
User profile for user: Shane Scott

Question: itunes not connecting via airplay on wired and wireless network