7 Replies Latest reply: Dec 7, 2010 9:05 PM by iMacaroon
Woodwose Level 1 Level 1 (0 points)
I have a LaCie Cinema HD which has about 500 Gb of movie files on it. I had it connected to my Airport Extreme by Ethernet. I then have my iMac on a wireless network and could transfer files from my iMac to the LaCie with no problems. I then tried using a wifi dongle on the LaCie rather than the ethernet connection. Again it just worked fine. I was a little worried about security on my iMac as I had set it up straight from the box as a single user, which I since learned was an administrator account. I reinstalled my iMac (after reformatting its internal disk) and set it up as a 2 user system (administrator & standard) as recommended in the magazines. My problem now is that whenever I try to copy files to the LaCie (using either account) I get a window asking me to "type an administrator's name and password to allow Finder to make changes". When I do this I then get another window saying "one or more items can't be copied to (folder on LaCie) because you don't have permission to read them. Do you want to copy the items you are allowed to read?" There are "Stop" & "Continue" buttons. Nothing happens regardless of which button I click. I can copy files from the LaCie to the iMac but not the other way round. LaCie tech support suggest resetting my LaCie (which would wipe the files on it!). I'm reluctant to do that as a) I can't afford to buy another external drive to back 500 Gb of files up first & b) I don't think that solution will make any difference anyway. There seems to be a few people with this problem with external drives but all my web searches seem to relate to Linux & OS 9 systems, or NAS drives from other manufacturers that have eventually issued a patch. I think the problem is with my iMac rather than the external drive. Any ideas anyone - please! I'm on the verge of going back to the dreaded Windows, I'm that desperate!

iMac 24", Mac OS X (10.6.4), Airport Extreme Dual Band
  • fjonga Level 1 Level 1 (0 points)
    Same here. Extremely annoying. LaCie drive won't permit to copy to a mapped network drive. Somehow I don't think this is a LaCie matter, but some quirk in the OSX.

    Maybe it's finally time to switch back to Windows and ditch the OSX.
  • Woodwose Level 1 Level 1 (0 points)
    Finally sorted it! You have to take the drive off the network and connect via USB. Once done, Cmd I on the drive (to Get Info). In the window that appears, look under "Shared" and untick the "Ignore Permissions on this Drive" box. Disconnect from USB & reconnect to the network. Hey Presto!
  • iMacaroon Level 1 Level 1 (25 points)
    I have similar problem with Seagate drive (http://discussions.apple.com/thread.jspa?threadID=2637705&tstart=0). After you did the disconnect, reset of permissions, how was your "Guest" account showing in Airport Utility, as "Read/Write" or "Read Only".

    I think my problem is in Finder but not sure. I am reluctant to allow "Guest" privileges to be "read/write" as my external HDD is my central backup for Dell/iMac machines (although each machine has separate backup).
  • Woodwose Level 1 Level 1 (0 points)
    I changed the permissions to Read/Write in an earlier attempt to try to solve the problem. However I wasn't using Guest (in fact I'd disabled the Guest Account). I was logged in as "Standard". In your case I too would be reluctant to allow privileges to Guest. I also think Finder is the culprit but I don't know my way round to be sure(I've had 20 years experience of Windows and I'm finding the switch to Apple problematic).
  • iMacaroon Level 1 Level 1 (25 points)
    I've been in the process of switching from Windows to Mac since 2008 when I got the iMac. The primary reason was I needed a new desktop and Vista wasn't cutting it for me.

    The single biggest complaint I have about Apple OS is this exact problem, the Mac OS will subversively make a decision and take control over certain aspects of the computer from the Administrator, without prior approval. And then this control is very difficult to regain. I realize this is a safety feature but it is one that simply doesn't exist in Windows, at least I can't remember a situation where it happened... I've also been using Windows since 3.1 was a baby.
  • BigDave2112 Level 1 Level 1 (0 points)
    iMacaroon wrote:

    I realize this is a safety feature but it is one that simply doesn't exist in Windows, at least I can't remember a situation where it happened... I've also been using Windows since 3.1 was a baby.

    I find it difficult to believe that you've been using PC's since you were a baby and have never run across a locked file in Windows? The locked file issue is so pervasive in Windows that at least half a dozen utilities have been written to alleviate the issue.

    We're getting off topic, but I thought it bad form to vent your frustration with your own inexperience with Mac OS X, by claiming that Windows doesn't also "hide" advanced functionality from the GUI. I could name several dozen critical Windows utilities that can only be accessed via CLI.
  • iMacaroon Level 1 Level 1 (25 points)
    Actually what I posted is true...and in fact, I've never encountered a locked file or hardware where Windows won't "give me permission" to an otherwise fully functioning program/file/hardware. I have had many instances under Windows where I've had to reload drivers or re-install programs due to crashes or other fault in order to regain access to them. That is not what I am talking about here...

    Here I have a fully functioning external hard drive that I can access right now if I go into Airport Utility and throw a software switch. But before I upgraded from Leopard to Snow Leopard, I was able to accesss without issue. In this instance, the software decided to deny me, the Administrator, full access for some unknown reason.

    I am not arguing a point here, just want to be clear about this problem...BTW, I recognize my inexperience wiht Mac OS but thus far no one has been able to help me fix this problem...

    Message was edited by: iMacaroon