Previous 1 2 3 4 Next 86 Replies Latest reply: Mar 1, 2015 3:29 PM by Laura Cameron Go to original post
  • pureutah Level 1 Level 1 (0 points)
    I was having the same issue of "Not enough room in Heap Zone" and I figured it out... I have recently added some clips to my events library (200 clips to be exact). I noticed that the clips did not import correctly so I deleted them from my User/Movies/iMovie Events folder reopened imovie and it fixed the issue. I re-imported the clips and everything is working fine.
  • Tom Wolsky Level 10 Level 10 (111,055 points)
    How not correctly? What was wrong with them?
  • Jason T. Level 1 Level 1 (0 points)
    For what it's worth, I had this exact problem yesterday with my iMac i7 27 inch, plenty of hard drive space, and 4 gigs RAM. I was trying to export about a 7 minute video shot into a Full HD movie. I was able to export as a 720p but not the 1080p option in iMovie 11. I figured it was memory since the file size for the 1080p version is about a Gig, and the latter was only about 500 megs.

    Then I read in this forum and a couple others sights that you can't have special characters in the project names. I had a "hyphen" in mine, and sure enough I changed that and restarted and I was able to export the movie. Seems quirky, I don't know what the correlation is. Applecare was useless as usual and they told me they had never even heard of the "Heap Zone" error before except with iDvd.

    I guess that was the problem, although I suspect with my 4 gigs of RAM I might have been running short on memory. Activity monitor had me only using about 2 gigs of it, so who knows. I should get more memory I guess anyway.

    Hope this helps, that was two Sundays in a row that iMovie consumed most of my afternoon figuring out stupid errors.
  • Chiumeister Level 1 Level 1 (0 points)
    if the problem is with special characters in the file name, then why did it worked for the 720p version trailer and not the 1080p version?

    thanks
  • Splurtizzle Level 1 Level 1 (0 points)
    NONSENSE!

    you guys are all "experts" but are claiming to have a solution which isnt true.


    its nothing to do with characters, i tried renaming my movie 5 times. I used hundreds of clips, well about 40, and i cant go eraseing each one and exporting a 8 minute movie to wait and see an error

    anybody really figure this out

    whats a heap zone, whats apple saying

    HEY STEVE, this is a serious problem!
  • MrPiv Level 1 Level 1 (10 points)
    Same problem with heap error, same solution: remove a hyphen from the project name. I was then able to do a 1080p movie export without the error. This may be only one fix for the problem, though since it didn't seem to work for others. Since others had to re-import clips to fix it, my guess is that the project XML has got issues that relate to path names.
  • Freedomhawk1776 Level 1 Level 1 (0 points)
    I totally agree Splurizzle, this is a serious problem!!! I have a movie that is 54 minutes long and two that are 8 minutes. I have published the 54min movie to media browser and then burned to a DVD using iDVD once before with no problems. We maked some minor changes to the movie and now I cannot publish the movie. I get a error that there is not enough room in the heap zone. I call Apple Care iMovie experts and they act like they have never heard of a heap zone. One Apple Care guy said since I am trying to make a DVD I should share the larger movie straight to iDVD. I shared the other two little movies to the the media browser and had no problems. I tried the larger movie again but this time to iDVD, same error. Called Apple Care again, the guy was a system guy this time, not an iMove guy. He looked on this forum apparently because he said he was reading in a discussion group that you can't have any special characters (which i didn't) and sometimes renaming will fix it. Renamed it and STILL GOT THE HEAP ZONE ERROR. He told me how to varify and repair disk permissions. Did that. STILL GOT THE HEAP ZONE ERROR.

    I was also having problems with iMove not saving captions on title slides and movie clips. I have had to go back a half dozen times to put the same text in. It is saving audio and video changes to the iMovies but the text would either disappear or revert back to an earlier version of the text. I even restored iMovie from Time Machine and the text were still not correct. Apple Care was no help.

    Apple needs to address these issues.
  • James Croft Photography Level 1 Level 1 (0 points)
    I ran into the same issue, and found a couple of different things: first, that I had two clips that imported at only 2 fps, which could have caused issues. The second was a simple fix: restarting the machine. After that, the issue was gone, and my HD movie has rendered nicely. It could be iMovie trying to allocate memory to the dump files that it's already used???
  • Robert LLerena Level 1 Level 1 (0 points)
    same disaster occurred with my project, 1st thing that happened I closed my laptop and editing for hours that day, total of 3 months editing actually, when I reopen laptop and imovie the next day , it's ALL GONE! everything, from this I learned , DUPLICATE , BACKUP, BACKUP, DUPLICATE PROJECT. it was a 360gb project/events size so it was a lot to back up, but after editing all that over again , it had to be done. Next disaster -this HEAP ZONE B.S., fixed it by renaming and haven't tried anything else since, but definitely worth a try. the most important lesson I learned - IMOVIE IS NOT A PROFESSIONAL APP, DO NOT USE iMOVIE FOR IMPORTANT WORK, YOU WILL LOSE, PLEASE LEARN FROM MY HUGE MISTAKE.
  • iGhost Level 2 Level 2 (200 points)
    You say:

    "Next disaster -this HEAP ZONE B.S., fixed it by renaming"

    What exactly did you rename?
  • AnTMaNKicK Level 1 Level 1 (0 points)

    Make sure that nothing is plugged into the computer. (i.e. iPod, iPhone, External Hard Drive). I ejected and removed all external connections and it resolved the problem. I guess the Mac gets confused when multiple external products are connected to the machine.

     

    Hope that this works for all.

  • Mandolin Player Level 1 Level 1 (0 points)

    I had the same problem with an hour long movie.

     

    It worked after restarting the computer.

     

    I had also disconnected all peripherals, so I'm not sure which corrected the issue.

     

    If you have the heap zone problem try restarting first, as I assume that is what corrected my problem.

  • Luke Kwan Level 1 Level 1 (0 points)

    Which speical characters did you have?   I have an " &" in mine.  and i can't get it to export!

  • HappyFestivus Level 1 Level 1 (0 points)

    So far we have the magical rename, unplugging external devices, the always friendly reboot, removal of special characters, re-import your clips, export at a different resolution, transcode your assets to different settings, did I miss anything?  Has anyone tried pixie dust and taping some four leaf clovers to the keyboard? 

     

    Anyone from apple want to chime in here?  Can we get this nonsense to just work?

  • payforsoup Level 1 Level 1 (0 points)

    same issues here. running lion with 16 gig ram mac pro imovie 11. 45 minute  movie. renders perfect in 720, errors everytime in 1080. no special charectors , no pixie dust.

     

    really annoying.

Previous 1 2 3 4 Next