Skip navigation

Imovie 11 export problem. Not enough room in Heap Zone. I have 32GB of RAM!

98204 Views 85 Replies Latest reply: Nov 8, 2013 12:32 PM by gilhouse RSS
  • BookX Level 1 Level 1 (10 points)

    I agree with you. Converting it is fine and does work pretty well. I convert it to mpeg4 w/o problems and even Apple Intermediate Codec at 1080 single pass encoding...

     

    I've noticed that during encoding in Max multi pass quality, free RAM kind of gets less and less available to the point where the error pops-up... Encoding starts nicely with 4.4 Gigs to spare, but after 15 - 20 minutes, I even seen it only at 720MB to spare...

    Time Machine is not even configured and the only running app is iMovie, yet strangely lacks RAM. I'm still looking what else did I missed... I did everything by the book and no culpirit found.

     

  • tysodrum Calculating status...

    Hi Same issues here...

     

    MBP 360 (70 gigs available) 2 gigs ram...

     

    I have a little different project here becasue mine is 2:02...2 hours yeah... That was a mistake but I'll get to it...

    This was my first time getting to that length in iMovie ever... I stared in '09 and ran into a problem..."unknown error" when exporting the movie (which was at 2:30 at the time) I was able to bounce to "large" but not HD 1080. I also had the 2nd half to this movie coming in at 1:20 that exported completely fine in HD...took about 3hrs but that's fine with me...

     

    SO, i felt my machine wasn't up to par and I wanted more answers so I took it to the Genius Bar and that guy had nothing...Said everything looked good...rebooted, PRAM, he installed iMovie '11 for me for free....all in all not bad.

     

    My confidence was restored (especially after this being my 3rd machine in a year and half with major driver errors) and I was ready to finish...

     

    As for my projecet, I was converting ALL my video files with top quality converter into .MOV I didn't evern want to mess with that so I went direct to .MOV. I made my origninal projecet smaller by dublicating the project 2x (that was the recommendation of the genius guy so i can cut and edit what I want in parts 1 & 2) I thought that was good.. I did that, completed the edits...

     

    I'm left with 2 videos to export:

     

    One at 2:03

    and one at 1:33

     

    I went for and "export movie" in HD 1080 yesterday for the big one and 15 hours later I get....yes, HEAP SPACE unreal. I am so ******...

     

    No special things in the name etc... I am going to try what Bryan F. mentioned... I am also going to rename the project to a one word title and we'll see if it that has any sucess... I'll of course restart and just leave iMovie to do it's thing only...

     

    Thanks...I can't believe this is an issue..I would imagine maybe with my file/project size but not some of your 8 min projects...

     

    Any other thoughts out there??????

  • Juuno Calculating status...

    Thank you, BookX - your solution was easy for me to understand and it seems to have worked.  Thank you thank you thank you! 

  • loach1969 Calculating status...

    Hey Brian.

     

    Just read your post from last year. Interesting. I've tried everything, and still i'm getting the "heap zone" while trying to export my 2 minute movie from iMovie '11.

     

    Please excuse my slowness at all this, but would you mind repeating exactly what i need to do? You wrote that you open the movie in QT Player and then export - is this after you have exported in Apple Intermediate Codec? I've tried all that and still iMovie either crashes or i get the heap zone window.

     

    Any help would be much appreciated.

     

    Kindly,

     

    Lee (Loach) Eldridge

  • rémon Calculating status...

    Got the official feedback from Apple (after I paid real cash for Apple Care), that iMovie is not a professional video editing software and can not handle larger files ....

     

    The only possibility to edit the movies is to upgrade to a profi programm like Final Cut or one from a third party.

     

    WAY TO GO APPLE !!! 

  • BookX Level 1 Level 1 (10 points)

    Hello Everyone,

     

    I ran several tests and performed some monitoring on iMovie to get a better analysis of the whole scenario over time.

    I did Memory Leaks Allocations tests, using Instruments (on Mallocs) choosing iMovie for target while rendering out iMovie projects (Share) to my Mac. I am not going to list the results log on this post because the list is very large, though I had to download and install Developer Tools Xcode to check for memory leaks.

     

    It is known, that any graphics intensive application, is using Quartz engine on Macs. At first, I noticed a solid memory leak pattern while launching iMovie with any of my video projects, even with an empty project… So, I looked deeper into the way virtual memory was allocated, how much and by what apps. There were some third party apps that use/allocate the memory even when they were not launched.

     

    I've downloaded AppCleaner from App Store (free) and with it, I've uninstalled the following third party applications previously installed by myself:

     

    Flip For Mac

    VLC

    HandBrake

    RealPlayer

    and...

    lastly, I dragged the iMovie app icon from Application folded to the Trash bin.

     

    After uninstalls, I performed maintenance with an app called CCleaner (free on Apps Store). One last step, I used Disk Utility to Verify Disk and to Repair Disk Permissions on the main HDD. Then, I quit all apps and rebooted my Mac and launched the App Store.

     

    At App Store, in the the right pane, in All Categories I clicked on Apps Enhanced for OS X Lion. There is a list of apps, refined, reprogrammed and rebuilt as such to work flawlessly on OS X Lion. I clicked on iMovie to purchase, download and install it. Since then, I din't have any issues exporting/sharing to an mov file at all. All I can say is, I hope the "not enough room in heap zone" error is gone for good. So far, I've been challenging the new iMovie install, with all sorts of lengthy and sophisticated video projects.

     

    I will let you know if iMovie encounters any errors or crashes after this update. So far, I cannot say, or claim, this is a permanent solution since is not verified over longer period of time...

     

    Best regards.

     

    Message was edited by: BookX Please note that "not enough room in heap zone" error is a memory leakage issue caused either by the running application or, by any other adjacent running (or not) app.

  • loach1969 Level 1 Level 1 (0 points)

    Hey BookX.

     

    I appreciate the ideas and advice. I might try what you've suggested and go from there. Otherwise, it's a FOURTH trip to the Genius Bar to use more of my Applecare.

     

    Cheers and all the best.

  • BookX Level 1 Level 1 (10 points)

    Sorry guys... iMovie is not up to speed and this time it crashed with this in the log file:

     

    "Exception Type:  EXC_BAD_ACCESS (SIGBUS)

    Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000073

     

    VM Regions Near 0x73:

    --> __PAGEZERO             0000000000000000-0000000000001000 [    4K] ---/--- SM=NUL  /Applications/iMovie.app/Contents/MacOS/iMovie

        __TEXT                 0000000000001000-0000000000442000 [ 4356K] r-x/rwx SM=COW  /Applications/iMovie.app/Contents/MacOS/iMovie"

     

    So, there ts something about writing to some areas that the OS is preventing iMovie to write to... I've checked the phisical RAM and is okay.

    I can't uderstand the reason why and, I can't speculate it at all... I am clules, but here it is anyway: there is still a VM issue somere in pagefile... perhaps iMovie is not allowed to write in this location?

     

    Anyone from Apple can you see what's this all about? There's got to be a way to resolve this... can someone answer to this? Why iMovie acts so weird?......

     

    Tx

  • BookX Level 1 Level 1 (10 points)

    P.S. I DON'T CARE ABOUT POINTS on these posts! What I care about is to have my OS systems working w/o meager  hiccups… especially the weird ones that shouldn't be there in the first place… those that don't make sense to me.

    You wouldn't see me here at all if I didn't have problems with my new OS system...

  • Noreen KB Calculating status...

    I also want to join the ranks of people thanking Brian Flaherty.  I followed his advice and it worked.  Prior to following Brian's advice, I received the following error messages:

     

    Unable to prepare project for publishing

     

    The project could not be prepared for publishing because an error occurred. (Error in user parameter list)

     

    The project could not be prepared for publishing because an error occurred. (Not enough room in heap zone / )

    I had already shut down everything other than iMovie, the project's file name did not include any unusual characters, and my 1TB HD, 16RAM 27 inch iMac should have been able to handle exporting the movie project, but it couldn't (more than 350 GB free).  I followed Brian's advice pasted here from earlier post:

     

    "THIS FIXED THE PROBLEM FOR ME: Use iMovie to "Export Quicktime", set to Apple Intermediate Codec at 1080. I then open this movie in Quicktime Player, and Export. This export works, and is H.264 1080"

     

    We then experienced other problems, but eventually resolved them.  I needed to copy the movie onto DVDs to distribute at a swim team banquet, but new Macs are shipped w/o iDVD installed.  (My attempt to install that a few weeks ago corrupted my iPhoto library so I didn't want to try that again.)  Instead, I air dropped the movie project over to my son's older 27 inch iMac (running same OS and iMovie but also has iDVD).  He could only hear the audio file but not see the video. (No idea why.)  Then air dropped to other son's Mac Book Pro and transferred from MBP again to first son's older 27 inch iMac.  The audio and video both transferred this time, and we were able to succesfully burn to discs. 

     

    My son wasn't able to export to QT from the air dropped file.  We also were not able to transfer the file from my computer to his using an external drive as two different Mac-formatted drives gave us error messages.  I don't know if the back-up drive's error message has anything to do with the Apple Codec selected.  I have backed up other iMovie projects to these drives but they were not exported using Apple Codec.  I do need to resolve that issue so that I can transfer the Movie project to the back-up drive and get it off my HD, so if anyone has any suggestions, would love to try them.

     

    Thanks again, Brian.  Your advice really saved me yesterday, especially when we arrived at the venue to discover that they needed a disc to play in their DVD player/projector set-up.  We had brought our MBP and our own projector planning to play movie off the laptop, but the club couldn't get it to communicate with their sound system. 

  • rrweather Calculating status...

    I just discovered the Heap issue. I tried using "Bryan's Method." I can sucessfully export the movie to QT. I can watch it in QT. When I open it in QT and try to export it, it appears to work; however, when I open the QT export, there is no picture and no sound. The video acts like it is playing but there is nothing to see or hear. I'm not sure if I have selected something incorrectly. Obviously I can watch the export to QT but the file is huge and I can't watch it on anything other than the iMac I used to edit the movie. I've tried twice and both times I ended up with a black screen and no sound. Anyone have any ideas on what I may have done wrong in the proces? Thanks for the help.

  • Mandolin Player Calculating status...

    First thing to try is restarting your Mac. That worked for me.

  • rrweather Level 1 Level 1 (0 points)

    Last night I tried resetting the PRAM, as described above. I then tried finalizing the movie in iMovie. It took all night but worked. My movie is 56 minutes long. This morning I was able to export it to my desktop. I haven't tried exporting it to the web but so far, so good. Either I got lucky or resetting the PRAM fixed it for now.

  • wtjanaka Calculating status...

    This problem has lingered since 2010. Has anyone truly found the solution? I have a new macbook air, 4GB RAM, 250GB SSD. I had the same heap zone problem a few days ago (yes, it is 2012). I tried all the "suggestions". None work. I did notice the memory leaking issue. iMovie literally chewed up all the RAM and eventually crashed and burned..... I also found out that iMovie is a 32-bit app. So, the extra RAM beyond 4GB may not be useful.

     

    I went to Apple Store. They gave me iDVD (yes, it was missing from original install). However, my problem is still not fixed. I am about to bring the laptop back to Apple Store again.

     

    BTW, iMovie works with 4:3 format. Once, it goes to 16:9 format, pretty much 720p or beyond would be hopeless. This is not an intermittent issue. It consistently fails every time.

  • wtjanaka Level 1 Level 1 (0 points)

    After 2 trips to Apple Store and 3 days of self-denial, I have come to realize that iMovie is just an amateur software. I set my expectation too high. In terms of processing capability, iMovie is on par with Windows PhotoStory. The difference is that PhotoStory tells you upfront once you have reached the limit. iMovie chooses to just crash and burn. MovieMaker on Windows 7 is more robust. I don't recall any limit. MovieMaker may take a long time to process big movies, but it does not leak memory and crash. So much for paying more money for an Apple machine and the touted user friendliness.

     

    To get around the problems:

    - I had to chop up the slide shows and movies into smaller chuncks. l ended up generating a few .mov files. I used Activity Monitor to monitor the memory usage. I think if the processing time is about 20minutes or less, it should work. I have been consistenly successful if the processing time is 10minutes or less.

     

    - Then, I used iDVD to stich all those movies together. You could make each movie into a DVD chapter. Ironically, I am even considering using MovieMaker to stitch up the movies.

     

    - Apparently, iDVD is no longer supported. If you don't have one, you may need to beg someone at Apple Store to install it on your computer. I think Apple should make iDVD available for free in the app store. This would be the least they can do to supplement iMovie deficiency.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.