Previous 1 3 4 5 6 7 8 Next 115 Replies Latest reply: May 21, 2014 1:46 PM by Terence Devlin Go to original post Branched to a new discussion.
  • Old Toad Level 10 (135,351 points)

    I would guess that would be what you would need to do in order to get all of your photos into a working library.  Don't get rid of those photos on the external HD.  They are a good backup.

  • krex88 Level 1 (0 points)

    I followed a users advice to search for jpg on my mac hd and i found my photos in the recently opend. thank **** for that. was getting very annoyed.

  • Jim Barrick Level 1 (0 points)

    I do also have Time Machine backup of my photos, which were deleted by iPhoto. When I retrieved them and put them back in iPhoto, they stayed there for less than a week, and then disappeared again. At least they're not gone forever, but it's very inconvenient to have to restore them every time I want to look at them. Is there some version of iPhoto that doesn't have such a problem? Failing that, is there some comparable program that works on the Mac?

  • Terence Devlin Level 10 (137,900 points)

    Perhaps it might be worthwhile exploring why these photos keep disappearing on you when this  doesn’t happen to other people. What can you tell us about your set up?

  • Jim Barrick Level 1 (0 points)

    Good point, Terence. Anyone to whom I addressed such a question would want to know that. I wouldn’t be surprised if something I did and/or some peculiarity of how my system is set up contributes to my problems. So I’ll make a list of how I’m set up, starting with generalities and proceeding through what I consider to be the most relevant peculiarities.


    I have a Mac mini - the same one since October of 2009, when my son gave it to me. It has Mac OS 10.6.8, 2.53 GHz Intel Core 2 Duo, 4 GB 1067 MHz DDR3. In 2010 I added a Time Machine. (Before that I had a separate external hard drive on which I kept backups, using Backup through MobileMe.) I upgraded to iWork ’09 in mid-2011. (Previously I had made much use of iWork ’08, esp. Pages.)


    iPhoto came installed on the computer when I got it, and I have always installed software updates as soon as they arrived.


    My wife and I both use MS Office 2004, esp. Word and Excel. We also use both Safari and Firefox for browsers, and Photoshop Elements. 

  • Terence Devlin Level 10 (137,900 points)

    WHere is the Library stored?


    When you restore, do you restore the whole library or just the missing parts?

  • Jim Barrick Level 1 (0 points)

    The Library - of which there are several, including iPhoto Library Save, created earlier this afternoon -  is in jcbarrick/pictures  at the same level as jcbarrick/documents   Spotlight didn't find them.


    I restore one or more of "the whole library."

  • Terence Devlin Level 10 (137,900 points)

    Nothing unusual there, unless the back up is corrupted.


    Here's what is very odd: It can happen that a library becomes corrupted. This can then be repaired or replaced with a back up. Then unless something very unusual is  going on, or gross user error, you will be very unlikely to  have the same issue again.


    But you have the problem repeating:


    When I retrieved them and put them back in iPhoto, they stayed there for less than a week, and then disappeared again.


    When you see an issue like this you start to wonder about directory damage on the HD.


    In your last post you say  that you restore "whole Libraries" but there you're  saying  "retrieve them and put them back into iPhoto"


    Are you retrieivng Photos only, or  iPhoto Libraries?

  • Jim Barrick Level 1 (0 points)

    I do indeed restore iPhoto Libraries. When I say "retrieve them and put them back into iPhoto," I mean that, before you gave me iPhoto Library Manager, it was tedious but necessary to switch back and forth from one iPhoto Library to another. Now, with iPhoto Library Manager, it's easy. The peculiar thing is, when I do that, e.g. when I switch to "iPhoto Library (original)" - which is 8.54 Gb - I get a page full of 12 black squares (4 across and 3 down), identified only by a date - i.e. at the beginning, upper left "Aug 5, 2004," lower right "Jul 26, 2005." Paging down, snapshots appear in the squares - still with the same kind of dates, though more recent - briefly, but I remember the snapshots - then the snapshots disappear again, and the squares go black - but the dates don't change.


    I chose the phrase, "less that a week" deliberately. It could have been less than a day.


    Directory damage? Does that mean I have to get a new HD?

  • Terence Devlin Level 10 (137,900 points)

    What you describe in your post is missing thumbnails: Is that what you mean when you say the photos go missing?


    Back Up and try rebuild the library: hold down the command and option (or alt) keys while launching iPhoto. Use the resulting dialogue to rebuild. Include the option to rebuild the thumbnails. It can take 3 or 4 goes for this to work







  • Jim Barrick Level 1 (0 points)

    Yes, missing thumbnails.


    I tried rebuilding the iPhoto Library: 4 shots at option 1 (small thumbnails) and 4 shots at option 2 (all thumbnails). All yielded black thumbnails.


    I suspect something more serious, because MS Excel doesn't work either, and that's something we do routinely (at least once a week, and usually more - last week several times. Permits starting from scratch, but not opening a file).





  • Old Toad Level 10 (135,351 points)

    What system version are your running?  How much free space do you have on your boot drive? We've been offering fixes somewhat blindly. 

  • Terence Devlin Level 10 (137,900 points)

    So, to clarify, the photos aren't missing, just the thumbnails?

  • Jim Barrick Level 1 (0 points)

    No, both: bringing the cursor to the black square just gets a deeper blackness.


    The system version is Mac OS 10.6.8


    Actually, I just checked the "pictures" directory under "jcbarrick" and many of the photos (not the thumbnails) are there, including some from 2007, but also including some libraries of iPhoto just regenerated this afternoon - and when I click on the latter I bring up iPhoto! So maybe TD's fixes worked after all - I'll have to Time Machine to be sure.


    Thanks, TD!



  • awhit2 Level 1 (0 points)

    I was upgrading my operating system (I was on 10.5.8) and due to the switch from MobileMe to iCloud, I was told that I had to upgrade my system.  So, I did the 10.6.x upgrade and then the 10.7.x upgrade in immediate succession.  I have used Time Capsule for years.  I checked to make sure that Time Capsule had backed up before I started the entire process.


    Somwhere along the line my iPhoto library got deleted (the "Genius" believes that I moved it trying to back it up but I did not!).  I didn't worry too much because I have Time Capsule.  Now that hard drive has "gone bad" and nothing can be accessed on it.  The "Genius" said "don't be too upset".  WHAT????  I had 11 years worth of pictures on there.  Those pictures were the entire documentation of my children's lives.  I had Time Capsule as my back up.  Apparently it was a nice, expensive paperweight.  And what happened to my iPhoto library????  It is no where to be found. 


    Sickening.....discovered all this on the same day that I Apple announced that they are paying cash dividends for the first time....


    Any help is much appreciated.

Previous 1 3 4 5 6 7 8 Next