Skip navigation

Stuck on "Generating Thumbnails"

15034 Views 13 Replies Latest reply: Sep 3, 2013 9:46 AM by LawnyfromVa RSS
teutates74 Calculating status...
Currently Being Moderated
Oct 25, 2010 12:14 PM
I upgraded from the previous version of iLife to iLife '11 today and when I went to use iMovie it has been stuck generating thumbnails all day.

I'm running 10.6.4 and have 4 GB of ram on an iMac. I also have 78 gigs of free space.

Is anyone else having this issue?
Mac Book Pro, iPhone 4, Mac OS X (10.6.4)
  • BruceEBonus Calculating status...
    Currently Being Moderated
    Oct 25, 2010 1:18 PM (in response to teutates74)
    Hi There
    As its only heavy and serious users who are getting this problem ... like wot I am .. here's what I did.

    Go to Users / iMovie and then go to the Projects folder. Pull out the folder that is causing the problem then let iMovie 11 import the remainder of your projects then pull the folder back in.
    Restart iMovie
    Chances are it will stall again at that Project.
    If it does ... pull it on to the desktop again like you did above.
    Now look in it .. I found about sixty odd files with about only ten with image files .. the rest were all zero k empties ... I deleted all the stuff with zero k and only the stuff with little images.
    Pulled it back in .. et voila .. it works!

    Hope that helps ... BUT now I have to work out why many of my past projects have error triangles and audio that doesnt play ... in't life grand? And no it doesn't JUST WORK Apple ...

    Cheers

    Bruce
    Medion P4 Titanium, Windows XP
  • BruceEBonus Level 1 Level 1 (5 points)
    Currently Being Moderated
    Oct 26, 2010 11:12 AM (in response to teutates74)
    Thanks for gettting back and I am glad it worked! Butits a bit worrying isnt it? Now .. i have to work out why sound files are a bit wonky .. oh dear .. Apple have taken their eye off the ball on this one!
    Medion P4 Titanium, Windows XP
  • cburkett Calculating status...
    Currently Being Moderated
    Oct 30, 2010 2:24 AM (in response to BruceEBonus)
    same problem, moved 200gig of files on to spare drive. imovie 11 still sitting on generating thumbnails even though movie directory is empty.
    IMAC 2.66 24", Mac OS X (10.6.4)
  • jmunro21 Calculating status...
    Currently Being Moderated
    Oct 30, 2010 4:12 AM (in response to teutates74)
    I am having the exact same issue, but all of my thumbnails are being generated from iPhoto where I have maybe around 30gb of digital camera clips in with my photos.

    I am finding that I need to force quit iMovie on every occasion that I open it when I have iPhoto open at the same time...

    All of this with a brand new iMac 27''

    Any suggestions...

    Thanks
    Imac 27'' i3, Mac OS X (10.6.4)
  • john payne Level 1 Level 1 (20 points)
    Currently Being Moderated
    Jan 22, 2011 6:16 AM (in response to jmunro21)
    I had this very same problem, started up iMovie and it wouldn't generate thumbnails. I, however, have two external hard drives where I store photos on Aperture and film clips. I switched off the external drives and re-launched iMovie and it worked immediately, generated thumbnails immediately. When I switched on one hard drive with the Aperture library on it it also worked immediately but not with the two hard drives in tandem.

    Hope that helps
    iMacG5, Mac OS X (10.6.6), 4gb ram DDR3 3.2 Ghz intel core i3
  • ivanovitch Calculating status...
    Currently Being Moderated
    Feb 3, 2011 3:40 PM (in response to john payne)
    I've tried everything listed here, and no success. It keeps hunting for two .mov files that don't exist, and thus I cannot find them. Nor can iPhoto find them (I've checked every movie listed in iPhoto).

    I have to force-quit iMovie 11 every time.

    I'm now at the stage of totally rebuilding iPhoto from scratch, and upgrading all of the internal data that it keeps (even though the upgrade worked fine for iPhoto).

    Incidentally, I've no movie files in my Movies folder at all, nor any projects. Starting from a blank sheet, other than what sits in iPhoto (hence my thought that rebuilding iPhoto was the way to go).

    Will report back when iPhoto is rebuilt.
    MacBook Pro 2.4 GHz Intel Core 2 Duo, Mac OS X (10.6.5), 4GB RAM
  • ivanovitch Level 1 Level 1 (15 points)
    Currently Being Moderated
    Feb 3, 2011 4:40 PM (in response to ivanovitch)
    Great: I've now transferred the problem to iPhoto: it cannot find three movies, yet I cannot find which movies they are meant to be (they aren't on my computer in any event, and I cannot find the reference in iPhoto, grumble grumble...). It also takes forever to search the entire machine for each missing file.
    MacBook Pro 2.4 GHz Intel Core 2 Duo, Mac OS X (10.6.5), 4GB RAM
  • viction Calculating status...
    Currently Being Moderated
    Jun 11, 2011 11:33 AM (in response to teutates74)

    I exerienced the same thing.  I found that it was having trouble generating thumbnails for very short movies that had little to no changes from frame to frame (e.g. a 3 frame movie where every frame was the same).

     

    I Don't have a fix, but to prevent it from happening try to import those files. 

     

    To stop iMovie from trying to create the thumbnails I had to:

     

    1. Force quit iMovie

    2. Navigate to ~/Movies/iMovie Events/<Your Event>/Thumbnails/

    3. Find the file(s) that don't have thumbnail (the file will be there, but won't have preview image in finder) and Delete file(s)

    4. Navigate up one directory to ~/Movies/iMovie Events/<Your Event>/ and delete the original file with same name as troublesome thumb.

    5. Restart iMovie.

     

    hope this helps.

  • markuswinzer Calculating status...
    Currently Being Moderated
    Aug 27, 2012 9:27 AM (in response to teutates74)

    Top! This helped me so much! Thanks

  • Sooty Calculating status...
    Currently Being Moderated
    Sep 2, 2012 7:42 AM (in response to teutates74)

    Solution for Me: Follow all the above and then open and leave open, iPhoto before opening iMovie.

     

    Background: Attempted to open iMovie-11 after a three week break, only to see it freeze after authorising it to make new Thumbnails of the videos in iPhoto. Allowed 15mins in case it was actually working behind the scenes before 'force-quitting.'

     

    The pattern was repeated many times despite meticulously following all the advice on this thread and several others around the forum. Nothing seemed to fix the snag with many valuable hours wasted.

     

    Usually when solving issues, I close all programmes not directly related to the problem app. (I resaon that memory and resources are better 'concentrated') I recalled that  iMovie initially grounded when trying to make thumbnails of my iPhoto videos I think after an update. So out of curiosity I opened iPhoto and iMovie loaded safely. iMovie did stumble one more time after replacing the suspected errant folders from my desktop into the Users / iMovie folder, (as in Bruce EBonus excellent suggestion above) but another 'repair permissions' and re-boot and everything has been fine since.

     

    I hope this helps anyone suffering the same issue.

  • LawnyfromVa Calculating status...
    Currently Being Moderated
    Sep 3, 2013 9:46 AM (in response to Sooty)

    Thanks Sooty, this worked for me after all else had failed.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.