4 Replies Latest reply: Dec 12, 2010 5:04 AM by pyry
pyry Level 1 Level 1 (0 points)
Hi,
On my MacBook 13" OS 10.5.8 my screen clock (the little one in the right hand upper corner) shows a different time from the date and time set and defined on my analog clock in the system preference settings.
Well the analog and the digital clocks in the system settings show different times with a digital clock time lag of 3 hours. No correction on that when I set the date and time automatically on (time .euro.apple.com) or any other of the automatic alternatives. The automatic settings give the correct time on the analog clock but not on the digital one.
Hope this schizophrenic state does not start to affect the user.
Can someone advice me on what's going on.
regards, pyry.

 MBP 15" 2,66 GHz, i7, 8GB 1066 MHz DDR3 SRAM 2x4GB, 500GB 7200rpm., Mac OS X (10.6.3),  2xTime Capsule 1TB  iPhone4 32GB,  iPod 5gen 30GB,  iPod Nano 4 GB
  • emmybee Level 1 Level 1 (0 points)
    I'm having the same issue. I cannot use automatic time&date because it sets it to the future. My lag is 5 hours. The analog clock shows the correct time 10:35am, but the digitial (and thus the computer) shows 3:35pm. This problem occur when I manually set date and time as well, only now the analog clock is the incorrect one. This is annoying, please advise.
  • CKMac Level 1 Level 1 (15 points)
    I've been plagued by this problem ever since I got a new iMac with Leopard and migrated from my old with Tiger. I just found the solution in another thread. This worked for me. I hope it does for you also.

    Author is Rod Hagen
    ---
    In the Finder head to the "Go" menu, choose "Go to Folder..." and type in "/etc"

    Now look for the "localtime" folder (within the etc folder) and drag it to trash. (It will ask you to authenticate yourself as someone with admin permissions when you do this).

    Now go to System Preferences (under the Apple menu) and set your date, time zone etc up again.

    (see http://support.apple.com/kb/TS2538 )

    If this isn't the problem, then I'd be wondering about an issue with third party software (perhaps a clock widget or GPS software of some kind) causing problems.

    Cheers

    Rod
  • emmybee Level 1 Level 1 (0 points)
    thanks this worked!
  • pyry Level 1 Level 1 (0 points)
    Rod,
    My apologies for not reacting earlier. The problem was on a MBP that i borrowed to a friend and just got back.
    Anyways, thanks for your help!!!
    pyry