9 Replies Latest reply: Dec 13, 2010 12:11 PM by mrthink
eyeandi Level 1 (0 points)
I'm having lots of problems with the 3.1 update. I've pretty much made mess and its very frustrating. I'm hoping there is a simple fix for getting screensaver to run using my Aperture library. How hard can that be? I've trashed iLifeShared>Aperture...Timestamp, but the file keeps coming back.

MacBookPro & iMac, Mac OS X (10.6.4)
  • eyeandi Level 1 (0 points)
    Thanks Dawg, yes, previews are updated, share previews with iLife and iWork is set to always. I repaired permission using Disk Utility, and Aperture itself and I have rebuild the data base. I'm at a loss here. This seems to be preference issue.
  • Steve Hoge Level 2 (165 points)
    To solve this problem, at least temporarily:

    1) Quit Aperture
    2) Delete the file *~/Pictures/Aperture Library/iLifeSharing/ApertureDatabaseTimestamp*
    3) Quit and restart System Preferences.

    Your Aperture projects should reappear in the list of photos available to the Desktop Image and Screen Saver.

    Deleting the file will get Aperture photo sharing through the iLifeMedia framework to start functioning again. The file gets recreated by Aperture when you create or delete new version images and then quit Aperture; in that circumstance, you may find that photo sharing quits working again. The problem does not seem to depend on whether Aperture's iLife sharing Preferences are set to "Always" or "When quitting Aperture".

    A workaround used by some in these forums is to make the directory *Aperture Library/iLifeSharing* read-only, but that might well cause other issues.

    This seems to be a new problem with the Aperture 3.1 release.
  • eyeandi Level 1 (0 points)
    Thanks Steve, this works for me too, temporarily.
  • mscroop Level 1 (0 points)
    Hi Steve,

    Must be doing something wrong as I cant see this file in my Pictures folder. Just the aperture library file.
  • eyeandi Level 1 (0 points)
    right click on your Aperture library, then, show packages. viola.
  • mscroop Level 1 (0 points)
    Ah, that did it. Many thanks.
  • spehanich Level 1 (0 points)
    Good call. The fix worked for me too. Thanks for your help.
  • mrthink Level 1 (0 points)
    I tried the above fix to no avail.

    I then decided to try "repairing" the Aperture library. Holding "Option" and "Command" keys, I started Aperture. It comes up with three repair options. I chose the first: Repair permissions.

    It ran through all of the photo folders, projects, etc., corrected permissions and re-assigned ownership of everything to "the current owner". With over 20,000 photos in my library, the repair only took a minute or two.

    This fixed the problem, and Aperture now displays in the System Preferences dialog box for Screensaver, along with all of the projects, albums, etc..