Previous 1 2 3 4 5 Next 375 Replies Latest reply: Mar 23, 2013 8:10 AM by John Mistretta Go to original post
  • jamiana Level 1 (10 points)
    My mba went back for a refund. Too many power problems for a new computer. Hope apple gets it fixed and quick. I am on a 13 inch good old reliable macbook pro at the moment and could not be happier....everything works.
  • daniloum Level 1 (0 points)
    I too am very disappointed with the wake issues. I have already exchanged my MB Air 11 for a new unit and ran into the same exact issue after a couple of days. Some time it wakes instantly, sometimes it just wakes-up and it's frozen. Sometimes it does not wake up at all...just a black screen.

    I took it back today for a full refund. I hope Apple gets a fix out soon. I'll have to wait until then.
  • jessamyn Level 1 (0 points)
    Just a reply after talking to the tech today. The tech bumped me up to a second level tech and we tried a few things.

    1. adjusting the energy saver settings to anything other than the standard things
    2. removing all the login items besides iTunes helper
    3. he suggested I try resetting the SMC

    I actually can't get the laptop to turn on with the Shift-Control-Option keys pressed, I have to release them first and then power-up. Haven't tried it with the machine plugged in. The problem hasn't recurred today, but it was an intermittent problem to begin with.

    I am now in the process of doing a Time Machine backup so I can do an erase-reinstall which they say is the next step. The tech I talked to seemed pretty interested in the problem when I told him that the only way I could get the machine to start up again after it hung on sleep was by plugging the power cord in and doing a hard restart. He definitely implied that if an erase-reinstall didn't fix it [along with the other things] that it might be back-to-the-factory time.
  • Smalta Level 1 (0 points)

    Thanks for the report. It would be great to hear how you get on with your solution as I have the same problem. I bought my MBA in London a couple of weeks ago but I live don't live there so I can't easily get it seen to at a store.

    My next London trip visit is in two weeks but if I can have it resolved without needing to take it back that would be great!
  • hiro-reason Level 1 (60 points)
    Tried all that. Using pmset to disable hibernation fixed it totally. Still sleeps and wakes, just doesn't hibernate ( or lock up anymore)
  • roland1970 Level 1 (0 points)
    I confirm, I set hibernate mode to 0, and so far, no more problem with waking up from sleep !
    thanks for the tip Hiro !
  • josemari Level 1 (110 points)
    Tried all that. Using pmset to disable hibernation fixed it totally. Still sleeps and wakes, just doesn't hibernate ( or lock up anymore).

    Hi, could you explain how to do this? Thanks!
  • hiro-reason Level 1 (60 points)
    Run terminal, then enter

    sudo pmset -a hibernatemode 0

    You will be prompted for an admin password. Same as for an update.
  • mmike70 Level 2 (315 points)
    That explains why I never had this problem. One of the first things I did was disable hibernation and as far as I can tell, all the instant on and deep sleep functions are not affected by this change. Another benefit is that you gain back 2-4GB of SSD space depending on how much RAM you have installed. If it doesn't remove the sleepimage file automatically, you can delete it from /var/vm.
  • Jonny Rodwell Level 1 (20 points)
    mmike70: I was thinking of disabling hibernation as well, but was worried about damaging instant on and deep sleep. But, how do you know that the features still work OK with hibernation disabled? I don't disbelieve you...just want to check I wont mess with something specific to the Air!

    Incidentally, I was thinking of using the handy smartsleep

    Message was edited by: Jonny Rodwell
  • hiro-reason Level 1 (60 points)
    Been about a week. Mine is fine. I used pmset cause I wasn't sure about older utils and new airs.
  • Intersnake Level 1 (0 points)
    Short answer:
    sudo pmset -b hibernatemode 25

    Long answer:
    (I do apologize for the formatting of this, but it appears that the forum-interface won't let me organize it as cleanly as I'd like.)

    Hey folks, recently got the 13" Air and discovered this quaint little error for myself, to my horror, as it's the purpose of an ultraportable-computer is somewhat hampered if it can't fulfill its function as portable.

    So, before I entered into a full-on panic, I resolved to troubleshoot the issue, beginning with PMSET...
    ... and it seems I was successful.

    I've seen that other people here have also resolved the problem (to varying degrees) with PMSET, but as yes a walkthrough as yet to be posted.

    I think I'll help with that:

    1) Type 'terminal' into spotlight; (this will bring up the command-line interface to OSX, which we'll need to use to address the issue)

    2) Press Command+T to open a new tab;

    3) Type 'man pmset'; (this is the manual to pmset, use spacebar to advance a page or the up and down arrows to scroll-by-line, Q to quit.)

    4) With your new tab open as a reference, go back to your first tab and type 'pmset -g cap'; (this tells you what your system can do, and you want to make sure deepsleep is there,
    elsewise your problem is beyond the scope of my tutorial.)

    NOTE: Steps 5 through 7 address troubleshooting, you may wish to skip ahead to Step 8.

    5) Now that you know your system can hibernate, you may want to troubleshoot what causes the problem, to achieve this you can reduce the time it takes for your machine to enter deepsleep/hibernation thusly:
    sudo pmset -b deepsleepdelay 10

    (NOTE: It appears that deepsleep WILL NOT activate when the computer is plugged-in. Additionally, the number provided is in seconds, so here I've changed the delay to 10 seconds; the default is 4200.)

    (NOTE: About sudo: You will be asked to provide the admin's password, and as there is no backspace you must enter the password precisely. Additionally, you may not be able to invoke sudo even with the password unless your account has admin status.)

    6) You may now, if you wish, unplug your computer and place it in sleep, listening very closely for its fans, as they will turn off when the computer enters regular sleep; furthermore you may hear the system temporarily reactivate while preparing for deepsleep, and this at least tells you the process is moving on along.

    7) Assuming you've entered deepsleep you may now attempt to reactivate your machine, though doubtless this is the point where your system has, unbeknownst to you, elected to reboot instead. Bear in mind, though, that even with a properly functioning deepsleep, the computer takes a few seconds to read the data from the completely silent Solid State Drive; again, listen for the near-silent fans to clue you in to the processes of your computer.

    8) To change the way your system enters deepsleep, use the following command:
    sudo pmset -b hibernationmode 25

    (Now then, I'm sure you're asking: Why 25? In short, because it's one of the few numbers pmset itself recommends, and furthermore, the description of Mode 25 more closely aligns with the advertised behavior of the MacBook Air than did my default of Mode 3. Indeed, I believe this one setting is the cause of the problem people have been experiencing. In the event that even Mode 25 fails, you may take some solace in the ability to disable deepsleep by using Mode 0, though at this point I'd recommend talking to Apple Hardware Support.)

    The error was resolved for me at this point, but I must again emphasize that, even when properly functioning, wake from deepsleep takes a little longer than you might like, and is exacerbated by the complete absence of visual feedback.
  • Nee Kun Level 1 (75 points)
    Mine is 13" MBA late 2010, got is for a week and so far no sleep issue.

    Just for sharing the following is my setting:

    Battery Power 1*
    AC Power 2
    Currently in use:
    deepsleepdelay 4200
    halfdim 1
    hibernatefile /var/vm/sleepimage
    disksleep 10
    sleep 10
    hibernatemode 3
    ttyskeepawake 1
    displaysleep 2
    deepsleep 1
    acwake 0
    lidwake 1

    The above was preset cause I did not change any setting. All i did is a clean install when I got my MBA
  • fyego Level 1 (0 points)
    I think I may have found the problem. I had the same intermittent waking problem. After a couple of calls to Apple support they allowed me to exchange it for a second new machine.

    Same problem. So I erased the drive reinstalled a clean system and upgraded to the latest version of the OS X 10.6.5 and didn't do anything else. Before that I was having about 1-2 crashes per day for four days. Then after the clean system no crashes for four days.

    All was good and I decided to give a shot at installing Adobe Flash - I have had 2 crashes on waking from sleep in 24 hours. I'm going to let this run for a few days to build up the crashes. Then I'm going to uninstall Flash and see whether they go away......
  • hiro-reason Level 1 (60 points)
    OK, looks like there's a better answer than turning off hibernate mode. Tech support has been calling me back and trying stuff. Check your system settings, startup disk. If nothing is selected, select your MAC OSX volume, and do a restart. I did that a couple of days ago, and now it sleeps, wakes, and hibernates correctly. Wakes up quite quickly from hibernation. Apparently, if you don't have a startup volume selected, it sometimes tries to find a network drive, or just gets confused on wake.

    I'll repost if I see any more problems, but this looks to be the real answer, from Apple tech support. Make sure you have the startup disk selected. That simple.
Previous 1 2 3 4 5 Next