9 Replies Latest reply: Nov 16, 2010 2:14 PM by Lowell Tuttman
singerdf Level 1 Level 1 (0 points)
Back in April, I hooked a 500 GB USB external drive to my iMac in order to run time machine. All worked fine until October 17. Yesterday Time Machine popped up with a message telling me it had not backed up in 10 days and I should figure this out. At this point, I noticed that the external drive was no longer mounted on the desktop, although I could see it in Disk Utility. The POSIX error came up. After a long search on the forum and fighting with a PC in the house, I was able to reformat the drive and let Time Machine do its thing.

The initial backup went great and it seemed to back up every hour until 12 am or so it says. Once again, I came down this am and the drive is not mounted and not showing in Disk Utility. I turned it off and on again and now the computer tells me it needs to be initialized.

What in the world is going on? Is it related to USB control and SL? Is it a Time Machine issue? Should I reformat the drive and see if I can simply copy files to the drive and see if it stays mounted that way?

I do not know how to tell an external drive when to unmount or if it should upon the computer going to sleep.

Any help would be greatly appreciated before I spend more money on a new drive.

Debbioe

iMac Intel, Mac OS X (10.6.4)
  • macjack Level 9 Level 9 (50,650 points)
    singerdf wrote:
    I turned it off and on again and now the computer tells me it needs to be initialized.

    Actually, it sounds like a drive issue. Do you unmount the disk before turning off or ejecting?
    Run Applications/Utilities/Disk Utility and Repair Disk.
    Also, you can download a demo of DriveGenius and run the drive tests but it will not do repairs in demo mode. The scan for bad blocks will be lengthy, run it overnight.
    Let us know the results.
  • singerdf Level 1 Level 1 (0 points)
    I am beginning to agree. Very annoying. Indeed I eject the disk. At this point, it will not unmount and I cannot reformat it as I am getting the POSIX error again. Now to make it worse, even Seagate's DiscWizard cannot see the disk.

    I will download the program you have suggested and see if I can run it and keep you posted.

    As always, I am grateful for the help,

    Debbie
  • singerdf Level 1 Level 1 (0 points)
    So far at 8 hours, less than 1 % of the drive has been scanned and it tells me that every single block is bad. I will let it run until the morning, but have little hope. I do not understand how one day the drive works fine and the next day it is completely dead with what seems like little warning.

    Debbie
  • singerdf Level 1 Level 1 (0 points)
    Here is the message that Drive Genius posted:

    Scanned 4,186,409 of 976,751,937 blocks, 0.43% (4,186,410) are bad or suspect.

    A hardware failure may have occurred. Failed to read 512 bytes at 2143471104. (6)

    I am sending the drive back. Thank you so much for your suggestion. I will let you know how the replacement drive does when I get it.

    Debbie
  • macjack Level 9 Level 9 (50,650 points)
    singerdf wrote:
    I am sending the drive back.

    Good
    Please give us feedback on the drive manufacturer and model. There are drives that are more prone to this than others and it's nice to keep a little list for when folks ask for suggestions.



    -mj
  • singerdf Level 1 Level 1 (0 points)
    No problem,

    It is a Seagate 500 GB 3.5" SATA drive Barracuda, Model No. ST3500418AS. It was not being used for the PC which is was originally intended and so I decided to use it as my Time Machine drive. Just very strange that it worked for 6 months and mysteriously gave way. Seagate is replacing the drive. I am a little concerned after all of the chatter about USB external drives vs. Firewire. I would use Firewire, if the enclosure had that connection, but it does not.

    Thanks again,

    Debbie
  • macjack Level 9 Level 9 (50,650 points)
    Thanks, that one's not on my suspect list... yet
    Good luck with the replacement, I'm sure it will be fine. When you get it remember to format for Mac OS X.

    1. Launch Disk Utility
    2. Click the "Erase" tab
    3. Select your entire external drive on the sidebar (the uppermost icon).
    4. Format: "Mac OS Extended Journaled"
    5. Name the Disk (Time Machine, or whatever) only the name of the volume will show in Finder.



    -mj
  • singerdf Level 1 Level 1 (0 points)
    Update for those following this. Seagate replaced the drive and it came today. I formatted the drive and set up Time Machine. it ran for the first time with no trouble. Upon completion, the drive seems to have disappeared. It is not visible in Disk Utility either. This is how all of this started. I can add that I now have a new iMac. So it cannot be the computer, but rather how the drive interacts with the computer(s). k Really frustrating. I am ready to buy a firewire drive and be done.

    Any help or suggestions would be wonderful. The drive is a 3.5" SATA in an irocks shuttle box. Connected via USB printer cable.

    Thanks,

    Debbie
  • Lowell Tuttman Level 4 Level 4 (1,350 points)
    If you cant see the drive from disk utility, I would pull the cable, and turn off the drive. I would then suggest you use a different cable, turn the disk on and make sure it spins up, and then reconnect it and see if that fixes your problem. The cable sounds like the most likely starting place for solving this.