5 Replies Latest reply: Nov 3, 2010 4:36 PM by luvlabs
Shnizzle Level 1 Level 1 (0 points)
Hi Apple users,

I'm posting here on the forums today because ever since i updated my iPod Touch 1st Gen to iOS 3.1.3 i have been experiencing problems with the Wi-Fi on my iPod. What happens is that it fails to reconnect after locking the iPod, When i put my network password in to connect to my Wi-Fi it says incorrect password when i know for a fact it is correct and also when i go to settings then Wi-Fi and i select my network to connect to it after it fails to automatically connect and it says failed to connect to my home network and at first it was fine for about 2 months but now it's absolutely UNBEARABLE and it's to the point of being absolutely unusable.

Also before anyone says the normal suggestions on how to fix it i have done the following already:

1. Reset my iPod Touch back to factory settings 3 times
2. Reset my network and reinstalled my network 2
3. Changed the password on my network 4 times

Also if anyone asks, yes, other wireless able devices i own connect to my wifi perfectly without problems.

I feel this is beyond a joke and I think by now Apple should have released a fix to this problem as I've seen across the forums this isn't the only thread promoting this problem. The only reason why I've not posted this any sooner is because being a loyal apple customer of 4 years and I thought this problem would eventually sort it out but I've had enough now and i don't see why i should have to go out and buy a new iPod touch and plus my iPod touch has fell out of it's warranty period.

Please Apple, help sort this problem out.

Message was edited by: Shnizzle

Dell Inspiron 6400, Windows XP Pro
  • luvlabs Level 4 Level 4 (3,610 points)
    This was a common problem a year and a half ago when most people upgraded - but the fix is pretty much the same today. Based on what you posted, you worked around the edges of the problem but didn't quite get there. The fact that other devices connect doesn't really mean too much. The problem is you want your touch to connect.

    Try the following (in this order) and check your connection after each step:

    1. Reboot the router - just unplug the power cord for 30 seconds. Plug it back in and let it reboot.
    2. Reset the touch network settings - tap Settings > General > Reset > Reset Network settings
    3. When the touch is done restarting tap Settings > WiFi. If you have a checkmark next to your network name, tap the blue ">". If your device IP, subnet mask, router IP, and DNS are all filled in, you are connected to your network. If not, tap Settings > WiFi > Other and re-enter your network name, security, and network password. If you appear to log on, tap the blue ">" again. If your device IP is 169.x your router is the most likely source of the problem.

    Things that can cause router problems:
    WEP encryption - disable completely to troubleshoot. If you have to stick with WEP, use the WEP key in place of the password when logging on. Better still, change your WiFi security to WPA2-psk.

    Outdated router firmware - check the router's website for updates to the firmware you are using and download/install it.

    Hidden network name (hidden SSID) - since this provides minimal enhancements to your security, I would just broadcast the name. However, if you feel you need to hide it, you can try and see if you can get the touch to remember everything by resetting network settings on the touch and then logging onto your network via the WiFi > Other route and re-entering everything.

    Apple tends to use the latest networking standards when it does major firmware upgrades and this seems to cause no end of problems to users who have older networking equipment. A three year old router that has never had the firmware upgraded may work perfectly fine with other devices and not with your iPod. Apple is not going to release a "fix" for this as they can't control all of the variations that occur in router firmware.
  • Shnizzle Level 1 Level 1 (0 points)
    It seems to have worked so far by doing as suggested and changing my security type to WPA but i need to do some thorough testing and then i shall mark this as answered being the fact that it ahs been temperamental where it used to connect for about 5 mins and then drop
  • Shnizzle Level 1 Level 1 (0 points)
    I have done testing and its fine when im connected as it doesn't drop connection now but the only problem is that after the iPod goes to sleep or i lock the iPod and it fails to automatically connect to my wifi after locking/going to sleep

    but another thing i can't understand is why bring out an OS for every gen iPod touch except 1st gen but that's different thing

    Message was edited by: Shnizzle
  • Shnizzle Level 1 Level 1 (0 points)
    I have since changed my router and it still drops connection so it isn't a problem with the router as i am now more inclined to say it is a hardware problem with the iPod or would the amount of routers down my street provide interference with connection to my router?
  • luvlabs Level 4 Level 4 (3,610 points)
    Sounds like you hide your network name (SSID). Either unhide it (near worthless as a security measure) or try this on your touch:

    1. Reset your network settings
    2. Log back into your network by tapping Settings > WiFi > Other and re-entering your network name, security, and network password.

    This will usually get your touch to remember a hidden network.