Previous 1 11 12 13 14 15 Next 301 Replies Latest reply: Nov 7, 2015 4:14 PM by estira Go to original post
  • Hopkins_Tech Level 1 (0 points)

    Updating to the latest iTunes fixed my connection to the App Store.

  • Ceci's MacBook Level 1 (0 points)

    NO - all my software is up to date, and I have tried on different devices (iPad, another mac) same problem.

  • dareiff Level 1 (20 points)

    Did you see if you have a "&" in your billing adress? This seems to be the problem and removing will probably fix it.

  • Anything works Level 1 (0 points)

    So this jsut started happening to me, I have checked through all the possible solutions posted so I sent in a email and this is there first response:


    Dear *******,


    Welcome to iTunes Store Customer Support. My name is Naveen and I am glad to assist you today.


    I understand that the purchased movie didn't download. I am sure you are eager to get this resolved and I will do my best to help you in resolving your issue.


    *******, I have reposted the movies "How to Train Your Dragon" and "Grease" to your account. Please follow these steps to initiate the download:


    1) Make sure you're using the latest version of iTunes. It can be downloaded free of charge from the Apple website:



    Note: Installing the latest version of iTunes will not affect your library or any items in your account that you haven't downloaded.


    2) From the Store menu at the top, choose Check for Available Downloads. You can also click this link to do the same thing:




    3) Enter your account name and password, then click the Check button.


    *******, the movies should begin downloading and appear in your Purchased playlist. If you receive an error message while downloading, try again after turning off any firewall or web-accelerator software that you may have installed. If the download process is interrupted for any reason, it should resume once you reopen iTunes.


    This article provides information about resuming interrupted downloads:



    I hope this resolves your issue. If you have any further questions or concerns, please reply to this e-mail and I will be happy to assist you further.


    Have a nice day!





    iTunes Store/Mac App Store Customer Support


    I work Sunday-Saturday with Tuesday, Wednesday weekly off, 07:00 AM - 04:00 PM CST.

    Thank you for allowing me the opportunity to assist you.




    so I tried things for the second time and NOTHING!

    so i responded.....




    I have tried to check for available downloads before and after your email and I am still receiving the same message. they do not show up in the downloads tab, but at the bottom it says 4 available downloads. even clicking on this results in the same message. I have deauthorized and authorized my computer, signed in and out, uninstalled and re installed, I tried clearing the dns, I have made sure all my info was correct. this just started happening right after I upgraded to they seem to be stuck as i have paid for them and it says they are available to download at the bottom of the download page, but it wont let me. I read some forums that this happened in the 8.1 upgrade, if so there will be a lot of people with this same problem. hopefully it can be fixed. all my settings for my computer has not changed, also it is not my ISP as that has not changed either - worked fine before the upgrade.






    Dear Richard,


    This is Naveen from the iTunes Store Support. Thank you for your reply.


    Richard. The content is still posted to your account and awaiting download, so you should be able to restart the download by following these steps:


    1) Open iTunes. From the Store menu at the top, choose Check for Available Downloads. You can also click this link to do the same thing:




    2) Enter your account name and password when prompted, then click the Check button. Your purchase should begin downloading. If you receive an error message when downloading, try again after turning off any firewall or web-accelerator software that you may have installed.






    getting frustrated.....

  • Tootm3323 Level 1 (0 points)

    It boggles my mind that whenever there's a problem everyone expects apple to FIX it right away. As if theres one Godly person in Apple thats gonna throw lightning strikes in 50 million places and ZAP problem fixed. I take it people who expect this don't run a business. I also expect they aren't writing programs. SERIOUSLY... get a life. Obviously... your not perfect, so why should Apple be. Good things come in time, so chill out!!!! If not every single person has this problem, maybe you're the problem.

  • ROSEJOY Level 1 (0 points)

    Hey! U dont have to be rude!  Maybe u should chill out!  Your reply is pretty aggressive-  it sounds like you forgot YOUR mrds that you would be so personal and agressive!  You may see this situation differently but dont attacke another persons view over it! 

  • Makenzi14 Level 1 (0 points)

    I keep getting that same message and that same message of "Your request could not be completed. The item you've requested is not currently available in the U.S. store." is even showing up when I try to get on iTunes on my iPhoen 4s.It is making me so angry! I want to know a way to fix this problem and i would like to know sooner rather than later!

  • Marge81 Level 1 (0 points)

    I have the same problem, this problem started during Hurricane Sandy.  I think this problem is because of Hurricane Sandy?  Maybe the power line is still down for the iTune store.

  • jusperfek Level 1 (0 points)

    You know what boggles my mind, why you wouldn't check the forum to see that people have been having this same issue for over a year. So pardon me for thinking that apple would have fixed the issue by now.

  • ab78 Level 1 (0 points)

    I'm having trouble with the store lately and would like some help. I can browse in the store and I can purchase items but for some reason I can't view my account information. I keep gettting the same message of "We could not complete your iTunes store request. The network connection was reset. Make sure your network connection is active and try again. I ran the iTunes diagnostics. The Internet connectivity is fine but the "secure link to iTunes store failed". Specifically in the diagnostics report, it says that the only connection that was unsuccessful was to firmware update server.

  • ab78 Level 1 (0 points)

    I think I may have figured out my solution. I clicked on the X on the error message instead of clicking Ok and got another error message with a number - 10054. Did a Google search for that and found out that I had to Reset cache in iTunes and it seems to have worked so far.

  • ab78 Level 1 (0 points)

    That solution did not work. It's back this morning to telling me to check my network connection. Like Marge81, I also wonder if my problem is potentially caused by Hurricane Sandy. That seems to be about the time it started happening. Because email support hasn't been very helpful, looks like it's time to contact phone support.


    Another issue I'm having is my CD drive on my computer has suddenly stopped working. I hope that checking various settings on my computer didn't mess anything up.

  • ab78 Level 1 (0 points)

    Well, I had to do a system restore to get my CD drive running again.


    As for my account, I've created a second account with a different email address and password. So far, the second account lets me view my account info.

  • jnkadoodles Level 1 (0 points)

    I had the same probelm a couple of minutes ago, and I remember messing up with my iTunes media library folder, I deleted some podcasts to save space, and then when I went to my iTunes I cannot donload new apps as it says its temporarily unavailble..bla bla.


    What I did was I went to my podcasts (on itunes) and deleted the files which I also deleted on the iTunes media library folder and it effin worked tee~hee

  • slimshades26 Level 1 (0 points)

    Thank you to ROSEJOY for posting.  I had put parental controls on my son's iTouch and didn't realize that by doing so it would lock up my iTunes when I have my own iPhone plugged in. Turns out it was an easy fix, finally. I'm sorry to everyone else still dealing. 

Previous 1 11 12 13 14 15 Next