Skip navigation

iTunes won't find my iPhone device in order to connect to "Remote"

10266 Views 15 Replies Latest reply: Dec 26, 2012 1:45 PM by CokeLover66 RSS
1 2 Previous Next
pbbowers Calculating status...
Currently Being Moderated
Nov 1, 2010 12:19 PM
I'm trying to connect my iPhone, iTunes and AppleTV via HomeSharing but in iTunes I can't seem to ever get my device to show up so I can enter the passcode to connect. HomeSharing is enabled.
  • Chenks Level 5 Level 5 (7,420 points)
    with HomeSharing you don't need the device to appear to enter a passcode.
    HomeSharing just works automatically.
     MBP 2.4GHz  Mac Mini G4  2 x AppleTV  iPhone4 32GB  iPod Classic 80GB, Mac OS X (10.6.4)
  • Chenks Level 5 Level 5 (7,420 points)
    are you sure you are running the latest version of both the remote app and itunes?
     MBP 2.4GHz  Mac Mini G4  2 x AppleTV  iPhone4 32GB  iPod Classic 80GB, Mac OS X (10.6.4)
  • mackesk Calculating status...
    Yes everything is updated
    iMac
  • Chenks Level 5 Level 5 (7,420 points)
    mackesk wrote:
    Yes everything is updated


    well all i can tell you is that i didn't have any need to add any passcodes when connecting to my various itunes libraries using HomeSharing.

    you simply enable HomeSharing in itunes, and then the remote app automatically sees the libraries in the list.
     MBP 2.4GHz  Mac Mini G4  2 x AppleTV  iPhone4 32GB  iPod Classic 80GB, Mac OS X (10.6.4)
  • mackesk Level 1 Level 1 (0 points)
    On both my laptop and Apple TV when you enable sharing under the "advanced" menu it prompts you to enter a username and password. Also when sharing on the original device you are prompted to enter your iTunes user name and password and then the window that pops up tells you that you should use that information on the attaching devices.
    iMac
  • Hitheringwaters Calculating status...
    I had this same issue. It turns out I had connected my AppleTV to my "Home Network 5g" but my iPhone only connects to "Home Network" I switched the AppleTV to "Home Network (sans 5g)" and it showed up fine.
    MacBook Air; MacMini; iPhone, Mac OS X (10.6.4)
  • PavlovsStepson Calculating status...
    I'm having the same problem as pbbowers, and I can understand why the others couldn't address his problem--because they had a different experience. Now I've had both experiences. When I got Apple TV 2nd Generation and the Remote app, everything worked perfectly. I entered my Apple ID and passwords in the appropriate places and it worked; there was no 4-digit passcode involved. Everything worked both on my iPhone and my wife's iPad, until we went to bed last night. This morning it didn't work on either device. All our softwares are up-to-date. I rebooted, etc., and then turned off sharing and tried to turn it back on, but in attempting to choose a library all I got was a screen with a 4-digit passcode. The intstructions simply state to open iTunes and choose iPhone from the devices list. That's it. It doesn't say what to do after that, or where to enter the passcode. After choosing the iPhone from the device list nothing happens, and there is no place to enter the passcode.
    Mac Pro, Macbook Pro, iPhone 4, iPad 3G
  • Rudegar Level 6 Level 6 (18,520 points)
    in itunes preferences->Sharing

    one can setup a required Password for home sharing this password have no relation to apple ID's and passwords and is required to be typed from phone and atv if they are to access the shared lib
    Shuttle, Windows 7
  • PavlovsStepson Level 1 Level 1 (0 points)
    An update: it's not the sharing password in iTunes preferences, it's a passcode provided by the Remote app on the iPhone or iPad when we try to add a library. Each time we try to add it we get a different passcode.

    I found the old instructions for Apple TV and apparently in the olden days one was required to enter a passcode to add an iTunes or Apple TV library. That was with iTunes 9.2.1 or earlier, or with Apple TV 1st Generation. I have 2nd Generation and iTunes 10, so apparently for some reason the app thinks I have something older. Worse, it happened to both my wife's app and my app simultaneously, and the change occurred sometime between 2 am when everything worked perfectly and 7:30 am this morn when neither app worked. During the intervening 5.5 hours we did nothing but sleep and there was no one else in the house. No kids, no animals.

    The problem is apparently that our apps are not recognizing the libraries, either in iTunes or Apple TV. This should happen automatically since all home sharing is on using the same Apple ID account. The AirPort is working, internet is working, and the Apple TV is working. The Apple TV remote control works, and our iTunes libraries show up in the Apple TV computer list. The only problem is the Remote app is not automatically connecting to the libraries and apparently assumes we have older hardware or software. I deleted and re-installed the app but got the same problem.
    Mac Pro, Macbook Pro, iPhone 3G, iPad 3G
  • PavlovsStepson Level 1 Level 1 (0 points)
    OK, problem solved after re-booting the AirPort base station. For some reason the problem affected only the intranet and not the internet. I had re-booted the cable modem yesterday but not the base station.
    Mac Pro, Macbook Pro, iPhone 3G
  • fishboy99 Calculating status...

    restarting the router worked for me...

  • NormanIshak Calculating status...

    Hi,

     

    I have the same problem as it seems and can't resolve it. I am trying to connect my iphone to my itunes using remote and trying to wifi sync it but I can't. I have home sharing on my labtop turned one and doing every step right biut it isn't working either for the remote ot itunes wifi sync. I have the newest itunes and ios5 ob my phone and windows 7 on my labtop. Sol anybody knows the solution for this?

  • 1MacGeek Calculating status...

    Step one : Please restart EVERYTHING involved. This means your cable modem / dsl router, Airport Base Station if you have one, your computer, your iPhone / iPod Touch / iPad (2) if applicable. Shut it all down and power it all back up in the appropriate order (modem / router / computer, et cetera)

     

    Step two : Make sure you have the most recent version of all software. Verify you have the latest version of iTunes and the Remote software. Check to make sure the AppleTV has no updates as well. 

     

    Step three : Enable Home Sharing on all applicable devices.

     

    Step four : Make sure the AppleTV and the computer are both hooked up to the same network, wireless or otherwise, and make sure if you have a non-Apple router anywhere in the mix it is allowing traffic to flow freely between all the Apple tech. Apple has specific documentation on this. Search the Support site for "Apple TV: TCP and UDP ports and protocols used" and make sure none of those ports are being blocked by the router or any firewall software you may have running, like Zone Alarm.

     

    Step five : Fire up the Remote app on your phone, and let it search for your AppleTV. There should be no passwords required anywhere if the Apple tech is properly talking to one another.

     

    Step six : If all the above still doesn't work, then call in a professional who can get eyes on the equipment and do a proper job of troubleshooting.

     

    Please let us know if this does not help.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.