Skip navigation

Logitech Harmony + Apple TV II = eternal need to unpair

102865 Views 33 Replies Latest reply: Jan 6, 2014 1:35 PM by Lee Beyer RSS
1 2 3 Previous Next
Paul Hamburg1 Level 1 Level 1 (70 points)
Currently Being Moderated
Nov 1, 2010 1:20 PM
I've set up my Logitech Harmony to work very well with my new Apple TV II except for one thing: whenever the TV or the Apple TV is turned off, the Apple TV needs to be reminded again the next time to "unpair" with the remote before the remote will work. It is not clear to me why the default state keeps coming back and actually, I have no idea what the Apple TV thinks it's paired to.......

Any suggestions would be very welcome.

Paul
macbook pro, Mac OS X (10.6.3)
  • Chenks Level 5 Level 5 (7,420 points)
    no idea why it's doing that, as mine works perfect with my Logitech Harmony One.
    there is no need to pair any remote, so not sure why you keep trying to pair it.
     MBP 2.4GHz  Mac Mini G4  2 x AppleTV  iPhone4 32GB  iPod Classic 80GB, Mac OS X (10.6.4)
  • Dave Marsh Level 2 Level 2 (325 points)
    I've not had any pairing issues with my ATV2. It works perfectly with my Harmony 880. When I was setting up the Harmony Remote via a USB connection to my iMac, I ignored the pairing comments and simply set it up as a TV/Apple/Apple TV, and everything worked fine.
    2.8GHz 24" iMac w/4GB RAM/750GB HD, 1.8GHz MacBook Air/80GB HD, iPad 3G, Mac OS X (10.6.4)
  • tgibbs Level 1 Level 1 (70 points)
    I intentionally paired my Harmony remote with my Apple TV, so that the Apple TV would not be confused by commands to my Apple Mini (controlled by the same Harmony remote, but using different Apple Remote IDs). I initially set up the Apple TV using Harmony's standard Apple Media PC configuration, which configures the remote to emulate an Apple Remote with ID = 1. Since then it has worked flawlessly.

    Have you tried unpairing the Harmony remote from the Apple TV, the re-pairing it and just leaving it paired?
    Cube, Mac Pro, MacBook Pro, Mac Mini, Mac OS X (10.5.7)
  • tgibbs Level 1 Level 1 (70 points)
    Have you tried restoring the Apple TV (http://support.apple.com/kb/HT4367), creating a new Harmony Apple Media PC device, and starting over from scratch?

    Last resort: Create a new Harmony device, tell the Harmony that you have some random DVD player or VCR (that you don't actually have), and then teach the Apple TV the commands for that device, using your Harmony remote and Apple TV's learn capability.
    Cube, Mac Pro, MacBook Pro, Mac Mini, Mac OS X (10.5.7)
  • tgibbs Level 1 Level 1 (70 points)
    This is a real puzzle, since I've generally found that different Harmony remotes are pretty much interchangeable functionally, and presumably Apple TV's are all the same.

    Have you tried creating a new Harmony device and learning the commands from the Apple Remote provided with the Apple TV?

    You didn't mention whether you tried telling Harmony that you had some random DVD player and then getting the Apple TV to learn those commands from the Harmony.
    Cube, Mac Pro, MacBook Pro, Mac Mini, Mac OS X (10.5.7)
  • tgibbs Level 1 Level 1 (70 points)
    Running out of ideas...

    Does the original Apple remote show the same problem?
    Another idea is to try changing the ID of your Apple Remote, which is done by holding down the Menu and Center buttons together for several seconds.

    http://support.apple.com/kb/HT3176

    Assuming those commands work, you could then try learning them on the Harmony. This is a long shot, since I think the things you've already done should have worked.

    Does the "Unpair" command in the Harmony library work from your Harmony remote, or do you have to choose "Unpair" from the on-screen menu?
    Cube, Mac Pro, MacBook Pro, Mac Mini, Mac OS X (10.5.7)
  • tgibbs Level 1 Level 1 (70 points)
    My next suggestion was going to be to have the Harmony issue the "unpair" command automatically on activity start, but it sounds like the Logitech guys have already tried that (although it still sounds like it ought to be possible to get it to work, if it is possible unpair manually using the Harmony--it might be a timing issue, in which case they may just have to work out when to issue the unpair).
    Cube, Mac Pro, MacBook Pro, Mac Mini, Mac OS X (10.5.7)
  • jaydfwtx Calculating status...
    I have a Logitech 880 and after fighting with this for quite awhile, I seem to have got it working. I believe what did the trick was manually mapping the remote buttons to the appletv commands (left/right/up/down/menu/select).

    BTW, the unpair command they have for the appletv seems to be wrong. Unpair only ever works if you do it from the device menu. I added unpair as a custom button, and it did nothing.
    Macbook Pro, Mac OS X (10.6)
  • TheOneAndOnly BiGMaC Level 1 Level 1 (95 points)
    Here's an article and blog of some 3rd party remotes that work with ATV2 from Tuaw on 24 November 2010. Might consider a different one.... check them out at:

    http://www.tuaw.com/2010/11/24/teaching-your-apple-tv-to-use-a-3rd-party-remote/

    Hope this helps
    MacPro Dual Quad, Mac OS X (10.6.5), 2TB Raid 5 and 16TB peripheral, iMac, iPad, ATV2, MacBook Pro
1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.