Previous 1 2 Next 20 Replies Latest reply: Dec 25, 2012 7:56 AM by charlesf49
morph21 Level 1 (10 points)

After a long, LONG, LOOOOOOONG time searching for an answer and trying different settings all over making a Mac OS the Master Browser finally solved the problem for me.

This is not about sharing, this is not about any of the other thousand issues that working with Windows' Samba might have.

Anyway, to put it simple, you need to edit /etc/smb.conf file as root. For that, open a Terminal and type:
+sudo nano /etc/smb.conf+

keep going down until you reach this part, then add the text in bold as shown:
+; Pull in system-wide preference settings. These are managed+
+; by smb-sync-preferences.+
+include = /var/db/smb.conf+

+; Pull in system share configuration. These are managed+
+; by smb-sync-shares.+
+include = /var/db/samba/smb.shares+

*+; Forcing Master Browser+*
*+os level = 65+*
*+preferred master = yes+*
*+local master = yes+*

+comment = All Printers+

Close the file with Control + X and then Yes for saving.

Now just go to System Preferences, Sharing and turn ON File Sharing, click in Options and turn "Share files and folders using SMB (Windows)" to ON. If it was ON already, just turn it OFF and then back ON to restart the service (nmbd).

In a few seconds, or minutes depending on the network, your Mac should become the local browser and then the PCs will appear in your Finder.

You can check if your Mac is the Master Browser by typing this in a Terminal:
+nmblookup -M -- -+

The Master Browser IP that will appear there should be your Mac's.

Message was edited by: morph21, fixing format issue

iMac 27" i7 4x2.8GHz 8GB, Mac OS X (10.6.4)
Previous 1 2 Next