Previous 1 2 Next 22 Replies Latest reply: Jan 23, 2013 8:18 AM by Pawool
kaispuccino Level 1 (0 points)
Garageband ( ilife 11') makes an registry error: Please ensure this product has been installed properly, then i click on OK and on the garageband icon on the dock and he starts....
how can i fix it?????

Imac 21,5, Mac OS X (10.6.4)
  • isteveus Level 5 (4,310 points)
    Will it open if you click on the icon in your aplication folder?

    Oh and macs don't have a registry.
  • kaispuccino Level 1 (0 points)
    yes it opens.
    i know macs don't have registry but i have this message error.
  • Michel van Kemenade2 Level 1 (0 points)

    I'm having the same problem for 8 months or so. It is not something new. It appeared after a migration from my old to my new MacBook Pro. I have installed iLife'11 recently hoping it would be resolved but it's not. I'm also a Logic user and found out that the registry error must have something to do with the registry of Jam Packs after the migration, because I'm getting the message 5 times! I've re-installed the Jam Packs without any effect. There is a 'Package Registry.plist' file in your library/garageband/ folder but erasing it has no effect. Hopefully Apple will resolve this problem!

    But now the good part! Of course you want to USE Garageband, you can!
    After you've clicked passed the error messages you wait for the finder to show the Garageband menu. Now you can start using Garageband by clicking the icon in the Dock!

  • kaispuccino Level 1 (0 points)
    this problem is unsolved by Apple?????
    There is an tech here???
  • MainStage Fan Level 1 (60 points)
    Sounds like a migration problem. I'd delete everything in Library/Application Support/GarageBand.
    It's possible if you go inside that folder and only delete "Package Registry.plist" that this would solve your problem, since I think GB would simply create a new one.

    But deleting the old content and app isn't a problem - you can keep your /Music/GarageBand folder with all your music.
    Then install the new ILife again.

    Sometimes you might have to delete your prefs as well, which are located here: yourhome/Library/Preferences/
  • abelsoul Level 1 (10 points)
    I have the same problem.

    "It's possible if you go inside that folder and only delete "Package Registry.plist" that this would solve your problem, since I think GB would simply create a new one."

    I tried that - no joy.

    Delete everything and it won't launch as it needs an instrument library.

    Most annoying.

    Message was edited by: abelsoul
  • abelsoul Level 1 (10 points)
    I also noticed there is an option to 'Register Grageband" in the file menu but it takes me to the Apple registration site which gives no option to register Garageband.
  • abelsoul Level 1 (10 points)
    Still no sign of a solution to this?

    Most disappointing.........
  • acramerus Level 1 (0 points)

    I'm having the exact same problem and it's driving me insane!


    Even the geniuses at the Apple Store have no idea what's going on, much less how to fix it. The problem started happening in osx 10.6.8 and it persists through 10.7.x; I have removed and/or reinstalled at least four different versions of Garageband attempting to fix the problem; and I've deleted all kind of files associated with GarageBand, but no dice.

  • xakil Level 1 (0 points)

    I have the same problem. But it happens when I migrate from Snow Leopard to Lion. I try to delete all GarageBand files, in Library too. And re-install GarageBand'11, but no effect...

    I suppouse some plugins was lost when I change OS, but I don't know, how to remove it.

  • acramerus Level 1 (0 points)

    I can tell you that I fixed my problem, but it was far from elegant.


    Maybe you can reverse-engineer a solution to your problem through an analysis of the following: I went into my user library and removed all the files that had anything to do with some 6 audio unit plug-ins, all of which had been unsuccessfully "deleted." It took me a while to realize that I no longer had access to my user library and I had to unhide system files in (which requires a script for or a maintenance program like


    The point is this: I deleted everything that even remotely sounded as though it might be associated in some way, however distant, to any of the various six audio-unit plug-ins I've been dicking around with for the past few weeks (especially the component files)...BINGO, fixed it!


    [Caution: it would also appear as though I deleted core audio, such that now my MacBook Pro doesn't even have the computing wherewithal to channel sounds through IT'S OWN F*ING SPEAKERS...but I'm confident that I'm just one quick download away from making my computer whole again.]

  • xakil Level 1 (0 points)

    I removed the Plugins files from Library, but the error message wasn't dissapear.

    I solve this problem just now, uninstall plugins by the original Uninstall Script from the CD of Audio Interface

  • Rakwulf Level 1 (0 points)

    I guess it's because in certain OS X Versions (in my case Lion) there is no Audio Device, which supports Input AND Output at the same time, installed by default. You can check this under Audio-MIDI-Setup in Utilities.


    With a Audio Interface connected it works flawlessly!


    The same error should appear if you have Logic Pro or Ardour or similar DAW installed.


    Hope this clears things up...



  • CAMXposure 13 Level 1 (0 points)

    REGISTRY in the real sense of the word - APPLE is REAL WORLD-

    so register the app - use an APPLE ID and then complete the process

    look in the menubar for garageband and click register- it'll will open web page

    after that you can fill out information until you get to the point where it asks for a market number- use MB966Z/A- as a single license to your computer- it's that simple


    thanks all knowledgeables from the Genius Bar- all they mostly know is how to get hired on to get an ipod

    You may not even have to fill out the information- just allow the web page to open

    before you know it- Garageband works



Previous 1 2 Next