Skip navigation

Canon MX870 HELP PLEASE

58581 Views 55 Replies Latest reply: Mar 13, 2014 1:20 PM by gothamdragon RSS
1 2 3 4 Previous Next
appleaka Level 1 Level 1 (20 points)
Currently Being Moderated
Nov 3, 2010 5:26 PM
Just recently my wifi printer (canon PIXMA MX870) wouldn't work when it goes to sleep. I mean that when the display goes black it will not print and on the Mac it just pauses itself when i unpause it it repauses itself and won't print. Then i have to turn it off and on again (printer) and it will print fine. Please help. I haven't change ANY settings, i just replaced the PGI-Black INK and the cyan and yellow ink is "low". Any help will be VERY much appreciated.
iMac Late 2009, Mac OS X (10.6.4), iMac, iPod Touch 2nd Generation w/ OS 3.1.3, iPod Nano 3rd Generation
  • PAHU Level 6 Level 6 (14,400 points)
    Currently Being Moderated
    Nov 3, 2010 7:22 PM (in response to appleaka)
    Some Canon AIO users had reported a similar symptom on this and other forums. For some, updating to the latest version of Canon driver appeared to resolve the symptom.

    To check which driver version you do have, open System Prefs > Print & Fax and select the MX870 in the list. Then open Options & Supplies and select the General tab. This will show the driver version you have installed. The latest is 10.30.3.0 which is available from Canon or via Apple's Software Update.

    If you already have the latest version then something else you can do when the printer 'drops off' your network is to open Safari and select the Bookmarks view. This should show the MX870 in the list. If it does, select it and you will connect to the internal web page of the MX870 that shows the wireless signal strength and quality. If this works then this may be enough to get the driver online again. If the Mac fails to connect to the internal web page then something could be wrong with the printer.
    MacBook Pro 17, Mac OS X (10.6.4), MacPro 2x3GHz Quad-Core, Xserve G5, iPhone 4
  • PAHU Level 6 Level 6 (14,400 points)
    Currently Being Moderated
    Nov 4, 2010 11:20 PM (in response to appleaka)
    If the printer fails to appear when it is in low power mode then you could look at changing the timer to see if that really is the cause. For my MP980 the menu is as follows: Settings > Device Settings > Advanced settings > Power save settings. By default my printer is set to 15 minutes. If your MX870 has a similar menu then you could change it to a higher value, such as 1 hour. If the printer loses connection inside of the hour then at least we know it is not related to the power save.

    When the machine does fail to print and the queue is paused, if you select the MX in Print & Fax and open Options & Supplies > Utility > Open Printer Utility are you able to access these menus and print a nozzle test page? And if you can are you then able to unpause the printer queue?
    MacBook Pro 17, Mac OS X (10.6.4), MacPro 2x3GHz Quad-Core, Xserve G5, iPhone 4
  • PAHU Level 6 Level 6 (14,400 points)
    Currently Being Moderated
    Nov 6, 2010 7:10 PM (in response to appleaka)
    I don't think that the iPad would be causing your issue, as you can open the internal web page and the restart does let you print to the Canon for a period of time. I'm not sure what to suggest next. The symptom does sound like it is a machine issue rather than it being something with the Mac. If you know how to change your wireless router settings then you could try changing the channel being used by the router as that can sometimes help. This may assist with whatever trouble you are having with the iPad also.
    MacBook Pro 17, Mac OS X (10.6.4), MacPro 2x3GHz Quad-Core, Xserve G5, iPhone 4
  • Ricky Egeland Calculating status...
    Currently Being Moderated
    Nov 7, 2010 7:25 PM (in response to appleaka)
    I'm having the same problem recently with my Canon MX870.

    - Starting a new print job won't wake the printer from sleep
    - Clicking "Resume Printing" on the paused printer in the OS X print queue manager sets it to "Printing" temporarily, but eventually goes back to "Paused". (the printer display doesn't change at all)

    Furthermore, I've had 4 instances now where the printer has stopped a job halfway through a page. Two document and two photo prints stopped like this.

    These problems are observed from two of my Macs (laptop and desktop), so I think it comes down to Software Update. I've recently been prompted to update the Canon printer driver (twice in a row, if I recall...) and also an HP print driver.

    Looking in System Preferences -> Software Update -> Installed Software, I see:

    On my laptop:

    Date Name Version
    11/4 HP Printer Software Update 2.5.2
    10/25 Canon Printer Software UPdate 2.3
    10/25 Java for Mac OS X 10.6 Update 3 1.0
    10/25 ProKit Update 6.0.1
    10/21 FaceTime
    10/3/10 Xcode Update 3.2.4
    9/25 Canon Printer Software Update 2.3

    On my Desktop:

    Date Name Version
    10/30 Logic Pro 9.1.3
    10/24 Java for Mac OSX 10.6 Update 3 1.0
    10/24 Prokit Update 6.0.1
    10/20 LED Cinema Display Software Update
    10/18 Canon Printer Software Update 2.3
    10/15 Canon Printer Software Update 2.3

    The things they have in common are:

    1. Two printer software updates for the same version (strange)
    2. Java updates
    3. Prokit updates

    apleaka, could you check to see what updates you have? The funny thing is, I did some major printing from the Desktop on Oct 25 and didn't notice any problems, which is after all of the relevant updates...

    Message was edited by: Ricky Egeland
    Mac OS X (10.6.4)
  • digitaltrader Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 8, 2010 3:51 PM (in response to Ricky Egeland)
    I have the exact same problem of the printer pausing and not printing using the latest driver version 10.30.3.0. If I turn of the printer and back on and print a page it works but if I try to print another page immediately it is again "paused" and I must recycle the printer on and off to print. The printer is connected via cat5e so this is not a wireless signal issue.
    Mac Pro dual 2.66GHz 2GB RAM, Mac OS X (10.4.7)
  • Ricky Egeland Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 8, 2010 9:17 PM (in response to digitaltrader)
    I spent last night running test after test of the printing and the scanning. I can't establish a pattern, but there's another problem with the scanning where it will transmit the scan over wifi at about 14 kB/s which makes a normal 300 dpi scan take many minutes to finish. Normal operation transfers at about 300 kB/s, which is how it behaves after the MX870 restarts, but something is causing it to go slow, and I believe it's related to the printing problem as well.

    I thought I had the problem fixed when I removed the device from the available printer list in OS X, then re-added it. But after some time the printing and scanning problems returned.

    I noticed that the device advertises itself using multiple network protocols, and from the IJ Scanner Selector you will see the device show up as either a Bonjour device or something else. I don't know if there is a recommended choice, but it's really confusing and probably really error-prone too.

    Thinking of calling Canon support, I hope they don't waste my time...
    Mac OS X (10.6.4)
  • PAHU Level 6 Level 6 (14,400 points)
    Currently Being Moderated
    Nov 8, 2010 10:45 PM (in response to Ricky Egeland)
    Ricky Egeland wrote:
    I noticed that the device advertises itself using multiple network protocols, and from the IJ Scanner Selector you will see the device show up as either a Bonjour device or something else. I don't know if there is a recommended choice, but it's really confusing and probably really error-prone too.

    There is two protocols used by the Canon wireless devices; Bonjour for the scanner component and 'canonijnetwork' for the printing component. When you add the device in Print & Fax you will see the scanner component appear quickly in the list with Bonjour Scanner and if you wait several more seconds, the printer component appears with 'canonijnetwork' in the Kind column.
    MacBook Pro 17, Mac OS X (10.6.4), MacPro 2x3GHz Quad-Core, Xserve G5, iPhone 4
  • Jim Warthman Level 1 Level 1 (125 points)
    Currently Being Moderated
    Nov 20, 2010 2:59 PM (in response to digitaltrader)
    I have the same problem trying to print from my iMac (10.6.4) using the latest driver (10.30.3.0) and connecting via Ethernet, so it's not a WiFi issue.

    Has anyone found a solution?

    Thanks,

    Jim
    iMac 27", Mac OS X (10.6.4)
  • Jim Warthman Level 1 Level 1 (125 points)
    Currently Being Moderated
    Nov 21, 2010 11:08 AM (in response to appleaka)
    Thanks very much - this worked!

    Enjoy,

    Jim
    iMac 27", Mac OS X (10.6.4)
  • HokiePerogi Calculating status...
    Currently Being Moderated
    Nov 22, 2010 9:44 PM (in response to appleaka)
    In my experience with this same exact issue with the Canon MP560, deleting and re-adding the printer is only a temporary fix. The pausing will come right back.

    How on earth is this problem not yet resolved? My two MBPros, a Windows XP netbook, and my iMac all have the same problem. None of them can wake up the MP560 after it goes into power conserve mode. I bet this is the same thing that is happening with the MX870.
    iMac, Mac OS X (10.6.4)
1 2 3 4 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.