6 Replies Latest reply: Jan 25, 2011 12:41 AM by Johnny Young
bombast Level 1 Level 1 (0 points)
Okay, some background info. For almost two years, anytime I'd put a CD into the computer, it would be these loud noises that sounded as if they were damaging the disc and/or it wouldn't eject the disc. After spending literally a day trying to eject this one CD, which I finally did after a day of continuously pressing "eject," the CD ejected and I decided to take my computer to the Apple store to get it fixed.

To make a long story short(er), I paid to have the optical drive replaced, and when I took my computer home, the new problem became that instead of reading the CDs (or DVDs), it would just automatically eject the discs. I took my computer back and they replaced the optical drive again with a new one. After I took the computer home, it quietly read two CDs and then starting with the third one, it started automatically ejecting the CDs again as before. I got so frustrated that I put my finger over the slot to prevent the disc from coming out. After attempting to eject the disc for a couple of minutes, the computer stopped trying to eject the CD and read it. And it ejected the disc with no problem. Since then, the computer has had no trouble reading and ejecting the numerous (15+) CDs. It does, however, now make a lot of noise when reading the CD.

Today I tried burning a playlist for the first time. When the blank disc was put in, it was loud but accepted it with no problem. But when I tried to burn the playlist from itunes, itunes would automatically crash. I've tried other blank discs and it does the same thing. It even crashes when I press burn disc even without a disc. Just to make sure the blank CD could burn something, I double-clicked the CD icon and burned some mp3s manually and that worked. So the optical drive is able to burn information on blank CDs. However, when I try through itunes, itunes crashes.

So do you guys think this is an itunes issue, or is it related to the replaced optical drive? I'm leaning towards the latter.

imac, Mac OS X (10.4.11)