1 2 Previous Next 24 Replies Latest reply: Mar 26, 2006 10:20 AM by Mr. Steveo
chansen20 Level 1 Level 1 (0 points)
Hi,

I am currently using a powerbook g4 and one of my USB ports is not working. The USB port on the right side will send power to any device that I connect to it, but it will not detect that actual device. The left usb port works fine. What's happening?

Powerbook G4, Mac OS X (10.4.3)
  • 1. Re: HELP: USB NOT WORKING
    orionfuel Level 1 Level 1 (0 points)
    The same thing was happening to me but with the left side. I don't know exactly what the problem might be, but as I was calling Apple Support, I turned off my computer to check out the Serial Number, and when I turned it back on it was working fine. I'm not saying this problem isnt happening again because it probably will.

    Anyways, if anyone DOES know what is going on here, please let us know.

    Thanks!

    Jorge.
  • 2. Re: HELP: USB NOT WORKING
    jrg_uk Level 3 Level 3 (720 points)
    Not quite the same, but I have a problem where all USB ports and the keyboard and trackpad stop working. The first couple of times it didn't clear up after a reboot..
  • 3. Re: HELP: USB NOT WORKING
    Polka Peter Level 1 Level 1 (0 points)
    I had the same problem, on the left USB port. After reading these posts, I tried sleep and back and then rebooting to fix it. The rebooting worked, I'll try and re-post if it re-occurs. Meanwhile, I am wondering what the problem could be.. Firmware perhaps, or driver software? Doesn't seem to make sense that there is something actually wrong with the machine given that a reboot will fix it.

    Do the roaming apple techs ever post on the forums to let us know when it is a driver problem that will be fixed?
  • 4. Re: HELP: USB NOT WORKING
    pschuell Level 1 Level 1 (0 points)
    Hi,

    I have the same. Only on the USB port right next to the firewire port, devices are recognized. I have the same exact issue on my ibook 12" G3 (Dual USB).

    Haven't tried the reboot yet.

    Cheers

    PB G4 12" 768, ibook 12" G3, iPod Video 60GB, iPod Shuffle 512   Mac OS X (10.4.3)  
  • 5. Re: HELP: USB NOT WORKING
    Colin TheMan Level 2 Level 2 (195 points)
    Same thing happened to me, I was ready to clean it and everything. Gladly, I came on here and read this...Rebooted and it worked. Meh. Hope it doesn't happen again.
  • 6. Re: HELP: USB NOT WORKING
    Christopher Jennings2 Level 2 Level 2 (220 points)
    I have seen a similar problem on a windows laptop, he plugged in a printer, and the USB stopped working, yet devices were still drawing power. Unfortunatly for him the problem seemed to be permanant, so he has invested in a USB PCIMA card, which normally costs around £20
  • 7. Re: HELP: USB NOT WORKING
    Kurtis Franklin Level 2 Level 2 (165 points)
    Happy to say that a reboot fixed my issue as well. Go figure. I am wondering if this was from the 10.4.4 update?
  • 8. Re: HELP: USB NOT WORKING
    jrg_uk Level 3 Level 3 (720 points)
    I've not had a reoccurrence of my total USB loss since applying the 10.4.3 combo patch and unplugging my lexar memory card reader when not in use.

    For completeness, I should try keeping it plugged in again and see what happens...

    (I've not yet upgraded to 10.4.4)
  • 9. Re: HELP: USB NOT WORKING
    jamie octo Level 1 Level 1 (55 points)
    Just did a clean reinstall and, guess what? the left hand USB drive had packed out.. restarted 3/4 times now and nada, niche, zero, zilch.. still isn't working!

    anyone, have a permenant problem that a restart didn't fix?
  • 10. Re: HELP: USB NOT WORKING
    jamie octo Level 1 Level 1 (55 points)
    I'm begining to lose faith in these 'Support Forums'
    noone seems to reply to anything i post
  • 11. Re: HELP: USB NOT WORKING
    rudi van Drunen Level 1 Level 1 (20 points)
    Hi all,

    My right USB slot went haywire after logic board replacement. It seems
    that it is not supplying power to the USB device connected. The left slot
    (next to the modem connector) does work. (when you connect a mighty
    mouse to it, the light does not come on when connected right, it does
    work when connecting left)

    Tried rebooting, resetting NVRAM, resetting PMU, but to no relief.
    I will be calling applecare once more I think.

    Rudi
  • 12. Re: HELP: USB NOT WORKING
    DrBruce Level 1 Level 1 (0 points)
    I purchased a 15 inch Powerbook from Orlando Apple Store, Millenia Mall in December, 2005. Went to my room (I was on vacation) and found the USB ports would recognize a flashdrive but not an external USB hard drive or my Nano ipod. I took it back the next evening and the tech told me there was no problem.
    I took the computer home and when I returned to a city with an Apple store, I took it in. The Genius Bar guy checked out the USB ports and this time, I brought the offending hard drives with me. He could get them to work on all the powerbooks around him, but not on mine. Then he went into the back office three times apparently talking to someone more knowledgeable than he. Then, he came out and told me my powerbook was "normal". That this was expected behavior on the 15 inch powerbook! I said since when does a Nano iPod not mount on a powerbook and why is this considered normal to which he shrugged.
    So, now I'm stuck with a brand new 15 inch powerbook that won't even mount an external USB hard drive or my Nano iPod. In fact, the genius bar guy suggested I purchase the PCMCIA USB 2.0 cardbus available in the store. I did and when I got back to my room and put it into the slot, it wouldn't work, either!
    I thought Apple was known for its outstanding support but so far it has left me in the dust with a powerbook that doesn't work properly. And, I'm out another $50 on a cardbus card that doesn't work.
  • 13. Re: HELP: USB NOT WORKING
    Anthony Buangan Level 1 Level 1 (15 points)
    Same problem here. Left USB port is not working. I plug in my Sandisk Cruzer drive and its drawing power from the USB port but it's not mounting the drive. I also tried connecting an external keyboard to the port and that doesn't work either. Checked system profiler and the USB drive isn't listed.

    Is it time to bring it in to the Apple Store?
  • 14. Re: HELP: USB NOT WORKING
    Dale McGraw1 Level 1 Level 1 (140 points)
    It sounds as if you are not drawing enough power from the USB bus. Are you connecting a portable hard drive (bus powered) or are you plugged in to an external power source? If your hard drive is of the "portable" flavor (bus powered) it will not mount. There is not enough power on the bus to support the USB drive. Even some PC laptops are plagued with this problem. I purchased a SmartDisk 40GB USB hard drive not too long ago, and the supplied manuals even stated that if your computer is not mounting the disk, you have to plug in the supplied PS/2 adapter to give it juice. PS/2 non-existent on Apple computers (obviously) so I had to take the thing back for a refund. I replaced it with a Firewire 400 portable HD and it works fine. As far as the iPod not mounting, I can't answer that question fully, but it sounds like that your USB hub is losing some power somewhere down the pipeline.
1 2 Previous Next