Skip navigation

Macbook Air Extremely Slow Wireless

142482 Views 103 Replies Latest reply: Mar 17, 2014 1:21 PM by cyranodesale RSS
1 2 3 ... 7 Previous Next
Bpasdar Calculating status...
Currently Being Moderated
Nov 6, 2010 4:14 AM
Hello All,

Got my brand new MB-Air and from the get-go noticed extremely slow wireless performance. I did a bit of digging and here is what I found.

The MB-Air works OK with cheap (consumer) wireless APs, however when used in conjunction with the commercial APs most of which use the Atheros chipset the performance is horrible. I found that when connecting to APs that use Atheros' commercial chipset, the MB-Air connects with 802.11 G specs instead of N even when the signal metrics are excellent such as -39 RSSI.

Moreover, even With the 802.11 G connection at 54Mbps the performance is both sluggish and latent. Small file transfers have a 50/50 shot at working and large file transfers seem to die reliably. Albeit this could be an issue with Apple's implementation of SMB / Samba which is rather poor.

I have tried to turn off Bluetooth to see if my experience is different. We'll see.

I would be interested in feedback from people who are also experiencing the same poor wireless performance to learn the chipset of the AP they are having issues with.

By-the-way -- I will take a fix, if someone has come up with one. However my guess is that this is an engineering issue that Apple has to fix.

BP
Macbook Air Late 2010, Mac OS X (10.6.4)
  • Xav8tor Calculating status...
    Currently Being Moderated
    Nov 6, 2010 6:42 AM (in response to Bpasdar)
    My experience has been the exact opposite. I have four other PC's, two top of the line, and none give me the wireless performance of my MBA, which I have carried all over and connected on a wide variety on networks, some huge public facilities. At home, my Air achieves published AT&T download/upload speeds while my PC's are running well if they get half that. Large downloads up to almost 1GB have been fast with no hiccups. I can't explain the difference, but I can sure see it. I do have BT turned off.
    Macbook Air 11" 1.6 Ghz, 4 GB RAM, 128 GB SSD, Mac OS X (10.6.4), iPhone 4
  • Xav8tor Level 1 Level 1 (50 points)
    Currently Being Moderated
    Nov 6, 2010 7:50 AM (in response to Bpasdar)
    Nope, I get similar fast results using the wireless network at a 1,000 bed medical complex that spans about 8 city blocks. I doubt that is a consumer grade setup. I'd take it in to an Apple store and have a diagnostic run on it if it is so slow. That just doesn't sound right. Apple is now targeting Fortune 500 companies too (with great success)and I can't see how they would put out a product like this that would not play nice in that environment.
    Macbook Air 11" 1.6 Ghz, 4 GB RAM, 128 GB SSD, Mac OS X (10.6.4), iPhone 4
  • ESanchez Calculating status...
    Currently Being Moderated
    Nov 6, 2010 9:51 PM (in response to Bpasdar)
    I was having the same problem and it turned out to be my WiFi's channel - it didn't like the "automatic" setting on my Time Capsule. Switched to channel 6 and now my Air speed is fine.
    MacBook Air 11", Mac OS X (10.6.4), 4GB RAM, 64GB
  • ppaulojr Calculating status...
    Currently Being Moderated
    Nov 11, 2010 6:54 AM (in response to Bpasdar)
    Mini is a brand new Macbook 7,1 and I have tried several AP with or without WEP, WPA, WPA2 and Multiple channels from 1 to 13

    The results are disappointing: 0.55Mb/s download and 0.13Mb/s download in SpeedTest.net

    We have a 100Mb/s connection here!
    Macbook 2.4Ghz Core2Duo 7,1, Mac OS X (10.6.4)
  • Matt Madison Calculating status...
    Currently Being Moderated
    Nov 13, 2010 12:39 PM (in response to ESanchez)
    This seems to have done the trick for me, too - manually selecting the channels on my Airport Extreme makes my new Air's wireless much more reliable.
    iMac, MB Air, Mac OS X (10.6.5)
  • CereS2010 Calculating status...
    Currently Being Moderated
    Nov 13, 2010 2:12 PM (in response to Matt Madison)
    Selecting a fixed channel worked here too, on a FritzBox Wireless Router.
    Before i had like one reconnect every 1-2 Minutes.

    Thanks for the hint,

    Regards,
    C.
    MBA 2010, MBA 2008, MacMini Core2, Mac OS X (10.6.5), Lenovo Thinkpad T61, iPod Touch 16 GB, soon iPhone 4 32GB
  • wifiguru Level 2 Level 2 (230 points)
    Currently Being Moderated
    Nov 21, 2010 8:15 PM (in response to Bpasdar)
    Bpasdar,
    A large number of Dlink AP's/Belkin/Netgear AP's use the Atheros chipset and the Mac works well with most of them.
    What AP model are you using ? Is it a Wi-Fi Certified AP and if you are using 11n, is it draft 2.0 or newer ?
    What security are you using ? Mac's won't do WEP in 802.11n mode, only Open and WPA2
    Mac OS X (10.6.4), 11"/13" MBA, 13"/15" 2010 MBP, All iOS devices
  • James_Gentry Calculating status...
    Currently Being Moderated
    Nov 27, 2010 5:25 PM (in response to Matt Madison)
    What do you mean by change the channel? I have an Imac and new MBA and an Airport Extreme wifi router. On the iMac I'm getting over 20 mb/s (wired connection), on my MBA less than 3 mb/s, and on my iphone 12 mb/s. The MBA is definitely SLOW. How do I change the channel on the extreme? Any additional suggestions?
    iMac, iPhone 8g, Mac OS X (10.4.10)
  • William Kucharski Level 6 Level 6 (14,395 points)
    Currently Being Moderated
    Nov 29, 2010 9:53 PM (in response to James_Gentry)
    James_Gentry wrote:
    How do I change the channel on the extreme? Any additional suggestions?


    Start the AirPort Utility, select your AirPort Extreme in the left side bar, then click the "Manual Setup" button at the bottom of the main window.

    Click on the "AirPort" icon at the top of the window and on the "Wireless" tab.

    Change the channel from "Automatic" to 1, 6 or 11, then click "Update" and allow your AirPort Express to reboot and see if your throughput improves.
    15" 2.6 GHz MBP Penryn, 4 GB | 64GB 3G iPad | 1 TB Dual-Band TC, Mac OS X (10.6.5)
  • MCDUFFY Calculating status...
    Currently Being Moderated
    Jan 21, 2011 9:13 AM (in response to William Kucharski)
    This did the trick for me as well on my new MB Air. However, I had to play around with a few different channel changes before the WiFi connection started running as it should. Obviously would be better if this problem didn't exist at all (resulted in about 30 mins of frustration before I found this forum), but fixed nonetheless.

    Thanks for the help -
    MB Air, Mac OS X (10.6.6)
  • rtdunham Level 2 Level 2 (325 points)
    Currently Being Moderated
    Feb 14, 2011 8:14 PM (in response to William Kucharski)
    Sitting side-by-side, my MBA was averaging less than 1 Mb/s on downloads, and my MBP more than 9 Mb/s. The MBP was fully ten times faster. As you can imagine, viewing videos was a ragged, unpleasant experience on the MBA.
    I'm using an early wireless-N Belkin router, so it didn't show up on airport utility, thus i couldn't change channels there as proposed on this thread. But to isolate the problem, at my brother's suggestion i took both computers to a Starbucks, and observed the two computers downloading there at equal speeds. So clearly the problem wasn't with my MBA, but my router.
    I went to Belkin's website to figure out how to change channels on the router, and checked for firmware updates. There was one, so i figured I'd do that before attacking the "changing channels" task. I upgraded the firmware, and with that simple fix my MBA is happily zipping along now with >9 Mb/s downloads, same as the MBP. More than TEN times faster than before. My iPhone download speeds increased more than tenfold, too.
    My advice, if you're having wireless problems with your MBA: First make sure your router's running the latest firmware.
    13" MBP, 11" MBA, iPhone4, Mac OS X (10.6.6)
  • sharly09 Calculating status...
    Currently Being Moderated
    Mar 11, 2011 4:47 PM (in response to Bpasdar)
    hi.

    I just bought a MB Air 11" and the wifi was extremely slow too. I turned off bluetooth and now it is very fast! (42 MB download / 3.66 MB upload)

    regards
    mac air 11
  • robdale Calculating status...
    Currently Being Moderated
    Mar 31, 2011 7:01 AM (in response to sharly09)
    Well, looks like that worked for me as well. As soon as I turned off bluetooth, the wireless speed jumped from 0.98mb/s download to 8.15mb/s

    Hope Apple will come up with a fix for this since I was using a bluetooth keyboard and mouse (Apple).
    MacBook Pro, Mac OS X (10.5.6)
1 2 3 ... 7 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.