8 Replies Latest reply: Mar 17, 2011 12:16 PM by droneprime
Wayne Stuart Level 1 Level 1 (0 points)
Cupertino, we have a problem...

Today, I attempted to install Windows 7 on my 2008 Macbook Pro via Boot Camp. All seemed to go okay to a point, but now it's all gone very wrong. All I get is a black screen with a flashing cursor.

The story goes I booted the Windows 7 DVD via Boot Camp assistant, and it seemed to install. It got to the point where it says it needs to restart to continue the installation, which it did. I then got a message that I need to hit any key to boot the DVD, but the keyboard wasn't recognised, so I had no choice but to switch it off and on again. Now it just freezes with a black screen and a flashing cursor when booting anything Windows.

Neither the Windows partition nor the installation DVD will boot. Even my old XP installation DVD won't boot anymore. Nothing BIOS based seems to boot. Only OS X boots now.

I see something similar was being suffered by a fair few folk in an old thread here...

http://discussions.apple.com/thread.jspa?threadID=1448291

...but none of the suggestions here have worked for me. Any more suggestions? Anyone else still suffering with this?

Thanks.

MacBook Pro 2.4GHz, Mac OS X (10.6.4)
  • Wayne Stuart Level 1 Level 1 (0 points)
    Okay, I'm not sure what I did exactly, but after many switchings off and switchings on, I finally got the W7 install DVD to boot again. From there, wiped the partition and started from scratch. W7 now installed and working... as well as Windows can work at least.

    Strange why it happened though. Little bug in the BIOS extension somewhere perhaps?
  • MILxDOT Level 1 Level 1 (0 points)
    I had this same problem. Spent an entire weekend on it then physically took it to the apple store and they couldn't fix it either.

    Finally, I dug deep and dig a bunch of research and came up with this fix!

    To fix:
    Open Terminal.app,
    at the prompt type:
    sudo bless --folder /System/Library/Coreservices --bootefi
    (press return, enter your admin password, press return again)

    Hope this helps other people.

    Seems to have been and efi boot issue.
  • MILxDOT Level 1 Level 1 (0 points)
    After further investigation of this blinking cursor during boot camp - boot from windows dvd issue (or Ubuntu CD from my experience), I found that the only way that I could get any media other than snow leopard to boot reliably, I had to remove one of the 2 x 2GB memory modules (4GB total) and then zap the NVRAM/PRAM using cmd-opt-p-r. I originally purchased the macbook pro with 2 x 1GB modules (2GB total). I have a feeling that this issue also has something to do with the recent SMC firmware update that recently came out for this early 2008 macbook pro model 4,1. I am confident there is nothing wrong with the memory...I have been using this macbook pro for 9 months now since I upgraded to 4GB. Plus, if I only ran Mac OS X and not windows or ubuntu, I wouldn't have even had this little hurdle to jump. Hope this saves others hours of pulling out their hair.
  • Mike Ewing Level 2 Level 2 (220 points)
    Thanks MILxDOT. I tried reverting my ram to the 2 gb (2 x 1gb) that it came with and the XP installer ran. I had upgraded my ram to 5gb (1gb + 4gb) in my iMac.
    Question... Will I be able to reinstall the extra ram and use it after i get Windows installed properly? I hope so Or I'll have to abandon BootCamp.

    Now the installer goes all the way until it reads 33 min remaining and then it seems to stall. I even left it overnight (6 hrs) and it didn't go any further. the "Windows is great with all these features" editorial text keeps changing out and the blinking progress boxes in the lower right keep going but no cd or hard drive activity seem to be going on.

    I did recreate the BootCamp partition and start again only to have the same problem.

    Got past one point, now more problems. Any thoughts.
  • Needaf1x Level 1 Level 1 (0 points)
    Hi guys,

    I am also having a black screen with flashing cursor issue! I select 'install' in Bootcamp, my iMac reboots and then I get nothing but a flashing cursor.

    I did find this thread: http://discussions.apple.com/thread.jspa?threadID=1514700&start=0&tstart=0

    where people found that by pulling the power plug to reset the power manager worked, but it isn't making any difference for me!

    MILxDOT, I am worried that it could well be a memory issue. My iMac was originally 2GB, which I then upgraded to 4GB. However I have sold my original memory so can't revert back to the 2x 1GB sticks!

    You originally posted a fix using Terminal. Do you still stand by this? I ask as the next day you posted about the memory stuff.

    Hopefully someone can help!

    Thanks

    Mark
  • Needaf1x Level 1 Level 1 (0 points)
    MILxDOT, thank you very much for your discovery!

    I could not get passed the flashing cursor at all. In the end I thought what the **** and removed one of my 2GB memory sticks, leaving me with 2GB as per my original iMac spec. Turned the iMac back on and it instantly went into the Windows 7 setup!!!!

    What a bizarre problem and fix!!

    Thanks again!
  • Fabiano F Level 1 Level 1 (0 points)
    WORKS!

    In mid 2009 (I think) I had my macbook pro running Windows_7RC1 with no problem at all in bootcamp, under Leopard.
    Then I bought the Win764Pro, Snow Leopard and 4GB of RAM.
    Installed the RAM, OSX and when I tried to install windows I got nothing, just the stupid blinking screen. Tried my old WinXP disc...nothing, tried the RC1 disc...nothing, tried to take my laptop to dinner several times, but still the machine would not let me install windows.
    The only solution was to get a copy of VMWare_Fusion and run it from there. Problem for me was my need to run heavy 3D app's on native mode in Windows to get the full strength of the video card.
    You have no idea how many voodoo tricks I tried (including a trip to the apple store) and finally after all this time it worked.

    Don't know which one did the trick. The SUDO command or re-installing the original memory, I did them one after the other and it worked 1st time I booted.
    Installed Windows 7 64 on bootcamp. Put the 4Gb of memory back and got no more problems.

    Major thanks for the solution.
    Appreciate it.
    F.

    Message was edited by: Fabiano F
  • droneprime Level 1 Level 1 (0 points)
    I didn't want to create an account on this forum. However, I went through the trouble just to let you know that your concise response really helped me. In a thread with so much finger pointing, you provided me with a simple command line solution to a problem that had been plaguing my install procedure for weeks.

    I just wanted to say thanks, and keep up the good work.

    P.S. How did you know about the 'bless' command? They don't have this utility in *nix.