Previous 1 2 Next 15 Replies Latest reply: Dec 29, 2010 1:15 PM by Gary Hood
Ed Colman Level 1 Level 1 (0 points)

This is more a software question. I transferred QuickBook files from a PC to my Mac. I can run QB for Mac easily, but the transfer left a locked .qbw file on my desktop. I think this is a QB backup for Windows file. I am trying to delete it but can't because it is locked. I tried to delete from within QB, but can't. It is no big deal, but I would love to get it off my Desktop. Any ideas? I tried to contact Intuit, but they require an Intuit ID which I don't have. Thanks.

Mac Book Pro 2.66
  • leroydouglas Level 6 Level 6 (15,865 points)
    How about if you highlite the rouge file and command-i for the info pane. Unlock the lock in lower right and change permissions to read write. Delete.

    Message was edited by: leroydouglas
  • Ed Colman Level 1 Level 1 (0 points)
    I tried this. In sharing and permissions In the list of users am listed as being able to read and write, but no execute. However above the user list is a message that I can only read. I am also not able to unlock it in the "general" section either. Thanks for the idea. I am now contacting an Intuit discussion group to see if they have any ideas. I will post results.
  • leroydouglas Level 6 Level 6 (15,865 points)
    At the top end of this info pane General: make sure the Locked box is not checked.
  • Ed Colman Level 1 Level 1 (0 points)
    The Locked box is checked but it is greyed out and I cannot uncheck it. A real conundrum.
  • leroydouglas Level 6 Level 6 (15,865 points)
    What is the exact name of this locked file, or is it a folder? And how was the file transfer to your Mac desktop?

    Message was edited by: leroydouglas
  • Ed Colman Level 1 Level 1 (0 points)
    It is called SuperDailies.qbw. It is a backup file of a Company from QuickBooks for PC. I transferred the files from a PC hard drive to my old Mac when the PC died. I installed QB 2007 for Mac in order to use the Company file to keep track of my business. The .qbw appeared along with other files when I transferred the data to the Mac. I have tried to open it with QB for Mac, but it cannot open a Windows backup.
  • leroydouglas Level 6 Level 6 (15,865 points)
    Ok Ed Colman lets try this:

    deleting locked files

    1. Open Terminal. It's located in your /Applications/Utilities.

    Paste the following command:

    *chflags -R nouchg*

    Note: Type one space (not pictured) after nouchg in the line above, so that it ends in "nouchg ". Do not press Return yet.

    2. Drag the files from the desktop to the Terminal window.

    Note: This automatically enters the pathname for file/folder.

    3. Press Return. No special text message will be shown indicating that the command was successful.
    This should unlock hidden flags in directory and subdirectories /file that you can not get to.

    4. Exit to terminate terminal session then quit as normal.

    5.Delete rouge file as normal, empty trash or secure empty trash.

    Message was edited by: leroydouglas
  • Ed Colman Level 1 Level 1 (0 points)
    First of all, thank you for your time in trying to solve this. I did as you suggested and got a "permission denied" message after the file name. Tough one. So far no response from the Intuit discussion list. I might have to install Windows XP via Boot Camp, install the QB for Windows (if I can find the disks) and try to do it from there. I'd prefer not to have to go that route as I don't really need Windows on this machine. Thanks again.
  • leroydouglas Level 6 Level 6 (15,865 points)
    We can go the next step. It requires switching to single-user mode and then changing the flags as root.

    You can get the command sequence example here:

    I might suggest you print out for reference (include your rouge file,) when you are booted in single user mode.

    Report back, good luck I hope this is helpful if not problem solved.

    You can read through this reference as well:

    Message was edited by: leroydouglas
  • Ed Colman Level 1 Level 1 (0 points)
    This is as far as I got: I got a heavy Warning message before entering my password. I did and got the following:

    Ed-Colmans-MacBook-Pro:~ edcolman$ sudo shutdown now
    shutdown: -h, -r, -s, or -k is required
    usage: shutdown [-] [-h [-u] [-n] | -r [-n] | -s | -k] time [warning-message ...]
    Ed-Colmans-MacBook-Pro:~ edcolman$

    Couldn't execute the su command.
  • leroydouglas Level 6 Level 6 (15,865 points)
    Yes a flag needs to be included with the shutdown command.

    I would like to send you over to the Unix forum for more decisive information about the process and help, you can post your new question there.

    Hope this helps
  • Ed Colman Level 1 Level 1 (0 points)
    Thanks again for your patience on a Sunday afternoon. I'll let you know how it goes. It all depends on how brave I am playing with the Terminal commands. If you scroll down to the article you referred me to, there are several comments to the effect that the command string doesn't really work anyway. I might just have to live with this little file. We'll see. Have a great afternoon and thank for your help with my other questions.
  • Ed Colman Level 1 Level 1 (0 points)
    Here is the solution:

    Open Terminal (Application->Utilities->Terminal, then
    1) enter "sudo rm -i ",
    2) then drag the file into the Terminal window (this is a shortcut to typing the files path),
    3) then press enter
    4) enter your password
    5) if the file is indeed the one you want deleted, then enter "y' (this deletion cannot be undone)

    This is from Tony T1 on the Unix discussion.
    Worked perfectly. Took 30 seconds. Thanks for all the help.
  • leroydouglas Level 6 Level 6 (15,865 points)
    Ed Colman thanks for the report, I am glad all this was helpful in getting to your final resolve. Good computing.
Previous 1 2 Next